Winsock 控件

Winsock 控件对用户来说是不可见的，它提供了访问 TCP 和 UDP 网络服务的方便途径。Microsoft Access、Visual Basic、Visual C++ 或 Visual FoxPro 的开发人员都可使用它。为编写客户或服务器应用程序，不必了解 TCP 的细节或调用低级的 Winsock APIs。通过设置控件的属性并调用其方法就可轻易连接到一台远程机器上去，并且还可双向交换数据。

TCP 基础

数据传输协议允许创建和维护与远程计算机的连接。连接两台计算机就可彼此进行数据传输。

如果创建客户应用程序，就必须知道服务器计算机名或者 IP 地址（RemoteHost 属性），还要知道进行“侦听”的端口（RemotePort 属性），然后调用 Connect 方法。

如果创建服务器应用程序，就应设置一个收听端口（LocalPort 属性）并调用 Listen 方法。当客户计算机需要连接时就会发生 ConnectionRequest 事件。为了完成连接，可调用 ConnectionRequest 事件内的 Accept 方法。

建立连接后，任何一方计算机都可以收发数据。为了发送数据，可调用 SendData 方法。当接收数据时会发生 DataArrival 事件。调用 DataArrival 事件内的 GetData 方法就可获取数据。

UDP 基础

用户数据文报协议 (UDP) 是一个无连接协议。跟 TCP 的操作不同，计算机并不建立连接。另外 UDP 应用程序可以是客户机，也可以是服务器。

为了传输数据，首先要设置客户计算机的 LocalPort 属性。然后，服务器计算机只需将 RemoteHost 设置为客户计算机的 Internet 地址，并将 RemotePort 属性设置为跟客户计算机的 LocalPort 属性相同的端口，并调用 SendData 方法来着手发送信息。于是，客户计算机使用 DataArrival 事件内的 GetData 方法来获取已发送的信息。


Topic Not Found

未找到该主题

未找到相匹配的主题。可能的原因和解决方法如下：

  • 包含目标主题的文件 (.chm) 没有位于指定的位置。

    解决方法：重新运行 MSDN Library的安装。

  • 包含当前主题或目标主题的文件 (.chm) 已经过时，并且链接不再有效。

    解决方法：安装最新版本的 MSDN Library。

  • MSDN Library CD 不在 CD-ROM 中。

    解决方法：将 MSDN Library CD 装入 CD-ROM 中。


Close 事件

当远程计算机关闭连接时出现。应用程序应正确使用 Close 方法关闭 TCP 连接。

语法

object_Close( )

object 所在处代表一个对象表达式，其值是“应用于”列表中的对象。

参数

None


Connect 事件 （Winsock 控件）

当一个 Connect 操作完成时发生。

语法

object.Connect()

object 所在处代表一个对象表达式，其值是一个 Winsock 控件。

说明

使用 Connect 事件确认已经成功建立了一个连接。


ConnectionRequest 事件

当远程计算机请求连接时出现。

  • 仅适用于 TCP 服务器应用程序。在请求一个新连接时激活该事件。激活事件之后，RemoteHostIP 和 RemotePort 属性存储有关客户的信息。

语法

object_ConnectionRequest (requestID As Long)

ConnectionRequest 的语法有包含下面部分：

部分 | 描述
object | 对象表达式，其值是“应用于”列表中的对象。
requestID | 新连接请求标识。应把此参数传递给第二个控件示例上的 Accept 方法。

说明

服务器可决定是否接受连接。如果不接受新连接，则同级人员（客户）将得到 Close 事件。（在一个新控件示例上）用 Accept 方法接受新连接。


DataArrival 事件

当新数据到达时出现。

语法

object_DataArrival (bytesTotal As Long)

DataArrival 事件的语法包含下面部分：

部分 | 描述
object | 对象表达式，其值是“应用于”列表中的对象。
bytesTotal | Long。可获取的数据总数量。

说明

如果没有获取一个 GetData 调用中的全部数据，则事件不会出现。只有存在新数据时才激活事件。可随时用 BytesReceived 属性检查可用的数据量。


Error 事件 （Winsock 控件）

无论何时，只要后台处理中出现错误（例如，连接失败，或者在后台收发数据失败）事件就会出现。

语法

object_Error(number As Integer, Description As String, Scode As Long, Source As String, HelpFile as String, HelpContext As Long, CancelDisplay As Boolean)

Error 事件的语法包含下面部分：

部分 | 描述
object | 对象表达式，其值是“应用于”列表中的对象。
number | 定义错误代码的整数。请参阅下述有关常数的“设置值”。
description | 包含错误信息的字符串。
Scode | 长 SCODE
Source | 描述错误来源的字符串。
HelpFile | 包含帮助文件名的字符串。
HelpContext | Help 文件上下文。
CancelDisplay | 指示是否取消显示。缺省值为 False，以此显示缺省的错误信息框。如果不想使用缺省的信息框，则将 CancelDisplay 设置成 True。

设置值

number 的设置值是：

常数 | 值 | 描述
sckOutOfMemory | 7 | 内存不足
sckInvalidPropertyValue | 380 | 属性值无效。
sckGetNotSupported | 394 | 属性不可读。
sckSetNotSupported | 383 | 属性是只读的。
sckBadState | 40006 | 所请求的事务或请求本身的错误协议或者错误连接状态。
sckInvalidArg | 40014 | 传递给函数的参数格式不确定，或者不在指定范围内。
sckSuccess | 40017 | 成功。
sckUnsupported | 40018 | 不受支持的变量类型。
sckInvalidOp | 40020 | 在当前状态下的无效操作
sckOutOfRange | 40021 | 参数越界。
sckWrongProtocol | 40026 | 所请求的事务或请求本身的错误协议
sckOpCanceled | 1004 | 取消操作。
sckInvalidArgument | 10014 | 所请求的地址是广播地址，但未设置标记。
sckWouldBlock | 10035 | 套接字不成块，而指定操作将使之成块。
sckInProgress | 10036 | 制造块的 Winsock 操作在进行之中。
sckAlreadyComplete | 10037 | 完成操作。未进行制造块的操作。
sckNotSocket | 10038 | 描述符不是套接字。
sckMsgTooBig | 10040 | 数据报太大，不适于缓冲区的要求，因而被截断。
sckPortNotSupported | 10043 | 不支持指定的端口。
sckAddressInUse | 10048 | 地址在使用中。
sckAddressNotAvailable | 10049 | 来自本地机器的不可用地址。
sckNetworkSubsystemFailed | 10050 | 网络子系统失败。
sckNetworkUnreachable | 10051 | 此时不能从主机到达网络。
sckNetReset | 10052 | 在设置 SO_KEEPALIVE 时连接超时。
sckConnectAborted | 11053 | 由于超时或者其它失败而中止连接。
sckConnectionReset | 10054 | 通过远端重新设置连接。
sckNoBufferSpace | 10055 | 没有可用的缓冲空间。
sckAlreadyConnected | 10056 | 已连接套接字。
sckNotConnected | 10057 | 未连接套接字。
sckSocketShutdown | 10058 | 已关闭套接字。
sckTimedout | 10060 | 已关闭套接字。
sckConnectionRefused | 10061 | 强行拒绝连接。
sckNotInitialized | 10093 | 应首先调用 WinsockInit。
sckHostNotFound | 11001 | 授权应答：未找到主机。
sckHostNotFoundTryAgain | 11002 | 非授权应答：未找到主机。
sckNonRecoverableError | 11003 | 不可恢复的错误。
sckNoData | 11004 | 无效名，对所请求的类型无数据记录。


SendComplete 事件

在完成一个发送操作时出现。

语法

object_SendComplete

object 所在处代表一个对象表达式，其值是“应用于”列表中的对象。

参数

None


SendProgress 事件

在发送数据期间出现。

语法

object_SendProgress (bytesSent As Long, bytesRemaining As Long)

SendProgress 事件的语法包含下面部分：

部分 | 描述
object | 对象表达式，其值是“应用于”列表中的对象。
bytesSent | 从上次激活事件以来已发送的字节数。
bytesRemaining | 在发送缓冲区等待发送时的字节数。


Accept 方法

仅适用于 TCP 服务器应用程序。在处理 ConnectionRequest 事件时用这个方法接受新连接。

语法

object.Accept requestID

object 所在处代表对象表达式，其值是“应用于”列表中的对象。

数据类型

Long

返回值

Void

说明

在 ConnectionRequest 事件中使用 Accept 方法。ConnectionRequest 事件有一个对应的参数，即 RequestID 参数，该参数应该传给 Accept 方法。请看下例：

Private Sub Winsock1_ConnectionRequest _
(ByVal requestID As Long)
   '测试 State 属性，如果当前连接是打开的话，
   '则关闭连接。
   If Winsock1.State <> sckClosed Then Winsock1.Close

   '将 requestID 参数值传递给 Accept 方法。
   Winsock1.Accept requestID
End Sub

应该在新的控件示例（不是侦听状态下的示例）中使用 Accept 方法。


Accept 方法，ConnectionRequest 事件示例

该示例显示了用 TCP 协议连接 Winsock 控件所需代码。代码在接受连接请求的机器上运行。用 RequestID 参数识别请求。将该参数传递给接受特定请求的 Accept 方法。

Private Sub WinsockTCP_ConnectionRequest _
(requestID As Long)
   If Winsock1.State <> sckClosed Then Winsock1.Close
   Winsock.Accept requestID
End Sub


Bind 方法

指定用于 TCP 连接的 LocalPort 和 LocalIP。如果有多协议适配卡，就用这个方法。

语法

object.Bind LocalPort, LocalIP

Bind 方法的语法包含下面部分

部分 | 描述
object | 对象表达式，其值是“应用于”列表中的对象。
LocalPort | 用来建立连接的端口。
LocalIP | 用来建立连接的本地 Internet 地址。

说明

在调用 Listen 方法之前必须调用 Bind 方法。


Close 方法（Winsock 控件）

对客户机和服务器应用程序关闭 TCP 连接或侦听套接字。

语法

object.Close

object 所在处代表对象表达式，其值是“应用于”列表中的对象。

参数

None

返回值

Void


Connect 方法

要求连接到远程计算机。

语法

object.Connect remoteHost, remotePort

Connect 方法的语法具有以下几个部分

部分 | 描述
object | 对象表达式，其值为“应用于”列表中的对象。
remoteHost | 必需的。要连接的远程计算机的名称。
remotePort | 要连接的远程计算机的端口。

返回值

无

说明

在想建立 TCP 连接时，必须调用 Connect 方法。


GetData 方法（Winsock 控件）、DataArrival 事件示例

该示例使用 Winsock 控件的 DataArrival 事件中的 GetData 方法。当事件出现时，代码调用 GetData 方法获取数据，并将数据存储在字符串变量中。于是就将数据写到一个 TextBox 控件中。

Private Sub Winsock1_DataArrival _
(ByVal bytesTotal As Long)
   Dim strData As String
   Winsock1.GetData strData, vbString
   Text1.Text = Text1.Text & strData
End Sub


GetData 方法（Winsock 控件）

获取当前的数据块并将其存储在变体类型的变量中。

返回值

Void

语法

object.GetData data, [type,] [maxLen]

GetData 方法的语法包含下面部分：

部分 | 描述
object | 对象表达式，其值是“应用于”列表中的对象。
data | 在方法成功返回之后存储获取数据的地方。如果对请求的类型没有足够可用的数据，则将 data 设置成 Empty。
type | 可选的。获取的数据类型，如下例“设置值”所示。
maxLen | 可选的。在接收到字节数组或字符串时所需大小。如果对字节数组或字符串、参数丢失、则将获取所有可用数据。如果提供的数据类型不是字节数组或字符串，则忽略这个参数。

设置值

type 的设置值是：

描述 | 常数
Byte | vbByte
Integer | vbInteger
Long | vbLong
Single | vbSingle
Double | vbDouble
Currency | vbCurrency
Date | vbDate
Boolean | vbBoolean
SCODE | vbError
String | vbString
Byte Array | vbArray + vbByte

说明

通常总是将 GetData 方法与 DataArrival 事件并用，而 DataArrival 事件包含 totalBytes 参数。如果指定一个比 totalBytes 参数小的 maxlen，则将得到警告 10040，以此指出剩余的字节将丢失。


Listen 方法

创建套接字并将其设置为侦听模式。该方法仅适用于 TCP 连接。

语法

object.Listen

object 所在处代表一个对象表达式，其值是“应用于”列表中的对象。

参数

None

返回值

Void

说明

当有新连接时就会出现 ConnectionRequest 事件。处理 ConnectionRequest 事件时，应用程序应该（在一个新的控件示例上）用 Accept 方法接受连接。


PeekData 方法

PeekData 不从输入队列删除数据，除了这一点之外，方法与 GetData 相似。该方法仅适用于 TCP 连接。

语法

object.PeekData data, [type,] [maxLen]

PeekData 方法的语法包含下面部分：

部分 | 描述
object | 对象表达式，其值是“应用于”列表中的对象。
data | 在方法成功地返回之后存储获取的数据。如果对于没有足够的适于所请求的类型来说没有足够可用的数据，那么 data 将被设置为 Empty。
type | 可选的。所获取的数据类型，如同“设置值”中所述。缺省值为：vbArray + vbByte。
maxLen | 可选的。在收到字节数组或字符串时，长度指定了所需要的大小。如果对字节数组或字符串的参数丢失，则将获取所有可用的数据。如果提供的数据类型不是字节数组和字符串的话，则忽略该参数。

设置值

type 的设置值是：

类型 | 常数
Byte | vbByte
Integer | vbInteger
Long | vbLong
Single | vbSingle
Double | vbDouble
Currency | vbCurrency
Date | vbDate
Boolean | vbBoolean
SCODE | vbError
String | vbString
Byte Array | vbArray + vbByte

返回值

Void

说明

如果所指定的类型为 vbString，则在返回到用户之前，字符串数据将转化成 UNICODE。


SendData 方法

将数据发送给远程计算机。

返回值

Void

语法

object.SendData data

SendData 方法的语法有下面这些部分：

部分 | 描述
object | 对象表达式，其值是“应用于”列表中的对象。
data | 要发送的数据。对于二进制数据应使用字节数组。

说明

当传进 UNICODE 字符串并在网络上发送出去之前，将转化成 ANSI 字符串。


BytesReceived 属性

返回接收到的（当前在接收端缓冲区内的）数据的数量。使用 GetData 方法来获取数据。

在设计时是只读的，而且是不可用的。

语法

object.BytesReceived

object 所在处代表一个对象表达式，其值是“应用于”列表中的对象。

返回值

Long


LocalHostName 属性

返回本地机器名。在设计时是只读的，而且是不可用的。

语法

object.LocalHostName

object 所在处代表一个对象表达式，其值是“应用于”列表中的对象。

返回值

String


LocalIP 属性

返回本地机器的 IP 地址，格式是 IP 地址加点字符串 (xxx.xxx.xxx.xxx)。在设计时是只读的，而且是不可用的。

语法

object.LocalIP

object 所在处代表一个对象表达式，其值是“应用于”列表中的对象。

数据类型

String


LocalPort 属性

返回或者设置所用到的本地端口。在设计时是可读/写的，而且是可用的。

  • 对客户来说，该属性指定发送数据的本地端口。如果应用程序不需要特定端口，则指定 0 为端口号。在这种情况下，控件将选择一个随机端口。在建立起连接之后，这就是用于 TCP 连接的本地端口。

  • 对于服务器来说，这是用于侦听的本地端口。如果指定的是端口 0，就使用一个随机端口。在调用了 Listen 方法后，属性就包含了已选定的实际端口。

语法

object.LocalPort = long

object 所在处代表一个对象表达式，其值是“应用于”列表中的对象。

数据类型

Long

说明

在计算机之间常用端口 0 来动态地建立连接。例如，一个客户希望服务器给他“回电话”，它就可用端口 0 获得新的（随机）端口号，然后将该端口号交给远程计算机，从而达到目的。


Protocol 属性（Winsock 控件）

返回或设置 Winsock 控件所使用的协议— 或者是 TCP，或者是 UDP。

语法

object.Protocol [=protocol]

object 所在处代表一个对象表达式，其值是“应用于”列表中的对象。

设置值

protocol 的设置值是：

常数 | 值 | 描述
sckTCPProtocol | 0 | 缺省的。TCP 协议。
sckUDPProtocol | 1 | UDP 协议。

返回值

Void

说明

在能够重新设置属性之前必须（用 Close 方法）关闭控件。


RemoteHostIP 属性

返回远程机器的 IP 地址。

  • 对于客户应用程序来说，已经用 Connect 方法建立连接后，属性就包含了远程机器的 IP 字符串。

  • 对于服务器应用程序来说，在请求连接（ConnectionRequest 事件）之后，属性包含远程计算机的 IP 字符串，该字符串启动了连接。

  • 当使用 UDP 协议时，在 DataArrival 事件出现之后，属性包含了发送 UDP 数据的计算机的 IP 地址。

语法

object.RemoteHostIP

object 所在处代表一个对象表达式，其值是“应用于”列表中的对象。

数据类型

String


SocketHandle 属性

返回一个与套接字句柄对应的值，控件用套接字句柄同 Winsock 层通信。在设计时是只读的，而且是不可用的。

语法

object.SocketHandle

object 所在处代表一个对象表达式，其值是“应用于”列表中的对象。

数据类型

Long

说明

这个属性是为了传递到 Winsock APIs 而设计的。


State 属性（Winsock 控件）

返回控件的状态，用枚举类型来表示。在设计时是只读的，而且是不可用的。

语法

object.State

object 所在处代表一个对象表达式，其值是“应用于”列表中的对象。

数据类型

Integer

设置值

State 属性的设置值是：

常数 | 值 | 描述
sckClosed | 0 | 缺省的。关闭
sckOpen | 1 | 打开
sckListening | 2 | 侦听
sckConnectionPending | 3 | 连接挂起
sckResolvingHost | 4 | 识别主机
sckHostResolved | 5 | 已识别主机
sckConnecting | 6 | 正在连接
sckConnected | 7 | 已连接
sckClosing | 8 | 同级人员正在关闭连接
sckError | 9 | 错误