Animation 控件

Animation 控件允许创建按钮，当单击它时即显示动画，如 .avi 文件。该控件只能播放无声的 AVI 文件。此外，动画控件只能显示未压缩的或已用行程编码 (RLE) 压缩的 .avi 文件。

说明

如果尝试加载含有声音数据或格式不为控件所支持的 .avi 文件，则返回错误（错误 35752）。

在 Windows 95 中，文件复制进度栏就是使用 Animation 控件的一个实例。在执行复制操作时，纸页从一个文件夹“飞”到另一个文件夹。


DateTimePicker控件

DateTimePicker控件使您可以提供格式化的日期字段，使得进行日期选择很容易。另外，用户还可以从类似于MonthView控件的下拉式日历界面中选择日期。

语法

DTPicker

说明

DateTimePicker控件，有两种操作模式：

  • 下拉式日历模式（缺省）—允许用户显示一种能够用来选择日期的下拉式日历。

  • 时间格式模式—允许用户在日期显示中选择一个字段（例如：月、日、年等等），按下控件右边的上下箭头来设置它的值。

可以自定义控件的下拉式日历的外观。使用各种颜色属性，例如CalendarBackColor、CalendarForeColor、CalendarTitleBackColor、CalendarTitleForeColor和CalendarTrailingForeColor，允许创建属于您自己的颜色方案。

可以使用键盘或鼠标对控件进行浏览。下拉式日历有两个按钮使您能够滚动月份数据出入视图。

注意 DateTimePicker控件是ActiveX控件组的一部分，包含在 MSCOMCT2.OCX 文件中。要在应用程序中使用DateTimePicker控件，必须将 MSCOMCT2.OCX 文件加入到工程之中。发布您的应用程序时，要将 MSCOMCT2.OCX 文件装入到用户的Microsoft Windows System或System32目录下。有关如何将ActiveX控件添加到工程之中的更多信息，请参阅Programmer's Guide中的"Adding controls to a Project"。


FlatScrollBar 控件

FlatScrollBar 控件是标准 Windows滚动条的对鼠标敏感版本，它提供平面格式选项。它也可以代替标准 Windows 的立体滚动条。使用滚动箭头和滚动框时，FlatScrollBar 能提供更强的交互性能。

语法

FlatScrollBar

说明

FlatScrollBar 提供三种格式选项。

  • 和Internet Explorer 4.0 中的滚动条看起来一样的平面外观。滚动箭头和滚动条滑块都是对鼠标敏感的；当鼠标指针移动到它们上面时，它们就会改变颜色。

  • 鼠标指针放在上面就变成立体的平面外观。当鼠标指针移动到滚动箭头和滚动条滑块上时，它们就会变成斜面，它仿照了 Microsoft Encarta Encyclopedia中的滚动条外观。

  • 和标准 Windows 的立体滚动条外观相同。立体模式没有鼠标敏感功能。

使用 FlatScrollBar 可以禁用两个滚动箭头之一,这就给用户提供了基于程序中其它因素的附加反馈信息，以作为在特定方向上的滚动指示。。

FlatScrollBar 按照对它的 Orientation 属性的设置，可以作为水平或垂直滚动条使用。

发布注意 FlatScrollBar 控件是 MSCOMCT2.OCX 文件中一组ActiveX 控件的一部分。要在您的应用程序中使用 FlatScrollBar 控件，您必须将MSCOMCT2.OCX 文件添加到工程。当发布您的应用程序时，将MSCOMCT2.OCX 问加安装到用户的 Microsoft Windows System 或 System32 目录中。有关如何将一个ActiveX 控件添加到工程的详细信息，请参阅《程序员指南》中的“添加控件到工程”。


MonthView 控件

MonthView 控件可以用来创建一个能够让用户通过日历风格的界面查看和设置日期信息的应用程序。

语法

MonthView

说明

MonthView 控件的 Value 属性返回当前被选定的日期。

可以允许最终用户通过将 MultiSelect 属性设置为 True，并使用 MaxSelProperty 指定可选择的天数来选择一个连续的日期范围。SelStart 和 SelEnd 属性返回所选择的日期范围的第一个日期和最后一个日期。

可以用许多方法自定义一个 MonthView 控件的外观。可以使用各种颜色属性，例如 MonthBackColor、TitleBackColor、TitleForeColor 和 TrailingForeColor 为控件创建一个唯一的配色方案。

通过设置 MonthRows 和 MonthColumns 属性，可以在一个 MonthView 控件中一次显示多个月份（多至 12）。MonthRows 和 MonthColumns 属性的总数必须小于或等于 12。

注意 MonthView 控件是 ActiveX 控件组的一部分，位于 Mscomct2.ocx 文件中。如果要在应用程序中使用 MonthView 控件，必须将 Mscomct2.ocx 文件添加到工程中。在发布该应用程序时，需要在用户的 Microsoft Windows 的 System 或 System32 目录中安装这个 Mscomct2.ocx 文件。有关如何将 ActiveX 控件添加到工程的详细信息，请参阅《程序员指南》中的“添加控件到工程”。


UpDown控件

UpDown 控件有一对上下箭头按钮，单击时使诸如滚动位置或者关联的伙伴控件中的值增减。

语法

UpDown

说明

对用户而言，UpDown 控件及其伙伴控件常常象单个控件。伙伴控件可以是通过 BuddyControl 属性与 UpDown 控件相关联的任何控件，通常它显示如 TextBox 控件或 CommandButton 控件的数据。

注意 象内在的标签控件这样，一些辅助的无窗口控件，都不能用作伙伴控件。

通过设置 AutoBuddy 属性，UpDown 控件就自动地将Tab 键次序中前面的控件作为它的伙伴控件。如果Tab 键次序中没有前面的控件，UpDown 控件则将Tab 键次序中的下一个控件作为它的伙伴控件。另一种设置伙伴控件的方法是使用 BuddyControl 属性。在设计时，一旦 AutoBuddy 属性或 BuddyControl 属性被设置，伙伴控件会自动地按其大小和位置与 UpDown 控件配对。UpDown 控件可用 Alignment 属性决定它被放在伙伴控件的右面或左面。

当单击控件上的按钮时，Increment、Min、Max 和 Wrap 属性规定 UpDown 控件的 Value 属性如何改变。例如，如果有一些值是 10 的倍数，且在 20 与 80 之间，可以设置 Increment、Min 和 Max 属性值分别为 10、20 和 80。Wrap 属性允许 Value 属性超过 Max 属性值从 Min 属性值重新开始增加，或相反。

没有伙伴控件的 UpDown 控件起一种简化滚动条的作用。

注意 UpDown 控件应当代替 Visual Basic 4.0 的 Spin Button 控件。

发行注意 UpDown 控件是在 MSCOMCT2.OCX 文件中可找到的 ActiveX 控件的一部分。为了在应用程序中使用 UpDown 控件，必须在工程中添加 MSCOMCT2.OCX 文件。在发行应用程序时，要将 MSCOMCT2.OCX 文件安装在用户的 Microsoft Windows 的 SYSTEM 目录中。关于如何在工程中添加自定义控件的详细信息，请参阅《程序员指南》。


Topic Not Found

未找到该主题

未找到相匹配的主题。可能的原因和解决方法如下：

  • 包含目标主题的文件 (.chm) 没有位于指定的位置。

    解决方法：重新运行 MSDN Library的安装。

  • 包含当前主题或目标主题的文件 (.chm) 已经过时，并且链接不再有效。

    解决方法：安装最新版本的 MSDN Library。

  • MSDN Library CD 不在 CD-ROM 中。

    解决方法：将 MSDN Library CD 装入 CD-ROM 中。


Error 常数 （ComCtl32）

常数 | 值 | 描述
cc2InvalidProcedureCall | 5 | 无效过程调用。
cc2BadFileNameOrNumber | &H34 | 错误文件名或文件号。
cc2FileNotFound | &H35 | 文件未找到。
cc2InvalidPropertyValue | &H17C | 无效属性值。
cc2SetNotSupportedAtRuntime | &H17E | 运行时不能设置属性。
cc2SetNotSupported | &H17F | 属性为只读。
cc2InvalidObjectUse | &H1A9 | 对象使用无效。
cc2WrongClipboardFormat | &H1CD | 指定格式与数据格式不匹配。
cc2DataObjectLocked | &H2A0 | DataObject 格式列表在 OLEStartDrag 事件之外不能被清除或扩展。
cc2ExpectedAnArgument | &H2A1 | 至少需要一个参数。
cc2RecursiveOleDrag | &H2A2 | 对 OLE 拖放的非法递归调用。
cc2FormatNotByteArray | &H2A3 | SetData 使用的非内部 OLE 拖放格式要求字节数组数据。 GetData 可能返回比已给定的 SetData 更多的字节。
cc2DataNotSetForFormat | &H2A4 | 在 OLESetData 事件过程中。 请求的数据未提供给DataObject 。
cc2InconsistentObject | &H8BA6 | 控件内部状态已经被损坏。
cc2ErrorDuringSet | &H8BA7 | 不能设置属性。
cc2ErrorOpeningVideo | &H8BA8 | 不能打开 AVI 文件。
cc2ErrorPlayingVideo | &H8BA9 | 不能播放 AVI 文件。
cc2NoValidBuddyCtl | &H8BAA | 必须首先设置BuddyControl 属性。
cc2VideoNotOpen | &H8BAB | 必须首先打开 AVI 文件。
cc2AutoBuddyNotSet | &H8BAC | AutoBuddy 没有设置， 没有发现潜在的buddy控件。
cc2ErrorStoppingVideo | &H8BAD | 试图停止正在播放的 AVI 文件出错。
cc2ErrorClosingVideo | &H8BAE | 正在关闭打开的 AVI 文件出错。
cc2CantStopAutoPlay | &H8BAF | Stop 方法不会影响 AutoPlay 属性。
cc2BuddyNotASibling | &H8BB0 | BuddyControl 必须是在同一个容器中的一个单独控件。
cc2NoUpDownAsBuddy | &H8BB1 | UpDown 控件不能成为另一个 UpDown 控件的合作者。


BuddyProperty 属性

设置或返回用于使 UpDown 控件与其伙伴控件同步的本属性。

语法

object.BuddyProperty [= value]

BuddyProperty 属性的语法包含下面部分：

部分 | 描述
object | 对象表达式，其值是“应用于”列表中的一个对象。
value | 变体值，它指定被 BuddyControl 属性所指定控件的属性。如果没有被指定的值，就使用缺省属性。

说明

如果 SyncBuddy 属性是 True，控件就将其 Value 属性与由 BuddyProperty 属性指定的属性同步。

通过在“属性”窗口下拉表中选择属性，在设计时可设置 BuddyProperty。

BuddyControl 属性必须在 BuddyProperty 属性设置之前设置。


CallbackKeyDown事件

在光标位于回调字段内的情况下，一个键被按下时发生。

语法

Private Sub object_CallbackKeyDown([index As Integer], KeyCode As Integer, Shift As Integer, CallbackField As String, CallbackDate As Date)

CallbackKeyDown 事件语法有如下部分：

部分 | 描述
Object | 一个对象表达式，其值是“应用于”列表中的一个对象。
Index | 一个整数，它唯一标识控件数组中的一个控件。
KeyCode | 一个数值表达式，指定被按下的键所对应的ASCII键码。
Shift | 一个数值表达式，指定事件发生时SHIFT键、CTRL键和ALT键的状态。
CallbackField | 一个字符串表达式，指定回调子字符串。
CallbackDate | 一个日期表达式，指定控件的日期数值。

说明

CallbackKeyDown事件是KeyDown事件的变种，可用于处理一个回调子字符串。

关于回调处理的更多信息，请参阅CustomFormat属性。

该事件在用户按下上下箭头键时也会发生。


Change 事件（UpDown 控件）

Value 属性改变时此事件发生。

语法

Private Sub object_Change([index as integer])

Change 事件的语法包含下面部分：

部分 | 描述
object | 对象表达式，其值是“应用于”列表中的一个对象。
Index | 整数，唯一地标识一个控件，如果它在控件数组中。

说明

每当 Value 属性改变，Change 事件就发生。通过单击箭头按钮或在 SyncBuddy 属性是 True 时改变伙伴控件的值，Value 属性也能被代码改变。


CloseUp事件

当下拉日历被关闭时发生。

语法

Private Sub object_CloseUp([index As Integer])

CloseUp 事件语法有如下部分：

部分 | 描述
Object | 一个对象表达式，其值是“应用于”列表中的一个对象。
Index | 一个整数，它唯一标识控件数组中的一个控件。

说明

CloseUp事件可用于对用户关闭下拉日历的响应。


DateClick 事件

单击该控件上的一个日期时发生。

语法

Private Sub object_DateClick([index As Integer], DateClicked As Date)

DateClick 事件的语法包括以下部分：

部分 | 描述
Object | 一个对象表达式，其值为“应用于”列表中的对象。
Index | 一个唯一标识控件的整数，如果该控件在一个控件数组中。
DateClicked | 一个日期表达式，指定被单击的日期。

说明

DateClick 事件可以用于响应用户单击一个特定的日期。DateClicked 可以用来决定单击的是哪一个日期。


DateDblClick 事件

双击控件上的一个日期时发生。

语法

Private Sub object_DateDblClick([index As Integer], DateDblClicked As Date)

DateDblClick 事件的语法包括以下部分：

部分 | 描述
Object | 一个对象表达式，其值为“应用于”列表中的对象。
Index | 一个唯一标识控件的整数，如果该控件在一个控件数组中。
DateDblClicked | 一个日期表达式，指出被单击的日期。

说明

DateDblClick 事件可以用于响应用户双击一个特定的日期。DateDblClicked 可以用来决定双击的是哪一个日期。


DownClick 事件

单击向下或向左箭头按钮时，此事件发生。

语法

Private Sub object_DownClick([index as integer])

DownClick 事件的语法包含下面部分：

部分 | 描述
object | 对象表达式，其值是“应用于”列表中的一个对象。
index | 整数，唯一地标识一个控件，如果它在控件数组中。

说明

DownClick 事件在 Change 事件之后发生。


DropDown事件（DateTimePicker控件）

当下拉日历被拉下时发生。

语法

Private Sub object_DropDown()

object所在处表示一个对象表达式，其值是“应用于”列表中的一个对象。


Format事件（DateTimePicker 控件）

当控件请求要被显示在调用字段中的文本时发生。

语法

Private Sub object_Format([index As Integer], CallbackField As String, FormattedString As String)

Format事件语法有如下部分：

部分 | 描述
object | 一个对象表达式，其值是“应用于”列表中的一个对象。
index | 一个整数，它唯一标识控件数组中的一个控件。
CallbackField | 一个字符串表达式，指定回调子字符串。
FormattedStringField | 一个字符串表达式，指定所要显示的格式化字符串。

说明

Format事件用于设置在回调字段中显示的文本。

关于回调处理的更多信息，请参阅CustomFormat属性。


CustomFormat 属性、Format 事件、FormatSize 事件示例

下例中，使用括号中的西班牙文月份名显示当前日期。The CallbackField "XXXX" is set in the Load event by setting the CustomFormat property to a string that includes the four "X"s. The FormatSize event once before the Forma event and is used to determine the size of the callback field. The Format event then occurs which returns a formatted string to replace the callback field text. To try the example, place a DateTimePicker control on a form and paste the code into the Declarations section.

Option Base 1
Private sSpanishMonthLong(12) As String

Private Sub DTPicker1_Format(ByVal CallbackField As String, FormattedString As String)
   If CallbackField = "XXXX" Then
      FormattedString = sSpanishMonthLong(DTPicker1.Month - 1)
   End If
End Sub

Private Sub DTPicker1_FormatSize(ByVal CallbackField As String, Size As Integer)
   Dim iMaxMonthLen As Integer

   If CallbackField = "XXXX" Then
      iMaxMonthLen = 0
      For i = 1 To 12
         If iMaxMonthLen < Len(sSpanishMonthLong(i)) Then
            iMaxMonthLen = Len(sSpanishMonthLong(i))
         End If
      Next
   End If
   Size = iMaxMonthLen
End Sub

Private Sub Form_Load()
   DTPicker1.CustomFormat = "MMMM(XXXX) dd, yyy"
   DTPicker1.Format = dtpCustom

   sSpanishMonthLong(1) = "Enero"
   sSpanishMonthLong(2) = "Febrero"
   sSpanishMonthLong(3) = "Marzo"
   sSpanishMonthLong(4) = "Abril"
   sSpanishMonthLong(5) = "Mayo"
   sSpanishMonthLong(6) = "Junio"
   sSpanishMonthLong(7) = "Julio"
   sSpanishMonthLong(8) = "Agosto"
   sSpanishMonthLong(9) = "Septiembre"
   sSpanishMonthLong(10) = "Octubre"
   sSpanishMonthLong(11) = "Noviembre"
   sSpanishMonthLong(12) = "Diciembre"
End Sub


FormatSize事件

在 CustomFormat 属性更改之后，并且在Format事件发生前发生。该事件允许您为格式化的字符串设置最大允许尺寸，这样就使控件可以在屏幕上以充足的空间描绘用户格式化的字符串。

语法

Private Sub object_FormatSize([index As Integer], CallbackField As String, Size As Long)

FormatSize 事件语法有如下部分：

部分 | 描述
object | 一个对象表达式，其值是“应用于”列表中的一个对象。
Index | 一个整数，唯一标识控件数组中的一个控件。
CallbackField | 一个字符串表达式，指定回调子字符串。
Size | 一个长整数，指定在Format事件中将要被返回的字符串的大小。

说明

FormatSize事件用于设置回调字段中所显示文本的大小。


GetDayBold 事件

当控件需要显示日期以获得粗体信息时发生。

语法

Private Sub object_GetDayBold([index As Integer], StartDate As Date, Count As Integer, State( ) As Array)

DateDblClick 事件的语法包括以下部分：

部分 | 描述
object | 一个对象表达式，其值为“应用于”列表中的对象。
index | 一个唯一标识控件的整数，如果该控件在一个控件数组中。
StartDate | 一个日期表达式，指出显示的第一个日期。
Count | 一个数值表达式，指出显示的天数。
State( ) | 一个布尔值数组，指出一个日期是否用粗体显示。

说明

当要显示日期时，可以使用 GetDayBold 事件来设置日期用粗体显示。


GetDayBold 事件示例

下列代码将所有的星期五设置为以粗体显示。要检验该示例，请将一个 MonthView 控件放置到一个窗体中，将代码粘贴到 Declarations 部分。然后运行该工程。

Private Sub MonthView1_GetDayBold(ByVal StartDate As Date, ByVal Count As Integer, State() As Boolean)
   ' 假定一周的开始为星期日，将变量 intBold
   ' 设为第五个星期五。然后将每个
   ' 星期五的状态设为真。
   Dim intBold As Integer
   intBold = mvwFriday
   While intBold < Count
      State(intBold - 1) = True

      intBold = intBold + 7
   Wend
End Sub


SelChange 事件（MonthView 控件）

当用户选择一个新的日期或一个新的日期范围时发生该事件。

语法

Private Sub object_SelChange(StartDate As Date, EndDate As Date, Cancel As Boolean)

SelChange 事件的语法包括以下部分：

部分 | 描述
Object | 一个对象表达式，其值为“应用于”列表中的对象。
StartDate | 选择的第一个日期。
EndDate | 选择的最后一个日期。
Cancel | 决定是否取消这一选择。


SelChange 事件示例

该示例打印用户所选择的日期范围。要检验该示例，请将一个 MonthView 控件放置到一个窗体中，然后将下述代码粘贴到代码模块的 Declarations 部分。启动该工程，并选择各种日期范围（应将 MultiSelect 属性设为 True）.

Private Sub MonthView1_SelChange(ByVal StartDate As Date, ByVal EndDate As Date, Cancel As Boolean)
   Dim d As Date
   d = StartDate
   Debug.Print "Start"
   While d <= EndDate
      Debug.Print d
      d = d + 1
   Wend
   Debug.Print "End"
End Sub


UpClick 事件

单击向上或向右的箭头按钮时，此事件发生。

Private Sub object_UpClick([index as integer])

UpClick 事件的语法包含下面部分

部分 | 描述
object | 对象表达式，其值是“应用于”列表中的一个对象。
Index | 整数，唯一地标识一个控件，如果它在控件数组中。

说明

UpClick 事件在 Change 事件之后发生。


Windows 通用控件的可捕获错误（ComCtl2）

下表列出了 MSComct2.OCX 文件中 Windows 通用控件的可捕获错误和常数。

以下是 MSComct2.OCX 文件中 Windows 通用控件的错误。此文件中的控件有：UpDown DateTimePicker、 Animation、 MonthView、和 FlatScrollBar。

常数 | 值 | 描述
cc2InvalidProcedureCall | 5 | 无效的过程调用
cc2BadFileNameOrNumber | 52 | 错误的文件名或编号
cc2FileNotFound | 53 | 文件找不到
cc2InvalidPropertyValue | 380 | 无效的属性值
cc2SetNotSupportedAtRuntime | 382 | 运行时不能设置属性
cc2SetNotSupported | 383 | 属性为只读
cc2GetNotSupported | 394 | Property is write-only
cc2InvalidObjectUse | 425 | 无效的对象用法
cc2WrongClipboardFormat | 461 | 指定的格式与数据格式不匹配。
cc2DataObjectLocked | 672 | 在 OLEStartDrag 事件以外不可清除或扩展 DataObject 格式列表
cc2ExpectedAnArgument | 673 | 至少应有一个参数。
cc2RecursiveOleDrag | 674 | OLE 拖放的非法递归调用。
cc2FormatNotByteArray | 675 | 使用 SetData 的非内部OLE 拖放格式要求字节数组数据，GetData 可能返回多于给 SetData 的字节数。
cc2DataNotSetForFormat | 676 | OLESetData 事件期间，请求的数据未提供给 DataObject。
cc2InconsistentObject | 35750 | 控件的内部状态杂乱
cc2ErrorDuringSet | 35751 | 无法设置属性
cc2ErrorOpeningVideo | 35752 | 无法打开 AVI 文件
cc2ErrorPlayingVideo | 35753 | 无法播放 AVI 文件
cc2NoValidBuddyCtl | 35754 | 必须先设置 BuddyControl 的属性
cc2VideoNotOpen | 35755 | 必须先打开 AVI 文件
cc2AutoBuddyNotSet | 35756 | AutoBuddy 未设置，找不到潜在的伙伴控件
cc2ErrorStoppingVideo | 35757 | 试图停止正播放的视频文件错误
cc2ErrorClosingVideo | 35758 | 关闭已打开的视频文件错误
cc2CantStopAutoPlay | 35759 | Stop 方法对 AutoPlay 不起作用
cc2BuddyNotASibling | 35760 | 在同一容器里 BuddyControl 必须是一个独立控件
cc2NoUpDownAsBuddy | 35761 | UpDown 控件不能与另一个 UpDown 控件成为伙伴。
cc2InvalidRange | 35770 | 指定了一个无效日期范围。
cc2InvalidMaxDate | 35771 | 为 MaxDate 属性指定了一个无效日期。
cc2InvalidMinDate | 35772 | 为 MinDate 属性指定了一个无效日期。
cc2DateOutOfRange | 35773 | 指定了一个不在 MinDate 和 MaxData 属性范围之内的日期。
cc2InvalidMaxDateMin | 35774 | 为 MaxDate 属性指定了一个小于 MinDate 当前值的值。
cc2InvalidMinDateMax | 35775 | 为 MinDate 属性指定了一个大于 MaxDate 当前值的值。
cc2InvalidRowColValue | 35776 | 为 MonthRows 或 MonthColumns 指定了一个不在 1 和 12 之间的值。
cc2InvalidRowColTotal | 35777 | 为 MonthRows 指定了一个将会造成月份总数 (即，MonthRows * MonthCols)大于 12 的值。
cc2MonthViewError | 35778 | 在对 Windows MonthView 控件的调用中出错。
cc2SetDayMultiSelectOn | 35779 | 当 MultiSelect = True 时，不能设置 Day 属性。
cc2SetDayOfWeekMultiSelectOn | 35780 | 当 MultiSelect = True 时，不能设置 DayOfWeek 属性。
cc2SetMonthMultiSelectOn | 35781 | 当MultSelect = True 时，不能设置 Month 属性。
cc2SetWeekMultiSelectOn | 35782 | 当 MultiSelect = True 时，不能设置 Week 属性。
cc2SetYearMultiSelectOn | 35783 | 当 MultiSelect = True 时，不能设置 Year 属性。
cc2SetMaxSelCountMultiSelectOff | 35784 | 当 MultiSelect = False 时，不能设置 MaxSelCount 属性。
cc2SetSelEndMultiSelectOff | 35785 | 当 MultiSelect = False 时，不能设置 SelEnd 属性。
cc2SetSelStartMultiSelectOff | 35786 | 当 MultiSelect = False 时，不能设置 SelStart 属性。
cc2NullValueNotAllowed | 35787 | 当 CheckBox = False 时，不能设置 Value 属性为 NULL。
cc2DTPickerError | 35788 | 当调用窗口 DTPicker 控件时发生错误。
cc2ScrollValueOutOfRange | 35789 | 滚动值超出范围


Close 方法（动画控件）

Close 方法使 Animation 控件关闭当前打开的 AVI 文件。如果没有加载任何文件，则 Close 不执行任何操作，也不会产生任何错误。

语法

object.Close

object 所在处表示一个对象表达式，其值是 Animation 控件。

说明

为了终止播放文件，要用 Stop 方法。但是，如果 Autoplay 属性的设置为 True，则将其设置为 False 来停播文件。


ComputeControlSize 方法

返回对一个给定行数和列数的 MonthView 控件的宽度和高度。

语法

object.ComputeControlSize(Rows, Columns, Width, Height)

ComputeControlSize 方法的语法包括以下部分：

部分 | 描述
Object | 一个对象表达式，其值为“应用于”列表中的对象。
Rows | 设置一个用来指定行数的整数。
Columns | 设置一个用来指定行数的整数。
Width | 返回一个单精度数值，即预期控件的宽度。
Height | 返回一个单精度数值，即预期控件的高度。

说明

当通过重新设置 MonthColumns 或 MonthRows 属性更改了 MonthView 控件的大小时，可以在更改前使用 ComputeControlSize 方法计算该控件的大小，并相应地重新调整窗体大小。

要使用 ComputeControlSize 方法，首先应声明两个 Single 类型的变量。然后将这两个变量作为 Width 和 Height 参数来调用该方法。


ComputeControlSize 方法示例

该示例在使用 MonthRows 和 MonthColumns 属性增加 MonthView 控件的大小后，再使用 ComputeControlSize 方法来计算该控件的大小。要检验该示例，请将一个 MonthView 控件放置到一个窗体中，然后将下述代码粘贴到代码模块的 Declarations部分。启动该工程，并双击该窗体。

Private Sub Form_Load()
   ' 设置该控件的 Top 和 Left 属性。
   With MonthView1
      .Left = 200 ' 假设 ScaleMode = Twip
      .Top = 400
   End With
End Sub

Private Sub Form_DblClick()
   Dim sWidth As Single
   Dim sHeight As Single

   With MonthView1 ' 计算控件的大小，增加列和行。
      .ComputeControlSize 3, 4, sWidth, sHeight
      .MonthColumns = 4
      .MonthRows = 3  '
   End With

   ' 使用从该方法获得的值，重新设置该控件的大小。
   Me.Width = MonthView1.Left + sWidth + 500
   Me.Height = MonthView1.Top + sHeight + 500
End Sub


HitTest 方法（MonthView 控件）

返回位于特定的坐标集合的日期。绝大多数通常使用拖放操作来决定目前位置是否可以作为拖放的目标项。

语法

object.HitTest(x as Single, y As Single, Date As Date)

HitTest 方法的语法包括以下部分：

部分 | 描述
Object | 一个对象表达式，其值为“应用于”列表中的对象。
x, y | 目标date的坐标。
Date | 当控件上的一个日期产生鼠标操作时返回的日期表达式。

返回设置值

HitTest 方法可能返回下述值，指出鼠标指针目前所指向日历的哪个部分：

常数 | 值 | 描述
MvwCalendarBack | 0 | 日历背景。
MvwCalendarDate | 1 | 日历的日期。
MvwCalendarDateNext | 2 | 如果单击该区域，则日历将显示下一月份。
MvwCalendarDatePrev | 3 | 如果单击该区域，则日历将显示前一月份。
MvwCalendarDay | 4 | 该日期上的日期标号。
MvwCalendarWeekNum | 5 | 星期号，如果 ShowWeekNumbers 被设置为 True。
MvwNoWhere | 6 | 日历的底边。
mvwTitleBack | 7 | 日历的背景。
mvwTitleBtnNext | 8 | 标题区域的Next按钮。
mvwTitleBtnPrev | 9 | 标题区域的Previous按钮。
mvwTitleMonth | 10 | 标题的月份字符串。
mvwTitleYear | 11 | 标题的年份字符串。
mvwTodayLink | 12 | 如果单击该区域，则该日历将显示当前月份和日期。只有当 ShowToday 被设为 True 时才可用。

说明

HitTest 方法可以用于决定日历的什么区域正在被鼠标操作影响。

如果在指定的坐标中不存在日期，HitTest 方法将返回 Null。 如果该坐标处不存在日期，Date 也可以是 Null。


HitTest 方法（MonthView 控件）示例

该示例使用 HitTest 方法，当鼠标经过一个日期时，在一个标签控件中显示该日期。要检验该示例，请将一个 MonthView 控件和一个 Label 控件放置到一个窗体中，然后将下述代码粘贴到 Declarations部分。

Private Sub MonthView1_MouseMove(Button As Integer, Shift As Integer, x As Single, y As Single)
   Dim iResult As Integer
   Dim dtMyDate As Date
   iResult = MonthView1.HitTest(x, y, dtMyDate)
   Label1.Caption = dtMyDate
End Sub


Open 方法（动画控件）

打开一个要播放的 .avi 文件。如果 AutoPlay 属性设置为 True，则只要加载该文件，剪辑就开始播放它。在关闭 .avi 文件或设置 Autoplay 属性为 False 之前，它都将不断重复播放。

语法

object.Open file

部分 | 描述
object | 必需的。对象表达式，其值为“应用于”列表中的一个对象。
file | 必需的。要播放的文件名。

说明

Animation 控件不能播放含有声音数据的 .avi 文件。此外，动画控件只能显示未压缩的或用行程编码 (RLE) 压缩的 .avi 文件。当用文件调用 Open 方法时，如果该文件含有声音数据或不具有受支持的压缩格式，则返回错误。


Open 方法（动画控件）示例

在下面示例中，用“打开”对话框打开一个 .avi 文件并自动播放。要试用此例，在窗体上放置 Animation 控件和 CommonDialog 控件，并把代码粘贴到窗体的声明部分。运行该例，并选择要打开的 .avi 文件。

Private Sub Animation1_Click ()
   With CommonDialog1
      .Filter = "avi (*.avi)|*.avi"
      .ShowOpen
   End With
   With Animation1
      .Autoplay = True
      .Open CommonDialog1.Filename
   End With
End Sub


Play 方法

在 Animation 控件中播放 .avi 文件。

语法

object.Play [= repeat, start, end]

部分 | 描述
object | 必需的。对象表达式，其值是 Animation 控件。
Repeat | 可选的。整数，它为指定重复剪辑的次数。缺省值是 -1，它使重复剪辑次数不受限定。
Start | 可选的。整数，它为指定开始的帧。缺省值是 0，表示在第一帧上开始剪辑。最大值是 65,535。
end | 可选的。整数，它为指定结束的帧。缺省值是 -1，表示上一次剪辑的帧。最大值是 65,535。

数据类型

Integer

说明

用 Stop 方法终止播放 .avi 文件。


Stop 方法（动画控件）

在 Animation 控件中终止播放 .avi 文件。

语法

object.Stop

object 所在处表示一个对象表达式，其值是 Animation 控件。

说明

Stop 方法仅终止那些用 Play 方法启动的动画。当设置 Autoplay 属性为 True 时，任何使用 Stop 方法的尝试都导致返回错误 (35,759)。


Alignment 属性（UpDown 控件）

返回或设置一个值，它决定 UpDown 控件与其伙伴控件对齐的方式。

语法

object.Alignment [= value]

Alignment 属性的语法包含下面部分：

部分 | 描述
object | 对象表达式，其值是“应用于”列表中的一个对象。
value | 指定 UpDown 控件与其伙伴控件对齐方式的值，对齐方式如“设置值”中所述。

设置值

value 的设置值：

常数 | 值 | 描述
cc2alignmentLeft | 0 | UpDown 控件与其伙伴控件左边对齐。
cc2AlignmentRight | 1 | （缺省）UpDown 控件与其伙伴控件的右边对齐。

说明

使用 Alignment 属性指定 UpDown 控件在其伙伴控件中的定方式。按照缺省规定，UpDown 控件显示在其伙伴控件右边。

设置 Alignment 属性，可使 UpDown 控件与其伙伴控件重新自动对齐。伙伴控件的宽度要减小一个 UpDown 控件的宽度量，所以这两个控件的总宽度与伙伴控件单独宽度一样。

注意 在 UpDown 控件对齐时，Alignment 属性忽略 Orientation 属性。


Appearance属性（FlatScrollBar 控件）

返回或设置 FlatScrollBar 控件的外观。

语法

object.Appearance [= integer]

Appearance 属性的语法有这些部分：

部分 | 说明
object | 一个对象表达式，其值为“应用于”列表中的对象。
integer | 一个数字表达式，指定滚动条的样式, 如同“设置值”中所描述的那样。

设置值

对integer 的设置值为:

常数 | 值 | 说明
fsb3D | 0 | 滚动条有标准 Windows 滚动条的立体外观。
fsbFlat | 1 | (缺省) 滚动条是平面的。
fsbTrack3D | 2 | 滚动条是平面的，当鼠标移动到滑块和箭头按钮上时，它们就会变成立体的。

说明

Appearance 属性设置滚动条的外观，并决定滚动条是平面的、立体的，还是两者的组合。组合的滚动条当鼠标指针在其上时，将滚动箭头和滑块从平面的变成立体，并允许创建一个动态界面。


Arrows 属性

返回或设置一个值，决定允许使用哪一个滚动箭头。

语法

object.Arrows [= integer]

Arrows 属性的语法有这些部分：

部分 | 说明
object | 一个对象表达式，其值为“应用于”列表中的对象。
integer | 一个数字表达式 ，指定允许使用的滚动按钮或按钮，如同“设置值”中所描述的。

设置值

integer 的设置值为：

常数 | 值 | 说明
cc2Both | 0 | (缺省) 向左的和向右的(或向上的和向下的,由 Orientation 而定)滚动箭头允许使用。
cc2LeftUp | 1 | 仅向左的(或向上的) 滚动按钮允许使用。
cc2RightDown | 2 | 仅向右的(或向下的) 滚动按钮允许使用。

说明

当 FlatScrollBar 的 Orientation 从水平变为垂直时，向左的滚动箭头变为向上的箭头，向右的滚动箭头变为向下的箭头。

对Arrows 属性最常见的使用是当控件达到最大或最小值时，禁用某个适当的滚动箭头。


AutoBuddy 属性

设置或返回一个值，该值决定 UpDown 控件是否根据控件的Tab 键次序将它作为其伙伴控件。

语法

object.AutoBuddy [= value]

AutoBuddy 属性的语法包含下面部分：

部分 | 描述
object | 对象表达式，其值是“应用于”列表中的一个对象。
value | 布尔表达式，决定方式它决定伙伴控件，如“设置值”中所述。

设置值

对于 value 的设置值是：

设置值 | 描述
True | UpDown 控件将Tab 键次序中前面的控件作为其伙伴控件。如果没有带前向选项卡索引的控件可用，UpDown 控件就将带更高的选项卡索引的第一个可用的控件作为其伙伴控件。
False | （缺省）UpDown 控件将 BuddyControl 属性中的设置值作为其伙伴控件。

说明

将 AutoBuddy 属性设置为 True，也就设置了 BuddyControl 属性。而将 AutoBuddy 设置为 False，就清除 BuddyControl 属性。


AutoPlay 属性

在将 .avi 文件加载到控件时，返回或设置一值，该值确定 Animation 控件是否开始播放 .avi 文件。

语法

object.Autoplay [= boolean]

AutoPlay 属性的语法包含以下部分：

部分 | 描述
object | 对象表达式，其值是 Animation 控件。
Boolean | 布尔表达式，说明是否已激活 Autoplay 属性。

设置值

boolean 的设置值是：

设置值 | 描述
True | 一旦将 .avi 文件加载到 Animation 控件中，则 .avi 文件将连续循环的自动播放。
False | 一旦加载了 .avi 文件，那么，不使用 Play 方法就不会播放这个 .avi 文件。

数据类型

Integer (Boolean)

说明

用 Autoplay 属性播放的 .avi 文件将不断重复，直到 Autoplay 的设置为 False 时为止。


BackStyle 属性（Animation 控件）

返回或设置一个值，该值确定 Animation 控件是在透明的背景上还是在动画剪辑中所指定的背景颜色上绘制动画。在运行时为只读。

语法

object.BackStyle [= value]

BackStyle 属性的语法包含以下部分:

部分 | 描述
object | 对象表达式，其值是 Animation 控件。
value | 数值表达式，指定透明性，与下列设置中描述的相同。

设置值

value 的设置值是：

设置值 | 描述
0 | （缺省）透明的─控件的背景颜色是可见的。
1 | 不透明的─动画剪辑中指定的背景颜色将充满控件并隐没其背后的所有颜色。

说明

可以用 BackStyle 属性运行动画，该动画显示 Animation 控件的背景颜色而非动画自身的背景颜色。

数据类型

Integer (Boolean)


BuddyControl 属性

设置或返回用作伙伴控件的控件。

语法

object.BuddyControl [= value]

BuddyControl 属性的语法包含下面部分：

部分 | 描述
object | 对象表达式，其值是“应用于”列表中的一个对象。
Value | 指定伙伴控件的变体值，指定方式如下所述。

说明

BuddyControl 属性可在设计时或运行时设置。在运行时，BuddyControl 属性在“属性”窗口中。为了在运行时设置 BuddyControl 属性，可使用下列代码：

UpDown1.BuddyControl = Text1

也可以使用将 AutoBuddy 设置为 True 的方法来隐含地设置 BuddyControl 属性。在这种情况下，BuddyControl 自动设置为Tab 键次序前面的控件。

将 BuddyControl 属性设置为 Nothing，便将 AutoBuddy 设置值自动地设置为 False。

注意 将 BuddyControl 属性设置成不能作为伙伴的控件，如内量标签控件那样的控件，将产生错误。


CalendarBackColor，CalendarForeColor属性

返回或设置一个值，指定控件中下拉式日历菜单部分的背景色或前景色。

语法

object.CalendarBackColor [= color]

object.CalendarForeColor [= color]

CalendarBackColor和CalendarForeColor属性语法有以下部分：

部分 | 描述
Object | 一个对象表达式，其值是“应用于”列表中的一个对象。
Color | 一个值或一个常数，决定所使用的颜色。

设置值

color 设置值是：

设置值 | 描述
RGB colors | 用调色板或者在代码中用RGB或QBColor函数指定的颜色。
System default colors | 对象浏览器的Visual Basic (VBRUN)对象库所列出的系统颜色常数所指定的颜色。Windows操作环境将替换用户在控件面板中的设置值。

说明

CalendarBackColor和CalendarForeColor属性可以与CalendarTitleBackColor、CalendarTitleForeColor和CalendarTrailingForeColor属性一起使用，来自定义控件的颜色。

正常RGB颜色的有效范围是从0到16,777,215 (&HFFFFFF)。在这个范围内的数值的高位字节等于0；更低的三个字节，由最低到最高有效字节，分别决定了红、绿、蓝三种颜色的数量。红、绿、蓝三种颜色的成分每一种分别由一个0到255 (&HFF)之间的数表示。如果高字节不等于0，Visual Basic将使用用户在控件面板中设置的系统颜色，或使用对象浏览器Visual Basic (VBRUN) 对象库中所列出的常量代表的颜色。


CalendarBackColor，CalendarTitleForeColor属性示例

下例通过重新设置几个颜色属性来改变DateTimePicker控件日历的外观。要试验该示例，在窗体中添加一个DateTimePicker控件和一个CommandButton控件。把代码粘贴到代码模块的声明部分。启动工程并单击DateTimePicker控件，观察缺省的颜色。单击CommandButton并再次单击DateTimePicker控件观察新颜色。

Private Sub Command1_Click()
   With DTPicker1
      .CalendarBackColor = vbYellow
      .CalendarTitleBackColor = vbRed
      .CalendarTitleForeColor = vbWhite
      .CalendarTrailingForeColor = vbGreen
   End With
End Sub


CalendarTitleBackColor，CalendarTitleForeColor属性

返回或设置一个值，指定控件下拉式日历部分标题的前景色或背景色。

语法

object.CalendarTitleBackColor [= color]

object.CalendarTitleForeColor [= color]

CalendarTitleBackColor和CalendarTitleForeColor属性语法有以下部分：

部分 | 描述
Object | 一个对象表达式，其值是“应用于”列表中的一个对象。
Color | 一个值或一个常数，决定使用的颜色。

设置值

color的设置值有：

设置值 | 描述
RGB colors | 用调色板或者在代码中用RGB或QBColor函数指定的颜色。
System default colors | 对象浏览器的Visual Basic (VBRUN)对象库所列出的系统颜色常数所指定的颜色。Windows操作环境将替换用户在控件面板中的设置值。

说明

CalendarTitleBackColor和CalendarTitleForeColor属性可以与CalendarBackColor、CalendarForeColor和CalendarTrailingForeColor属性一起使用来自定义控件的颜色。

正常RGB颜色的有效范围是从0到16,777,215 (&HFFFFFF)。在这个范围内的数值的高位字节等于0；更低的三个字节，由最低到最高有效字节，分别决定了红、绿、蓝三种颜色的数量。红、绿、蓝三种颜色的成分每一种分别由一个0到255 (&HFF)之间的数表示。如果高字节不等于0，Visual Basic将使用用户在控件面板中设置的系统颜色，或使用对象浏览器Visual Basic (VBRUN) 对象库中所列出的常量代表的颜色。


CalendarTrailingForeColor属性

返回或设置一个值，定义下拉式日历中显示的后续日期的前景色。

语法

object.CalendarTrailingForeColor [= color]

CalendarTrailingForeColor属性语法有下列部分：

部分 | 描述
object | 一个对象表达式，其值是“应用于”列表中的一个对象。
color | 一个值或一个常数，决定后续日期的颜色，后续日期是属于前面或后年的月份的。如设置值中所述。

设置值

color的设置值为：

Setting | 描述
RGB colors | 用调色板或者在代码中用 RGB 或 QBColor 函数指定的颜色。
System default colors | 对象浏览器的Visual Basic (VBRUN)对象库所列出的系统颜色常数所指定的颜色。Windows操作环境将替换用户在控件面板中的设置值。

说明

后续日期是在下拉式日历中显示的当前选中的月份之前和后续的日期数。缺省情况下，后续数据以vbWhite显示。

CalendarTrailingForeColor属性可以与CalendarBackColor、CalendarForeColor、CalendarTitleBackColor和CalendarTitleForeColor属性一起使用来自定义控件的颜色。

正常RGB颜色的有效范围是从0到16,777,215 (&HFFFFFF)。在这个范围内的数值的高位字节等于0；更低的三个字节，由最低到最高有效字节，分别决定了红、绿、蓝三种颜色的数量。红、绿、蓝三种颜色的成分每一种分别由一个0到255 (&HFF)之间的数表示。如果高字节不等于0，Visual Basic将使用用户在控件面板中设置的系统颜色，或使用对象浏览器Visual Basic (VBRUN) 对象库中所列出的常量代表的颜色。


Center 属性

在 Animation 控件内确定 .avi 文件是否居中。当设置为 True（缺省）时，根据图象的大小，在控件中心显示 .avi 文件。当设置为 False 时，.avi 文件定位在控件内的 0,0 处。

语法

object.Center [= boolean]

部分 | 描述
object | 必需的。对象表达式，其值为“应用于”列表中的一个对象。
boolean | 必需的。布尔表达式，指定 AVI 文件在控件内是否居中。

数据类型

Integer (Boolean)

说明

如果设置 Center 属性为真，且 .avi 帧大小比控件大，则在播放文件时不显示 .avi 的帧边界。


CheckBox属性

返回或设置一个值，决定是否在选中日期的左边显示一个复选框。

语法

object.CheckBox [= boolean]

The CheckBox 属性语法有如下部分:

部分 | 描述
object | 一个对象表达式，其值是“应用于”列表中一个对象。
boolean | 一个布尔表达式，定义是否显示复选框。

设置值

boolean的设置值为：

Setting | 描述
True | 在选中日期的左边显示一个复选框。
False | （缺省）在所选日期的左边不显示复选框。

说明

复选框允许用户决定是否使用控件来设置日期。当复选框为空时，则没有日期被选中。


CustomFormat属性

返回或设置一个值，指定控件在显示日期/时间信息时所使用的格式。

语法

object.CustomFormat [= string]

CustomFormat 属性语法有以下部分：

部分 | 描述
object | 一个对象表达式，其值是“应用于”列表中的一个对象。
string | 一个字符串表达式，指定显示的格式。

设置值

DateTimePicker控件支持下列格式字符：

字符串分段 | 描述
d | 一位或两位数字的日期数值。
dd | 两位数字的日期数值。一位数字的日期数值要前置零。
ddd | 三个字母的星期日期缩写。
dddd | 星期日期全名。
h | 12小时格式的一位或两位数字的小时数值。
hh | 12小时格式的两位数字的小时数值，一位数字的小时数值要前置零。
H | 24小时格式的一位或两位数字的小时数值。
HH | 24小时格式的两位数字的小时数值。一位数字的小时数值要前置零。
m | 一位或两位数字的分钟数值。
mm | 两位数字的分钟数值。一位数的分钟数值要前置零。
M | 一位或两位数字的月份数值。
MM | 两位数字的月份数值。一位数字的月份数值要前置零。
MMM | 三个字母的月份缩写。
MMMM | 月份全名。
s | 一位或两位数字的秒的数值。
ss | 两位数字的秒的数值。一位数字的秒的数值要前置零。
t | 一位字母缩写AM/PM （例如： "AM" 由 "A" 来代表）。
tt | 两位字母缩写AM/PM （例如： "AM" 由 "AM" 来代表）。
X | 一个回调字段。控件仍然使用其它的有效格式字符，并要求所有者填写 "X" 部分。所有者必须准备好去响应那些要求提供怎样填写这些字段信息的事件。可以使用连续的多个 'X' 字符来表示唯一的回调字段。
y | 一位数字的年份（就是说，1997将显示为 "7" ）。
yy | 年份的后两位数字来代表年份（这就是，1997将显示为 "97" ）。
yyy | 完整的年份表示（这就是，1997将显示为 "1997" ）。

说明

CustomFormat属性的作用就象一个输入掩码。要显示一个自定义格式，必须把Format格式设置为dtpCustom。

可以在格式字符串中加入说明文字。例如：如果希望控件以 "Today is:Friday July 25, 1997 Time: 8:34 AM" 的格式来显示当前日期，那么CustomFormat字符串应为 "'Today is:' ddddMMMMdd, yyy ' Time: 'h:mtt" 。说明文字必须以单引号括起。

上述描述的自定义格式字段中有一种称为回调字段。回调字段允许通过指定格式字符串的特定部分作为回调字段来自定义输出。要声明一个回调字段，必须在格式字符串体中的任何位置包含一个或多个 'X' 字符（ASCII码为88）。回调字段按从左到右的顺序显示。

在包含一个或多个回调字段的格式中显示新的日期时，每个回调字段都将产生Format和FormatSize事件。可以使用Format事件自定义响应字符串，使用FormatSize事件决定显示该字符串所需要的空间。这就使您能够完全控制回调字段的显示。

每一个X的序列都有其特定的含义。例如：X可能意味着 "st/nd/rd/th"（对 "1st" "2nd" "3rd" 或 "4th"）而 "XX" 可能意味着 "first" "second" "third" 或 "fourth"。这些字段不是格式化用户的文本。它们只是将日期格式化为可以显示的格式。

例如：希望用英语和西班牙语以下列格式显示月份：

July (Julio) 29

可以按下列格式创建字符串：

MMMM XXXX d

处理Format和FormatSize事件时，可以通过比较输入字符串与"XXXX"来检查哪一个回调字段正在被调用。如果字段字符串相互匹配，那么就能够创建输出字符串 "(Julio)"，并能够提供输出字符串的长度。

仅当应用程序决定向回调字段提供文本的内容时，才使用X的数量。在处理FormatSize事件时，文本的大小可以被编程计算。

可以通过使用多个 "X" 字符来产生唯一的回调字段。因此，格式字符串 "XXddddMMMdd'、'yyyXXX" 包含两个回调字段。回调字段是有效字段，所以应用程序必须准备处理Key事件。


DayBold 属性

返回或设置一个值，决定所显示的日份是否用粗体。

语法

object.DayBold(date) [= boolean]

DayBold 属性的语法包括以下部分：

部分 | 描述
Object | 一个对象表达式，其值为“应用于”列表中的对象。
Date | 一个日期表达式，指定VisibleDate 属性中的一个日期。
Boolean | 一个布尔表达式，指定该日期是否用粗体显示。

设置值

boolean 的设置值为：

设置值 | 描述
True | 该日期用粗体显示。
False | （缺省值）该日期不用粗体显示。

说明

DayBold 属性是一个对应于VisibleDays 属性的数组。每个布尔元素表示是否以粗体显示所对应的日期。

只有当前显示的日期才是合法的。可以通过查看 VisibleDays 属性来得到合法的日期。

当从一个月份移动到另一个月份时，该属性的信息不会被保留。


DayBold 属性示例

下述代码将第一个和最后一个显示日期设置为粗体。要检验该示例，请将一个 MonthView 控件放置到一个窗体上，将代码粘贴到Declarations部分。运行该工程，并双击该窗体。

Private Sub Form_DblClick()
   With MonthView1
      .DayBold(MonthView1.VisibleDays(1)) = True
      .DayBold(MonthView1.VisibleDays(42)) = True
   End With
End Sub


DayOfWeek 属性

返回或设置一个值，指出当前为星期几的数值。

语法

object.DayOfWeek [= number]

DayOfWeek 属性的语法包括以下部分：

部分 | 说明
Object | 一个对象表达式，其值为“应用于”列表中的对象。
Number | 一个数值表达式，指出是星期几，如下面的“设置值”所示。

设置值

number 的设置值为：

常数 | 值 | 描述
MvwSunday | 1 | （缺省值）星期日
MvwMonday | 2 | 星期一
MvwTuesday | 3 | 星期二
MvwWednesday | 4 | 星期三
MvwThursday | 5 | 星期四
MvwFriday | 6 | 星期五
MvwSaturday | 7 | 星期六

说明

DayOfWeek 属性可以设置为从 0 到 6 的任意整数。


Day 属性

返回或设置一个值，指出当前的日期数。

语法

object.Day [= number]

Day 属性的语法包括以下部分：

部分 | 描述
Object | 一个对象表达式，其值为“应用于”列表中的对象。
Number | 一个数值表达式，其值为一个表示日期数的整数。

说明

Day 属性可以设置为从1 到 31 的任意整数。


Format属性（DateTimePicker 控件）

返回或设置一个值，决定在控件中显示文本所使用的格式类型。

语法

object.Format [= integer]

Format属性语法有以下部分：

部分 | 描述
object | 一个对象表达式，其值是“应用于”列表中的一个对象。
integer | 一个值，指定控件中显示文本所使用的格式样式。如设置值所示。

设置值

intege的设置值为：

常数 | 值 | 描述
DtpLongDate | 0 | 长型数据格式（例如： "Friday, Nov 14, 1972" ）。
dtpShortDate | 1 | 短型数据格式（例如： "11/14/72" ）。
dtpTime | 2 | 时间格式（例如 "5:31:47 PM" ）。
dtpCustom | 3 | 用户自定义格式。

说明

将 Format 属性设置位 dtpCustom 来使用 CustomFormat 属性。


Hour属性

返回或设置一个值，指定当前所显示的小时的数值。

语法

object.Hour [= value]

Hour 属性语法有如下部分：

部分 | 描述
object | 一个对象表达式，其值是“应用于”列表中的一个对象。
value | 一个数值表达式，指定当前所显示的小时的数值

说明

Hour属性可以是从0到23的任意整数值。


Increment 属性

设置或返回一个值，它决定 Value 属性在 UpDown 控件的按钮被单击时改变的量。

语法

object.Increment [= value ]

Increment 属性的语法包含下面部分：

部分 | 描述
object | 对象表达式，其值是“应用于”列表中的一个对象。
value | 长整数，它决定 Value 属性改变的量。value 不能是负数。value 的缺省值是 1。

说明

在 UpDown 控件上单击箭头按钮时，Increment 属性决定 Value 属性改变的量。单击向上或向右箭头，使 Value 向着 Max 属性变化，变化量由 Increment 属性指定。单击向下或向左箭头，使 Value 向着 Min 属性变化，变化量由 Increment 属性指定。


MaxDate, MinDate 属性

返回或设置该日历所允许的第一天和最后一天。

语法

object.MaxDate [= date]

object.MinDate [= date]

MaxDate 和 MinDate 属性的语法包括以下部分：

部分 | 描述
Object | 一个对象表达式，其值为“应用于”列表中的对象。
Date | 一个日期表达式，其值为一个合法的日期。

说明

MaxDate 属性用于设置日历的上限。

MinDate 属性用于设置日历的下限。


Max 属性

为 UpDown 控件设置或返回滚动范围的最大值。

语法

object.Max [= value]

Max 属性的语法包含下面部分：

部分 | 描述
object | 对象表达式，其值是“应用于”列表中的一个对象。
Value | 指定最大值的长整数值，指定方式如下所述。value 设置值可为负。

说明

按向上或向右箭头通常是使 UpDown 控件 Value 属性值增加，但是，如果 Max 属性值小于 Min 属性值，则 UpDown 控件操作反向。

按向上或向右箭头总是使 Value 属性值接近 Max 值。按向下或向左箭头总是使 Value 属性接近 Min 值。


MaxSelCount 属性

返回或设置一次可以选择的连续日期的最大数目。

语法

object.MaxSelCount [= number]

MaxSelCount 属性的语法包括以下部分：

部分 | 描述
Object | 一个对象表达式，其值为“应用于”列表中的对象。
Number | 一个数值表达式，其值为一次可以选择的日期数。

说明

只有当MultiSelect 属性为 True 时，MaxSelCount 属性才有效。此外，MaxSelCount 属性必须设置为一个大于 SelStart 和 SelEnd 属性之差的一个值。例如，给定从 9/15 到 9/18 的一个选择范围，则 MonthView.SelEnd - MonthView.SelStart = 3。然而，由于实际上选择了四天，因此MaxSelCount 必须设为 4。

该属性的缺省值是一个星期（即 7 天）。


Min 属性

为 UpDown 控件设置或返回滚动范围的最小值。

语法

object.Min [= value]

Min 属性的语法包含下面部分：

部分 | 描述
object | 对象表达式，其值是“应用于”列表中的一个对象。
Value | 指定最小值的长整数，指定方式如下所述。value 的设置值可为负。

说明

按向下或向左箭头通常是使 UpDown 控件 Value 属性值减小。但是，如果 Min 属性值大于 Max 属性值，则 UpDown 控件操作反向。

按向下或向左箭头总是使 Value 属性值接近 Min 属性值。按向上或向右箭头总是使 Value 属性值接近 Max 属性值。


Minute属性

返回或设置一个值，指定当前所显示的分钟的数值。

语法

object.Minute [= value]

Minute 属性语法上有如下部分：

部分 | 描述
object | 一个对象表达式，其值是“应用于”列表中的一个对象。
value | 一个数值表达式，指定当前所显示的分钟的数值。

说明

Minute属性可以是从0到59的任意整数。


MonthBackColor 属性

返回或设置一个值，指定在月份中所显示的背景色。

语法

object.MonthBackColor [= color]

MonthBackColor 属性的语法包括以下部分：

部分 | 描述
object | 一个对象表达式，其值为“应用于”列表中的对象。
color | 一个数值或常数，用于确定在月份中所显示的背景色，如“设置值”中所描述的。

设置值

Visual Basic 使用 Microsoft Windows 操作环境的红-绿-蓝 (RGB) 配色方案。color 的设置值为：

设置值 | 描述
标准 RGB 颜色 | 通过使用“颜色”调色盘或在代码中使用 RGB 或 QBColor 函数指定的颜色。
系统缺省颜色 | 由对象浏览器中的 Visual Basic (VBRUN) 对象库所列出的系统颜色常数指定的颜色。Windows操作环境将替换用户在控制面板中的设置值。

说明

MonthBackColor 属性可以与 TitleBackColor、TitleForeColor 以及 TrailingForeColor 属性一起使用来自定义控件的颜色。

一个标准的 RGB 颜色的合法范围是从 0 到 16,777,215 (&HFFFFFF)。这一范围中的值的高字节为 0，低三位字节，从最低到最高字节，即决定了红、绿、蓝三种颜色各自的量。红、绿、蓝每一种成分都可以由一个从 0 到 255 (&HFF) 之间的数值表示。如果高字节不为 0，Visual Basic将使用用户在控制面板中设置的系统颜色，和对象浏览器的 Visual Basic (VB) 对象库中所列出的常数代表的颜色。


MonthColumns, MonthRows 属性

返回或设置一个值，指出横向和纵向显示的月份数目。

语法

object.MonthColumns [= number]

object.MonthRows [= number]

MonthColumns 和 MonthRows 属性的语法包括以下部分：

部分 | 描述
Object | 一个对象表达式，其值为“应用于”列表中的对象。
Number | 一个数值表达式，指定月份的数目。

说明

MonthColumns 和 MonthRows 属性使您可以一次显示多个月份。

MonthColumns 属性允许您指定横向显示的月份数目。MonthRows 属性允许您指定纵向显示的月份数目。

该控件可以显示多至十二个月。


Month 属性

返回或设置一个值，指出当前的月份。

语法

object.Month [= number]

Month 属性的语法包括以下部分：

部分 | 描述
object | 一个对象表达式，其值为“应用于”列表中的对象。
number | 一个常数或数值表达式，其值为一个表示月份的整数，如“设置值”所示。

设置值

number 的设置值为：

常数 | 值 | 描述
mvwJanuary | 1 | January
mvwFebruary | 2 | February
mvwMarch | 3 | March
mvwApril | 4 | April
mvwMay | 5 | May
mvwJune | 6 | June
mvwJuly | 7 | July
mvwAugust | 8 | August
mvwSeptember | 9 | September
mvwOctober | 10 | October
mvwNovember | 11 | November
mvwDecember | 12 | December

说明

Month 属性可以设置为从1 到12 的任意整数。


MultiSelect 属性 （MonthView 控件）

返回或设置一个值，决定是否可以一次选择多个日期。

语法

object.MultiSelect [= boolean]

MultiSelect 属性的语法包括以下部分：

部分 | 描述
object | 一个对象表达式，其值为“应用于”列表中的对象。
boolean | 一个布尔表达式，用于说明该控件所表现出的选择行为。

设置值

boolean 的设置值为：

设置值 | 描述
True | （缺省值）用户可以一次选择多个日期。
False | 用户不可以一次选择多个日期。

说明

缺省情况下，该控件允许用户选择一个日期范围。缺省的最大范围是一个星期（即 7 天）。通过设置MaxSelCount 属性，可以更改这个最大的可选择范围。Value 属性将在这一范围中，指出哪个日期有焦点。


Orientation 属性

在 UpDown 控件上设置或返回箭头按钮的位置。这个属性在运行时是只读的。

语法

object.Orientation

Orientation 属性的语法部分有：

部分 | 描述
object | 对象表达式，其值是“应用于”列表中的一个对象。

设置值

Orientation 属性的设置值是：

常数 | 值 | 描述
cc2orientationVertical | 0 | （缺省）箭头按钮垂直放置。
cc2orientationHorizontal | 1 | 箭头按钮水平放置。

说明

设计时，这个属性可在“属性”窗口或通过控件的属性页进行设置。

设置 Orientation 属性时，UpDown 控件本身便自动重新在其伙伴控件旁边定位。


Orientation 属性 （FlatScrollBar 控件）

返回或设置一个值。该值决定了对象的方向（水平或垂直）

语法

object.Orientation [= integer]

Orientation 属性的语法有如下部分：

部分 | 描述
object | 一个对象表达式，其值是“应用于”列表中的一个对象。
integer | 一个数值表达式，决定控件的方向，如“设置值”中所示。

设置值

integer 的设置值为：

常数 | 值 | 描述
cc2OrientationHorizontal | 0 | （缺省）该控件是水平方向的。
cc2OrientationVertical | 1 | 该控件是垂直方向的。


ScrollRate 属性

返回或设置一个值，指出当用户单击一个滚动按钮时滚动的月份数目。

语法

object.ScrollRate [= number]

ScrollRate 属性的语法包括以下部分：

部分 | 描述
object | 一个对象表达式，其值为“应用于”列表中的对象。
number | 一个数值表达式，指定一次滚动的月份数目。

说明

ScrollRate 属性允许用户一次滚卷多个月份。


Second属性

设置或返回一个整数，代表当前所显示秒的数值。

语法

object.Second [= integer]

Second 属性语法有如下部分：

部分 | 描述
object | 一个对象表达式，其值是“应用于”列表中的一个对象。
integer | 一个数值表达式，其值在0和59之间，表示秒的数值。


SelEnd、SelStart 属性 （MonthView 控件）

返回或设置所选择的日期范围的上限和下限。

语法

object.SelEnd [= date]

object.SelStart [= date]

SelEnd 和 SelStart 属性的语法包括以下部分：

部分 | 描述
Object | 一个对象表达式，其值为“应用于”列表中的对象。
Date | 一个日期表达式，其值为一个合法的日期。

说明

SelStart 属性定义了所选择的日期范围的下限。SelEnd 属性则定义了所选择的日期范围的上限。

所选择的日期范围可以跨越多个月份。它可以包括目前没有显示的日期。

如果要使多个日期选择能正确工作，则必须将 MaxSelCount 属性设置为一个大于SelStart 和 SelEnd 属性之差的值。

只有当MultiSelect 属性被设置为 TRUE时，SelStart 和 SelEnd 的设置值才是合法的。


SelEnd、 SelStart 属性示例

假设 MaxSelCount 属性被设为 7，则下述代码将选择从1998 年 11 月 8 日到 1998年11月 14 日之间的日期：

With MonthView1
   .MultiSelect = True
   .Value = CDate("11/8/98")
   .SelStart = CDate("11/8/98")
   .SelEnd = CDate("11/14/98")
End With

设置 Value 属性时会自动将 SelStart 和 SelEnd 属性设为同一日期。如果不首先设置Value 属性，则设置 SelStart 属性将选择从目前所选择的日期到 SelStart 日期之间的所有日期。


ShowToday 属性

返回或设置一个值，决定是否在该控件的底部显示当前日期。

语法

object.ShowToday [= boolean]

ShowToday 属性的语法包括以下部分：

部分 | 描述
Object | 一个对象表达式，其值为“应用于”列表中的对象。
Boolean | 一个布尔表达式，指定当前日期指示器的状态。

设置值

boolean 的设置值为：

设置值 | 描述
True | （缺省值）显示当前日期。
False | 不显示当前日期。


ShowWeekNumbers 属性

返回或设置一个值，决定是否在每个星期的相邻位置显示星期序号。

语法

object.ShowWeekNumbers [= boolean]

ShowWeekNumbers 属性的语法包括以下部分：

部分 | 描述
object | 一个对象表达式，其值为“应用于”列表中的对象。
boolean | 一个布尔表达式，指出当前日期指示器的状态。

设置值

boolean 的设置值为：

设置值 | 描述
True | 显示星期序号。
False | （缺省值）不显示星期序号。

说明

星期序号在星期的左边显示，且序号从日历年份的第一个星期开始。


StartOfWeek 属性

返回或设置一个值，指定星期的开始日期。

语法

object.StartOfWeek [= integer]

StartOfWeek 属性的语法包括以下部分：

部分 | 描述
Object | 一个对象表达式，其值为“应用于”列表中的对象。
Integer | 一个数值表达式，指定一个星期的开始日期，如“设置值”中所示。

设置值

integer 的设置值为：

常数 | 值 | 描述
MvwSunday | 0 | （缺省值）星期日
MvwMonday | 1 | 星期一
MvwTuesDay | 2 | 星期二
MvwWednesday | 3 | 星期三
MvwThursday | 4 | 星期四
MvwFriday | 5 | 星期五
MvwSaturday | 6 | 星期六

说明

使用 StartOfWeek 属性可以指定将显示在日历最左边的日期。这一点在为多个国家/地区设计应用程序时可能会很有用。


SyncBuddy 属性

设置或返回一个值，它决定 UpDown 控件是否使 Value 属性与伙伴控件中的某一属性同步。

语法

object.SyncBuddy [= value]

SyncBuddy 属性的语法包含下面部分：

部分 | 描述
object | 对象表达式，其值是“应用于”列表中的一个对象。
value | 布尔表达式，它决定伙伴控件是否与 UpDown 控件同步，决定方式按“设置值”中的描述。

设置值

对 value 的设置值是：

设置值 | 描述
True | UpDown 控件使 Value 属性与 BuddyProperty 属性所指定的伙伴控件的属性同步。如果在 BuddyProperty 属性中没有属性指定，则对伙伴控件使用缺省属性。
False | （缺省）UpDown 控件不使 Value 属性与伙伴控件中的属性同步。

说明

使用 SyncBuddy 属性可使伙伴控件的属性与 UpDown 控件的 Value 属性自动同步。例如，可以将 UpDown 控件的 Value 属性与 TextBox 控件的 Text 属性同步。Value 属性一改变，TextBox 控件中的 Text 属性就更新，反之亦然。也可以使 UpDown 控件的 Value 属性与一个控件的其它属性，如 Top、Left、BackColor、ForeColor 等同步。

为了查看可以与 Value 属性同步的可用属性的列表（设置 BuddyControl 属性之后），可在属性窗口中或从“属性页”中选择 BuddyProperty 属性。


TitleBackColor、 TitleForeColor 属性

返回或设置用于指定该控件的标题域的背景色和前景色的数值。

语法

object.TitleBackColor [= color]

object.TitleForeColor [= color]

TitleBackColor 和 TitleForeColor 属性的语法包括以下部分：

部分 | 描述
Object | 一个对象表达式，其值为“应用于”列表中的对象。
Color | 一个数值或常数，决定所用的颜色。

设置值

Visual Basic 使用 Microsoft Windows 操作系统的红-绿-蓝 (RGB) 配色方案。color 的设置值为：

设置值 | 描述
标准的 RGB 颜色 | 通过使用Color调色盘或在代码中使用 RGB 或 QBColor 函数指定的颜色。
系统缺省颜色 | 由对象浏览器的 Visual Basic (VBRUN) 对象库中列出的系统颜色常数所指定的颜色。Windows操作环境将替换用户在控制面板中的设置值。

说明

TitleBackColor 和 TitleForeColor 属性可以和 MonthBackColor 以及 TrailingForeColor 属性一起使用来自定义该控件的颜色。

一个标准的 RGB 颜色的合法范围是从 0 到 16,777,215 (&HFFFFFF)。这一范围中的值的高字节为 0，低三位字节，从最低到最高字节，即决定了红、绿、蓝三种颜色各自的量。红、绿、蓝每一种成分都可以由一个从 0 到 255 (&HFF) 之间的数值表示。如果高字节不为 0，Visual Basic将使用用户在控制面板中设置的系统颜色，和对象浏览器的 Visual Basic (VBRUN) 对象库中所列出的常数代表的颜色。


TitleBackColor、TitleForeColor、 TrailingForeColor 属性示例

该示例通过重新设置 TitleBackColor、TitleForeColor 以及 TrailingForeColor 属性，来更改 MonthView 控件的外观。要检验该示例，请将一个 MonthView 控件放置到一个窗体中，然后将代码粘贴到代码模块的Declarations部分。运行该工程，并双击该窗体来察看日历的改动。

Private Sub Form_DblClick()
   With MonthView1
      .TitleBackColor = vbBlue
      .TitleForeColor = vbWhite
      .TrailingForeColor = vbRed
   End With
End Sub


TrailingForeColor 属性

返回或设置一个值，指出当前显示的后续日期的前景色。

语法

object.TrailingForeColor [= color]

TrailingForeColor 属性的语法包括以下部分：

部分 | 描述
Object | 一个对象表达式，其值为“应用于”列表中的对象。
Color | 一个数值或常数，决定color of trailing dates，如“设置值”中所描述的。

设置值

Visual Basic 使用 Microsoft Windows 操作系统的红-绿-蓝 (RGB) 配色方案。color 的设置值为：

设置值 | 描述
标准的 RGB 颜色 | 通过使用“颜色”调色盘或在代码中使用 RGB 或 QBColor 函数指定的颜色。
系统缺省颜色 | 由对象浏览器中的 Visual Basic (VBRUN) 对象库所列出的系统颜色常数指定的颜色。Windows操作环境将替换用户在控制面板中的设置值。

说明

后续日期是在当前所选择的月份之前或之后显示的天数。缺省情况下，后续日期用 vbWhite 颜色显示。

TrailingForeColor 属性可以与 MonthBackColor、TitleBackColor 以及 TitleForeColor 属性一起使用自定义控件的颜色。

一个标准的 RGB 颜色的合法范围是从 0 到 16,777,215 (&HFFFFFF)。这一范围中的值的高字节为 0，低三位字节，从最低到最高字节，即决定了红、绿、蓝三种颜色各自的量。红、绿、蓝每一种成分都可以由一个从 0 到 255 (&HFF) 之间的数值表示。如果高字节不为 0，Visual Basic将使用用户在控制面板中设置的系统颜色，以及对象浏览器的 Visual Basic (VBRUN) 对象库中所列出的常数代表的颜色。


UpDown属性

返回或设置一个值，决定是否在DateTimePicker控件的右边显示一个up-down控件。

语法

object.UpDown [= boolean]

UpDown 属性语法有如下部分：

部分 | 描述
object | 一个对象表达式，其值是“应用于”列表中的一个对象。
Boolean | 一个布尔表达式，指定是否在DateTimePicker控件的右边显示一个up-down控件。

设置值

boolean 的设置值为：

设置值 | 描述
True | 显示一个up-down控件。
False | （缺省）不显示一个up-down控件。

说明

上下按钮可以替代下拉日历来选择日期。


Value 属性 （MonthView、 DatePicker 控件）

返回或设置当前显示的日期。

语法

object.Value [= date]

Value 属性的语法包括以下部分：

部分 | 描述
Object | 一个对象表达式，其值为“应用于”列表中的对象。
date | 一个日期表达式，指定由该控件所显示的日期。

说明

Value 属性是该控件的缺省属性。


Value 属性（UpDown 控件）

设置或返回滚动值的当前位置。

语法

object.Value [= long]

Value 属性的语法包含下面部分：

部分 | 描述
object | 对象表达式，其值是“应用于”列表中的一个对象。
long | 指定当前值的长整数，指定方式如下所描述。

说明

Value 属性指定在 Min 和 Max 属性值范围中的当前值。在单击箭头按钮时，Value 属性值被增加或减小。Min 和 Max 属性的设置值决定在单击箭头按钮时属性值是增加还是减小。

如果 SyncBuddy 属性设置为 True，在 Value 属性有变化或在 BuddyProperty 属性值被改变时，BuddyProperty 属性被同步。


VisibleDays 属性

返回一个包含当前可见日期的数组。

语法

object.VisibleDays(index)

VisibleDays 属性的语法包括以下部分：

部分 | 描述
Object | 一个对象表达式，其值为“应用于”列表中的对象。
Index | 一个整数，指定在日历上显示的日期。

说明

Index 可以是从 1 到 42 的任意值。如果值为 1 则表示是目前所显示的第一天。

只有目前所显示的日期才能在 VisibleDays 属性中找到。此外，可以根据 MonthColumns 和 MonthRows 属性的设置值来更改可见日期的天数。

如果从一个月份移动到另一个月份，则该属性中的信息不会被保留。


VisibleDays 属性示例

下列代码将打印在日历上所显示的所有日期。要检验该示例，请将一个 MonthView 控件放置到一个窗体中，然后将代码粘贴到 Declarations部分。运行该工程，并双击该窗体。

Private Sub Form_DblClick()
   Dim i As Integer
   For i = 1 To 42
      Debug.Print MonthView1.VisibleDays(i)
   Next i
End Sub


Week 属性

返回或设置一个值，指出当前的星期序号。

语法

object.Week [= number]

Week 属性的语法包括以下部分：

部分 | 描述
Object | 一个对象表达式，其值为“应用于”列表中的对象。
Number | 一个数值表达式，其值为一个表示星期序号的整数。

说明

Week 属性可以设置为从1 到 52 的任意整数。


Wrap 属性

设置或返回一个值，一旦它到达 Max 或 Min 值，便决定控件的 Value 属性是向始端还是向末端环绕。

语法

object.Wrap [= value]

Wrap 属性的语法包含下面部分：

部分 | 描述
object | 对象表达式，其值是“应用于”列表中的一个对象。
value | 布尔表达式，它决定 UpDown 控件其 Value 属性是否环绕，决定方式如“设置值”中所描述。

设置值

对 value 的设置值：

设置值 | 描述
True | 当使用箭头按钮移动 Value 属性超过 Max 或 Min 属性值时，UpDown 控件便向始端或末端环绕 Value 属性。
False | （缺省）UpDown 控件 Value 属性不环绕。

说明

在 Wrap 是 True 时，Value 属性按 Min、Max 和 Increment 属性值环绕。

当 Value 属性环绕时，它首先是跳到 Min 值。例如，如果 Min 是 20、Max 是 70、Increment 是 10、Value 是 70，且单击向上或向右按钮，Value 属性将环绕到 20。


Wrap 属性示例

该示例通过 UpDown 控件使用 Wrap 属性，创建值域从 10 至 70 和 增量为 10 的环绕旋转器控件。要试用此例，在窗体上安放 TextBox 控件和 UpDown 控件并添加以下代码：

Private Sub Form_Load()
   UpDown1.BuddyControl = Text1
   With UpDown1
      .Min = 10
      .Max = 70
      .Increment = 10
      .Wrap = True
      .SyncBuddy = True
   End With

   '于是 TextBox 就能反应起始值
   Text1.Text = UpDown1.Value
End Sub


Year 属性

返回或设置用于指定日历年份的数值。

语法

object.Year [= number]

Year 属性的语法包括以下部分：

部分 | 描述
Object | 一个对象表达式，其值为“应用于”列表中的对象。
Number | 一个数值表达式，其值为一个表示年份的整数。

说明

Year 属性可以设置为从 1601 到 9999 的任意整数。


Year属性（ActiveX控件）

返回或设置当前所显示的年份。

语法

object.Year [= number]

Second 属性语法有如下部分：

部分 | 描述
object | 一个对象表达式，其值是“应用于”列表中的一个对象。
number | 一个数值表达式，在MinDate和MaxDate属性值之间。