CoolBar 控件

CoolBar 控件包含一个Band对象集合，用于产生与窗体相关联的可配置工具条。

说明

CoolBar 控件是容器控件，它一般包含两个或多个可以由用户重新定义大小和重新调整的 Bands。每一个 Band 包含一个单一的 Child 控件。


Topic Not Found

未找到该主题

未找到相匹配的主题。可能的原因和解决方法如下：

  • 包含目标主题的文件 (.chm) 没有位于指定的位置。

    解决方法：重新运行 MSDN Library的安装。

  • 包含当前主题或目标主题的文件 (.chm) 已经过时，并且链接不再有效。

    解决方法：安装最新版本的 MSDN Library。

  • MSDN Library CD 不在 CD-ROM 中。

    解决方法：将 MSDN Library CD 装入 CD-ROM 中。


Bands 集合

一个集合，其元素代表CoolBar控件上的带区。Bands集合具有Count 属性，它指定集合内的Band 对象数目。

语法

object.Bands.Count

object.Bands (index)

Bands 集合语法有以下部分:

部分 | 描述
object | 一个对象表达式，它给 CoolBar 控件赋值。
index | 一个整数，其范围从1到 Bands.Count 。

说明

Bands集合列举CoolBar 控件上的带区。例如，可以用它来改变一个控件所有带区的 BackColor 属性。

注意 Bands集合不是Visual Basic Collection类的成员；无法创造其实例。


HeightChanged事件

当一个CoolBar 控件的 Height 改变时发生.。

语法

Private Sub object_HeightChanged([index As Integer], newheight As Single)

HeightChanged事件语法有这些部分:

部分 | 描述
object | 一个对象表达式，它给 CoolBar控件赋值。
index | 一个整数，其值唯一识别控件组中的一个控件。
newheight | 一个单精度浮点数来指定控件新高度。

说明

当 CoolBar 高度需要改变时，HeightChanged事件在Resize 事件之后发生。当用户在运行时重新排列带区或当一个或多个带区的高度按程序改变时，这个事件可以发生。

当 CoolBar由一个能抑制变化的容器宿驻时，该事件有用。在这种情况下，在Resize事件过程中读取Height属性可能不可靠或者 Resize事件可能不能被抑制。 HeightChanged事件允许您添加代码来使CoolBar控件正常显示。


Add方法（Bands集合）

添加一个新的Band对象到带区集合中。

语法

object.Add ([index As Long], [key As String], [caption As String], [image As Variant], [newrow As Boolean], [child As Object], [visible As Boolean])

Add 方法语法含有这些部分:

部分 | 描述
object | 一个对象表达式，它给CoolBar控件的 Bands 集合赋值。
Index | 选项。一个长整数，它在 Bands 集合中唯一识别一个带区。
key | 选项。一个识别 Band 对象的一个唯一字符串。用这个值检索一个指定的 Band 对象。
caption | 选项。一个含有显示在带区上标题的字符串。
image | 选项。来指定与 object 一起使用的 ListImage 对象的一个整数或唯一字符串。这个整数是Index 属性的值，字符串是 Key 属性的值。
newrow | 选项。缺省 = False。指定新的带区是否将显示在它自己行上的布尔表达式。
child | 选项。指定控件将成为带区子控件的一个对象引用。
visible | 选项。缺省 = False。指定在运行时新带区是否可见的一个布尔表达式。


Bands 对象

一个Band对象，代表 CoolBar 控件Bands集合的单个带区。

说明

带区是 CoolBar 控件内部的一个区域，它可以包含单个子控件、标题和图象。每一个Band可以由用户在运行时单独移动和重新定义大小。

在设计时，使用CoolBar 控件的“属性页”中“带区”制表符的“插入带区”和“删除带区”按钮，可以向Bands集合内插入和删除Band对象。在运行时，可以用Bands集合的Add和Remove方法来添加和删除Band对象。


AllowVertical 属性（Band对象）

返回或设置一个值，表示当 CoolBar 控件的取向设置为竖直时是否显示带区。

语法

object.AllowVertical [= boolean]

AllowVertical 属性语法有以下部分:

部分 | 描述
object | 一个对象表达式，它给 CoolBar 控件的Band对象赋值。
booleam | 一个布尔表达式 ，它指定带区是可见的或隐藏的。

设置值

booleam设置值为:

设置值 | 描述
True | (缺省值) 带区可见。
False | 带区隐藏。

说明

当 Orientation 设置为竖向时，要在启动时隐藏带区，应在设计时将 AllowVertical 属性设定为 False。在代码中设定该属性，使您在运行时能够响应特定的事件而隐藏或重新显示带区。

注意 当 Orientation 属性设置为竖向时，为了使带区可见，AllowVertical 和 Visible 二者必须是 True。如果二者任何一个是 False，则带区将不可见。


BandBorders 属性

返回或设置一个值，表示CoolBar控件是否显示分割带区的窄线。

语法

object.BandBorders [= boolean]

BandBorders 属性语法有以下部分:

部分 | 描述
object | 一个对象表达式，它给 CoolBar 控件赋值。
boolean | 一个布尔表达式 ，指定带区边框是可见的或者是隐藏的。

设置值

booleam设置值为:

设置值 | 描述
True | （缺省值）边框可见。
False | 边框隐藏。

说明

为了删除带区之间的边框，应该在设计时将 BandBorders 属性设定为 False。在代码中设定该属性，可使您在运行时响应特定的事件而隐藏或显示带区之间的边框。设置该属性影响 CoolBar 控件内的所有带区。

注意 BandBorders 属性不影响 CoolBar 自身的外部边框。CoolBar 边框总是显示。


Bands 属性

返回一个对 CoolBar 控件的Band对象集合的引用。

语法

object.Bands

object 所在处是一个对象表达式，用于给CoolBar控件赋值。

说明

可以用标准的集合方法（如 Add 和 Remove 方法）处理Band对象。集合内的每一个元素都可以按其索引值（Index属性值）或唯一的键值（Key属性值）访问。


Caption 属性 （Band对象）

返回或设置出现在 CoolBar 控件中Band对象上的标题。

语法

object.Caption [= string]

Caption 属性语法有以下部分：

部分 | 描述
object | 一个对象表达式，它给CoolBar 控件的Bands集合内的一个Band赋值。
string | 一个字符串表达式，内容是标题中显示的文本。

说明

标题在移动柄和子控件之间按左对齐方式显示。当一个带区竖直显示时，带区的宽度是依赖于标题宽度的。


Child 属性 （Band对象）

设置或返回对CoolBar 控件上的Band对象内的一个子控件的引用。

语法

Set object.Child = control

object.Child

Child 属性语法有以下部分：

部分 | 描述
object | 一个对象表达式，它给CoolBar 控件的Bands集合内的Band赋值。
control | 一个表达式，它给CoolBar 控件Band对象内的一个控件赋值。

说明

在设计时可以通过在 CoolBar 控件“属性页”内“带区”选项卡中，从“Child”列表选择一个控件来设置带区的“Child”属性。运行时可以通过读取 Child 属性来检索Band对象上控件的名称。

要在运行时给带区指定新的子控件，应使用 Set 关键字。这将替换Band对象上的现有控件。


EmbossHighlight 属性

设置或返回CoolBar 控件中所显示图象的增强亮度颜色。

语法

object.EmbossHighlight [= color]

EmbossHighlight 属性语法有以下部分：

部分 | 描述
object | 一个对象表达式，它给 CoolBar 控件赋值。
color | 一个数值或者常数，它决定一个对象的背景或前景的颜色，如设置值所示。

设置值

Visual Basic 采用 Microsoft Windows 操作环境的红-绿-蓝（RGB）配色方案。颜色的设置值如下：

设置值 | 描述
正常 RGB 颜色 | 通过颜色调色板指定，或者在代码中使用RGB 或 QBColor 函数来指定。
系统缺省颜色 | 由“对象浏览器”的Visual Basic (VB) 对象库列出的系统颜色常数指定。Windows 操作环境将替换用户在控制面板中的设置。

说明

EmbossHighlight 属性的缺省设置是由常数 vbButtonHighlight 指定的系统缺省颜色。

一个正常 RGB 颜色的有效范围是 0 到 16,777,215 (&HFFFFFF)。一个在该范围内的数的高字节等于 0；更低三位字节，从最低到最高有效字节，分别决定了红、绿和蓝的数量。红、绿和蓝的成分的每一个分别用 0 和 255 (&HFF)之间的一个数字代表。如果高字节不是 0，Visual Basic 使用系统颜色，如在用户“控制面板”设置值定义的，它由Visual Basic (VB) 对象浏览器的对象库列出的常数定义的。

注意 除非CoolBar 控件的 Picture 属性包含一个有效的图象，并且 EmbossPicture 属性设为 True，该属性不影响图象的显示。


EmbossPicture 属性

返回或设置一个值，表示 CoolBar 控件上的背景图片是以双色还是以多色显示。

语法

object.EmbossPicture [= boolean]

EmbossPicture 属性语法有以下部分：

部分 | 描述
object | 一个对象表达式 ，它给CoolBar 控件赋值。
boolean | 一个布尔表达式，它指定背景图片是以双色还是以多色显示。

设置值

booleam设置如下：

设置值 | 描述
False | （缺省值）背景图片是以多色显示的。
True | 背景图片是以双色显示的。

说明

缺省CoolBar 控件上的背景颜色将用包含在图象文件中指定给 Picture 属性的颜色显示。当 EmbossPicture 属性为 True 时，背景图片将抖动到 EmbossHighlight 和 EmbossShadow 属性中定义的两种颜色

注意 除非 CoolBar 控件的 Picture 属性包含一个有效图象，该属性没有影响。如果包含Band对象的UseCoolbarPicture 属性设为 False ，则该属性对该Band没有影响。


EmbossShadow 属性

设置或返回 CoolBar 控件上显示的图象的背影颜色。

语法

object.EmbossShadow [= color]

EmbossShadow 属性语法有以下部分：

部分 | 描述
object | 一个对象表达式 ，它给 CoolBar 控件赋值。
color | 一个数值或常数，它决定一个对象的背景或前景颜色，如设置值所示的。

设置值

Visual Basic 采用 Microsoft Windows 操作环境的红-绿-蓝 （RGB） 配色方案。颜色的设置值如下：

设置值 | 描述
正常 RGB 颜色 | 使用颜色调色板或在代码中使用RGB 或 QBColor 函数指定。
系统缺省颜色 | 由“对象浏览器”的Visual Basic (VB) 对象库列出的系统颜色常数来指定。Windows 操作环境将替换用户在控制面板中的设置。

说明

EmbossShadow 属性的缺省设置是由常数 vbButtonFace 指定的系统缺省颜色。

一个正常 RGB 颜色的有效范围是 0 到 16,777,215 (&HFFFFFF)。一个在该范围内数的高字节等于 0；更低三位字节从最低到最高有效字节，分别决定红、绿和蓝的数量。红、绿和蓝的成分的每一个分别用 0 和 255 (&HFF) 之间的一个数字代表。如果高字节不是 0，Visual Basic 使用系统颜色，如在用户“控制面板”设置值定义的，它由在Visual Basic (VB)对象浏览器的对象库列出的常数定义的。

注意 除非 CoolBar 控件的 Picture 属性包含一个有效的图象，且 EmbossPicture 属性设为 True，该属性不影响图象的显示。


FixedBackground 属性 （Band对象）

设置或返回一个值，表示 CoolBar 控件上的背景图片当带区重新排列时是否保持固定。

语法

object.FixedBackground [= boolean]

FixedBackGround 属性语法有以下部分：

部分 | 描述
object | 一个对象表达式，它给Band 控件赋值。
boolean | 一个布尔表达式，它指定背景图片为固定还是可移动。

设置值

booleam设置值如下：

设置值 | 描述
True | （缺省值）背景图片固定。
False | 背景图片不固定。

说明

CoolBar 控件的 Picture 属性的缺省行为是用 CoolBar 控件的 “Top”和“ Left”作为起点在控件上跨所有带区上平铺显示图片。如果带区重新排列或重新调整其大小，图片跨所有带区重绘。

当 FixedBackground 属性设置为 False 时，图片在控件上的每个带区内平铺显示。如果带区重新排列或重新调整其大小，图片在每个带区内保持固定。

注意 该属性只适用于 CoolBar 自身的 Picture 属性。如果图片指定给Band对象的 Picture 属性且该带区的 UseCoolbarPicture 属性设置为 False ，则 FixedBackground 属性对该带区没有影响。


FixedOrder 属性

设置或返回一个值，表示是否允许用户在运行时重新排列 CoolBar 控件上带区的顺序。

语法

object.FixedOrder [= boolean]

FixedOrder 属性语法有以下部分：

部分 | 描述
object | 一个对象表达式，它给 CoolBar 控件赋值。
boolean | 一个布尔表达式，它指定带区可见还是隐藏。

设置值

booleam设置值如下：

设置值 | 描述
False | （缺省值）带区可重新排列。
True | 带区不能重新排列。

说明

设计时. 要固定 CoolBar 控件上带区的排列，将 FixedOrder 属性设为 True 。这将阻止用户利用拖放重新排列带区。以代码的形式设定该属性您可在运行时响应一个特定事件时禁用或启用重新排列带区的能力。设定该属性影响 CoolBar 控件包含的所有带区。


Image 属性 （Band 对象）

返回或设置一个值，它指定在 ImageList 控件内的哪一个 ListImage 对象将出现在 Coolbar 控件的 Band 对象上。

语法

object.Image [= index]

Image属性语法有以下部分：

部分 | 描述
object | 一个对象表达式，它给Band对象赋值。
index | 指定与 object 一起使用的 ListImage 对象的整数或唯一字符串。整数为Index 属性的值，而字符串为 Key 属性的值。

说明

在设定Image 属性之前，您必须通过将CoolBar 的 ImageList 属性设定给一个 ImageList 控件将ImageList 控件和 CoolBar 控件关联起来。

在运行时，包含在 Image 属性中所指定的 ListImage 对象的图象将在位于移动柄和标题之间的Band对象上显示。图象在设计时不显示出来。


MinHeight, MinWidth 属性 （Band对象）

设置或返回一个值，表示Band对象可调整到那一个最小的高度和宽度。

语法

object.MinHeight [= single]

object.MinWidth [= single]

MinHeight and MinWidth属性语法有以下部分：

部分 | 描述
object | 一个对象表达式，它给 Band 对象赋值。
single | 一个单精度浮点数值，来表示高度或宽度。

说明

缺省 MinHeight 的值等于 Band 对象的子控件的 Height。您可把 MinHeight 设置到一个很大的值， 但您不能重新调整Band低于缺省值以下。

注意 当 CoolBar 的 Orientation 设为竖向时， MinHeight 则变为 MinWidth 而 MinWidth 则变为 MinHeight。


NewRow 属性

设置或返回Band对象是否在 CoolBar 控件的新一行中显示。

语法

object.NewRow [= boolean]

NewRow 属性语法有以下部分：

部分 | 描述
object | 一个对象表达式，它给Band 对象赋值。
boolean | 一个布尔表达式，来指定是否在新一行显示带区。

设置值

布尔设置值为：

设置值 | 描述
False | （缺省值）带区将加入到现存最后一行。
True | 带区将从新的一行开始。

注意 NewRow 属性不影响Bands集合内的第一个Band对象。第一个Band总是从新的一行开始。


Orientation属性 （Coolbar 控件）

设定一个值，表示CoolBar 控件是横向还是竖向。

语法

object.Orientation [= enum]

Orientation 属性语法有这些部分:

部分 | 描述
object | 一个对象表达式，它给 CoolBar 控件赋值。
enum | 一个常数或数值，用于指定方向，如设置值所示。

设置值

enum 的设置值是:

常数 | 值 | 描述
cc3OrientationHorizontal | 0 | (缺省) 横向。
cc3OrientationVertical | 1 | 竖向。


Picture属性（Coolbar 控件）

返回或设置一个在控件中显示的图形。

语法

object.Picture = LoadPicture(pathname)

object.Picture [= picture]

Picture 属性语法有这些部分:

部分 | 描述
object | 一个对象表达式，其值是“应用于”列表中的一个对象。
pathname | 一个字符串表达式来指定含有图形的文件的路径和文件名，如设置值所示的。
picture | Form 对象的 Picture 属性，PictureBox 控件，或Image 控件。

设置值

picture 设置是:

设置值 | 描述
(none) | (缺省) 无图片.
(Bitmap, GIF, JPEG) | 指定一个图形。设计时您可从“属性页”加载一个图形。运行时您也可使用 LoadPicture 函数设置这个属性。

说明

CoolBar 控件的 Picture 属性显示在任意一个子控件后面跨 CoolBar 控件上所有带区的背景图形。 每一个CoolBar 控件上的Band对象也有一个 Picture 属性和一个可用来覆盖控件上Picture 属性的 UseCoolBarPicture 属性。


Position属性 （Band对象）

返回 CoolBar 控件内Band对象的位置。

语法

object.Position [= integer]

Position 属性语法有这些部分:

部分 | 描述
object | 一个对象表达式，它给Band对象赋值。
integer | 一个整数来表示目前位置。

说明

Position 属性可用来决定 CoolBar控件内一个Band的当前位置。然而Band的Index保持不变时，重新排列带区 Position 发生变化。

对于处在左上角位置上的Band其Position 属性起始值为1，并且当CoolBar为横向时它从左到右、从上到下增加。当它为竖向时其 Position从上到下，从左到右增加。


RowCount属性（Coolbar控件）

返回在 CoolBar控件上显示的行数。

语法

object.RowCount [= number]

RowCount 属性语法有这些部分:

部分 | 描述
object | 一个对象表达式，它给 CoolBar控件赋值。
number | 一个长整数来指示行数。

说明

CoolBar 控件所显示的行数并不一定要与带区数相同，因为在一行中可以显示多个带区。


Style属性（Band对象）

设置或返回一个值，指示CoolBar控件中Band对象的大小变化行为。

语法

object.Style [= enum]

Style属性语法有这些部分:

部分 | 描述
object | 一个对象表达式，它给 Band 对象赋值。
enum | 一个常数或数值来指定样式，如设置值所示的。

设置值

enum 的设置值是:

常数 | 值 | 描述
cc3BandNormal | 0 | (缺省) 带区大小可以调整。仅当 CoolBar 控件中含有两个或多个带区时显示调整块。
cc3BandFixedSize | 1 | 带区大小不能调整。不显示调整块。


UseCoolbarColors属性

设置或返回是否Band对象采将使用 CoolBar 控件的 ForeColor 和 BackColor 属性。

语法

object.UseCoolbarColors [= boolean]

UseCoolbarColors 属性语法有这些部分:

部分 | 描述
object | 一个对象表达式，它给Band对象赋值。
boolean | 一个 布尔表达式，来指定带区是否将覆盖 CoolBar 控件的 ForeColor 和 BackColor 。

设置值

boolean 的设置值是:

设置 | 描述
True | (缺省) Band 将使用 CoolBar控件的 ForeColor和 BackColor属性显示。
False | Band将使用它自己的ForeColor 和 BackColor属性显示。


UseCoolbarPicture属性

设置或返回是否Band对象将使用CoolBar 控件的Picture 属性。

语法

object.UseCoolbarPicture [= boolean]

UseCoolbarPicture 属性语法有这些部分:

部分 | 描述
object | 一个对象表达式，它给 Band 对象赋值。
boolean | 一个布尔表达式，它指定带区的 Picture属性是否将覆盖CoolBar 控件的Picture 。

设置值

boolean 的设置值是:

设置 | 描述
True | (缺省) Band 将显示 CoolBar控件的 Picture.
False | Band 将显示它自己的 Picture .


VariantHeight属性

返回或设置一个数值来指示 CoolBar控件是否采用同一高度显示所有的带区。

语法

object.VariantHeight [= boolean]

VariantHeight 属性有这些部分:

部分 | 描述
object | 一个对象表达式，它给 CoolBar控件赋值。
boolean | 一个布尔表达式，指定所有带区是否是同一高度。

设置值

boolean 的设置值是:

设置 | 描述
True | (缺省) 带区高度可能变化。
False | 带区高度相等。

说明

当该属性被设置成False时， CoolBar控件将基于全部可见带区最大的 MinHeight属性来显示所有带区。当该属性被设置成True时，如果每行只有一个带区，每个带区的高度就是基于它自己的MinHeight 属性。如果在一行中有多个带区，这些带区将利用所有在这行中可见带区的最大的 MinHeight属性来显示。