MSChart 控件

以图形方式显示数据的图表。

语法

MSChart

说明

MSChart 控件支持以下特性：

  • 真三维表示。

  • 支持所有主要的图表类型。

  • 数据网格成员支持随机数据，数据数组。

MSChart 控件与数据网格（DataGrid 对象）相关连。这种数据网格是存有已图表化数据的表。数据网格中也包括用于在图表中标识系列和分类的标签。图表应用程序的设计人员通过从表单或数组中插入或输入数据，来给数据网格填充信息。


Topic Not Found

未找到该主题

未找到相匹配的主题。可能的原因和解决方法如下：

  • 包含目标主题的文件 (.chm) 没有位于指定的位置。

    解决方法：重新运行 MSDN Library的安装。

  • 包含当前主题或目标主题的文件 (.chm) 已经过时，并且链接不再有效。

    解决方法：安装最新版本的 MSDN Library。

  • MSDN Library CD 不在 CD-ROM 中。

    解决方法：将 MSDN Library CD 装入 CD-ROM 中。


Tick 属性

Tick 对象

沿图表坐标轴标识图表项的标记。

语法

Tick


DataPoints 集合

图表数据点组。

语法

object.DataPoints.(index)

DataPoints 集合的语法包含下面部分：

部分 | 描述
object | 对象表达式，其值是“应用于”列表的一个对象。
index | 标识当前系列中的特定数据点。在这个版本的图表中，该参数唯一有效的设置值是 -1。可变更系列中所有数据点的缺省设置值。但是，不能变更系列中的单个数据点的设置值。


DataPoints 集合示例

下面的示例为图表中的数据点设置标记。

Private Sub Command1_Click()
   With MSChart1.Plot.SeriesCollection(1).DataPoints(-1)
   '将数据点标记设置成可见的。
      .Marker.Visible = True
      .Marker.Style = VtMarkerStyleDiamond
   End With

End Sub

Datapoints 集合的 Item 方法使用特殊的 -1 参数，指定系列中所有数据点的缺省属性。可以象操作普通的 Datapoint 对象一样操作 Item(-1) 返回的 Datapoint 对象。在这个缺省数据点设置的属性将影响系列中的所有数据点，但是，单独设置该属性的那些数据点除外。在示例中，将每个数据点标签设置在三个不同的位置。在缺省设置之前或之后设置个别数据点没有区别；个别的设置值总是覆盖缺省设置值。可用 ResetCustom 方法删除数据点的任何个别设置值，并使之使用系列的缺省设置值。

Option Explicit
Option Base 1
Private Sub Command1_Click()
   With MSChart1.Plot
      .SeriesCollection(1).DataPoints.Item(-1) _
      .DataPointLabel.LocationType = VtChLabelLocationTypeAbovePoint

      .SeriesCollection(2).DataPoints.Item(-1) _
      .DataPointLabel.LocationType = VtChLabelLocationTypeCenter

      .SeriesCollection(3).DataPoints.Item(-1) _
      .DataPointLabel.LocationType = VtChLabelLocationTypeBase
   End With
End Sub


Labels 集合

一组图表的坐标轴标签。

语法

axis.Labels(index)

Labels 集合的语法包含下面部分：

部分 | 描述
axis | Axis 对象。
index | 标识当前集合中的特定坐标轴标签（Label 对象）。


LightSource 集合示例

下面的示例设置一个光源的坐标和强度，然后在图表中添加光源光源。试着使用该示例，请在窗体上绘制一个 MSChart 和两个 CommandButton 控件。将代码粘贴到Form 对象的代码模块并运行该工程。单击该按钮更改光源。

Option Explicit

Private Sub Form_Load()
   ' 配置图表及其光源。
   With MSChart1
      .chartType = VtChChartType3dBar
      .Plot.Light.AmbientIntensity = 0.01 ' 1 % 强度。
      .Plot.Light.EdgeIntensity = 0.5      ' 50 % 强度。
      .Plot.Light.EdgeVisible = True
   End With
End Sub
Private Sub Command1_Click()
   Dim LightSource As Object
   Set LightSource = _
   MSChart1.Plot.Light.LightSources(1)
   '设置光源 1 的坐标及其
   '强度。
   LightSource.X = 1
   LightSource.Y = 0.5
   LightSource.Z = 1
   LightSource.Intensity = 1
End Sub

Private Sub Command2_Click()
   '添加新光源。
   MSChart1.Plot.Light.LightSources.Add 0.5, 0.1, 1, 1
End Sub


LightSources 集合

图表中的一组 LightSource 对象。

语法

object.LightSources(index)

LightSources 集合的语法包含下面部分：

部分 | 描述
object | 对象表达式，其值是“应用于”列表中的一个对象。
index | Integer。唯一标识集合成员的数字。


Series 集合

图表系列集合。

语法

Series (index)

Series 集合的语法包括以下部分：

部分 | 描述
index | Integer。标识图表的系列。从 1 开始，按数据网格列的顺序来标识系列。


SeriesCollection 集合

该属性提供关于组成图表的系列的信息。

语法

SeriesCollection(index)

SeriesCollection 集合的语法包含下面部分：

部分 | 描述
index | 标识系列集合中的特定系列。


Series，SeriesCollection 集合示例

下面的示例隐藏图表中所有的系列。

Private Sub Command1_Click()
   Dim serX As Series
   '隐藏所有系列。
   For Each serX In MSChart1.Plot.SeriesCollection
      serX.Position.Hidden = True
   Next
End Sub


AngleUnits 常数

VtAngleUnits 提供度量图表角度的有效单位。

常数 | 描述
VtAngleUnitsDegrees | 以度数度量图表角度。
VtAngleUnitsRadians | 以弧度度量图表角度。
VtAngleUnitsGrads | 以梯度度量图表角度。


AxisId 常数

VtChAxisId 常数提供标识图表坐标轴的选项。

常数 | 描述
VtChAxisIdX | 标识 x 坐标轴。
VtChAxisIdY | 标识 y 坐标轴。
VtChAxisIdY2 | 标识次要 y 坐标轴。
VtChAxisIdZ | 标识 z 坐标轴。


AxisTickStyle 常数

VtChAxisTickStyle 常数提供选项，以指示坐标轴刻度标记位置。

常数 | 描述
VtChAxisTickStyleNone | 坐标轴上不显示刻度标记。
VtChAxisTickStyleCenter | 刻度标记位于坐标轴的中心。
VtChAxisTickStyleInside | 刻度标记显示在坐标轴内侧。
VtChAxisTickStyleOutside | 刻度标记显示在坐标轴外侧。


BorderStyle 常数 (MSChart)

VtBorderStyle 常数提供放置在图表控件周围的边框类型的选项。

常数 | 描述
VtBorderStyleFixedSingle | 在图表控件周围放置单线边框。
VtBorderStyleNone | 图表控件周围无边框。


BrushHatch 常数

如果将 VtBrushStyle 设置为 VtBrushStyleHatch，则 VtBrushHatch 提供有效的画笔类型。

常数 | 描述
VtBrushHatchHorizontal | 水平阴影线
VtBrushHatchVertical | 垂直阴影线
VtBrushHatchDownDiagonal | 向下的对角阴影线
VtBrushHatchUpDiagonal | 向上的对角阴影线
VtBrushHatchCross | 十字阴影线
VtBrushHatchDiagonalCross | 对角十字阴影线


BrushPattern 常数

如果将 VtBrushStyle 设置为 VtBrushStylePattern，则 VtBrushPattern 提供有效的画笔类型。

常数 | 描述
VtBrushPattern94percent | 94% 图案颜色
VtBrushPattern88percent | 88% 图案颜色
VtBrushPattern75percent | 75% 图案颜色
VtBrushPattern50percent | 50% 图案颜色
VtBrushPattern25percent | 25% 图案颜色
VtBrushPatternBoldHorizontal | 粗水平线
VtBrushPatternBoldVertical | 粗垂直线
VtBrushPatternBoldDownDiagonal | 向下的粗对角线
VtBrushPatternBoldUpDiagonal | 向上的粗对角线
VtBrushPatternChecks | Checks 图案
VtBrushPatternWeave | Weave 图案
VtBrushPatternHorizontal | 水平线
VtBrushPatternVertical | 垂直线
VtBrushPatternDownDiagonal | 向下对角线
VtBrushPatternUpDiagonal | 向上对角线
VtBrushPatternGrid | Grid 图案
VtBrushPatternTrellis | Trellis 图案
VtBrushPatternInvertedTrellis | 倒置的 trellis 图案


BrushStyle 常数

VtBrushStyle 提供有效的画笔类型。

常数 | 描述
VtBrushStyleNull | 无画笔（背景透出）。
VtBrushStyleSolid | 纯色画笔。
VtBrushStylePattern | 位图图案画笔。
VtBrushStyleHatched | 阴影画笔。


ChartType 常数

VtChChartType 提供图表类型选项。

常数 | 描述
VtChChartType3dBar | 3D 条形图
VtChChartType2dBar | 2D 条形图
VtChChartType3dLine | 3D 折线图
VtChChartType2dLine | 2D 折线图
VtChChartType3dArea | 3D 面积图
VtChChartType2dArea | 2D 面积图
VtChChartType3dStep | 3D 阶梯图
VtChChartType2dStep | 2D 阶梯图
VtChChartType3dCombination | 3D 组合图
VtChChartType2dCombination | 2D 组合图
VtChChartType2dPie | 2D 饼图
VtChChartType2dXY | 2D XY 散点图


DrawMode 常数

在图表变更之后，VtChDrawMode 常数提供重新显示图表的选项。

常数 | 描述
VtChDrawModeDraw | Draw 方式。每次图表设置值变更后在屏幕上重绘图表。
VtChDrawModeBlit | Blit 方式。在内存中重绘图表，重绘完成后才显示出来。

在放置图表时，Blit 模式将图表的副本存储在内存中。重新绘制图表时使用位图，绘制速度很快。这种模式需要的内存比 Draw 模式所需的内存多，但是它可以减少在屏幕上等待重绘图表的时间。使用包含多个元素的图表时，Blit 模式特别有用。


FillStyle 常数

VtFillStyle 常数提供指定用于绘制背景的填充类型的选项。

常数 | 描述
VtFillStyleNull | 无填充（背景透出）。
VtFillStyleBrush | 纯色或图案填充。


FontEffect 常数

VtFontEffect 为达到预期效果而提供变更字体的方法。

常数 | 描述
VtFontEffectStrikeThrough | 字体应用删除线属性。
VtFontEffectUnderline | 字体应用下划线属性。


FontStyle 常数

VtFontStyle 提供有效的字体属性选项。

常数 | 描述
VtFontStyleBold | 字体应用粗体属性。
VtFontStyleItalic | 字体应用斜体属性。
VtFontStyleOutline | 字体应用轮廓属性。


FrameStyle 常数

VtFrameStyle 常数提供显示背景框架的选项。

常数 | 描述
VtFrameStyleNull | 无框架。
VtFrameStyleSingleLine | 背景周围围绕单线。
VtFrameStyleDoubleLine | 背景周围围绕两条等宽线。
VtFrameStyleThickInner | 背景周围围绕一条粗的内线和一条细的外线。
VtFrameStyleThickOuter | 背景周围围绕一条细的内线和一条粗的外线。


HorizontalAlignment 常数

VtHorizontalAlignment 常数提供文本对齐方式的选项。

常数 | 描述
VtHorizontalAlignmentLeft | 所有文本行向左边界对齐。
VtHorizontalAlignmentRight | 所有文本行向右边界对齐。
VtHorizontalAlignmentCenter | 所有文本行水平居中。


LabelComponent 常数

VtChLabelComponent 常数提供显示图表标签的选项。

常数 | 描述
VtChLabelComponentValue | 数据点数值出现在标签中。散点图表、极坐标图表和气泡图表中的数据点实际包含两个或三个数值。这些图表的缺省标签以标准格式显示所有数值。但是也可以自定义这种格式，以突出显示单个的数据值。
VtChLabelComponentPercent | 在标签中将数据点数值显示成该数据点数值占系列总数值的百分比。
VtChLabelComponentSeriesName | 用系列名称来标注数据点。该名称源于与数据网格列关联的标签。
VtChLabelComponentPointName | 用数据点名称来标注数据点。


LabelLineStyle 常数

VtChLabelLineStyle 常数提供选项，以供在显示连接标签和系列的线段时作选项。

下表列出了 VtChLabelLineStyle 有效的常数：

常数 | 描述
VtChLabelLineStyleNone | 标签和系列之间没有线段连接。
VtChLabelLineStyleStraight | 标签和系列之间用直线连接。
VtChLabelLineStyleBent | 标签和直线之间用弯曲线连接。


LabelLocationType 常数

VtChLabelLocationType 常数提供决定系列标签位置的选项。

下表列出了 VtChLabelLocationType 有效的常数：

常数 | 描述
VtChLabelLocationTypeNone | 不显示标签。
VtChLabelLocationTypeAbovePoint | 标签显示在数据点上方。
VtChLabelLocationTypeBelowPoint | 标签显示在数据点下方。
VtChLabelLocationTypeCenter | 标签显示在数据点正中。
VtChLabelLocationTypeBase | 标签沿分类坐标轴显示在图表底部，并位于数据点的正下方。
VtChLabelLocationTypeInside | 标签显示在饼图的饼块内部。
VtChLabelLocationTypeOutside | 标签显示在饼图的饼块外部。
VtChLabelLocationTypeLeft | 标签显示在数据点左侧。
VtChLabelLocationTypeRight | 标签显示在数据点右侧。


LocationType 常数

VtChLocationType 为图表元素提供了以下位置选项。

常数 | 示例
VtChLocationTypeTop | 顶部
VtChLocationTypeTopLeft | 左上角
VtChLocationTypeTopRight | 右上角
VtChLocationTypeLeft | 左边
VtChLocationTypeRight | 右边
VtChLocationTypeBottom | 底部
VtChLocationTypeBottomLeft | 左下角
VtChLocationTypeBottomRight | 右下角
VtChLocationTypeCustom | 自定义


MarkerStyle 常数

VtMarkerStyle 常数提供了以下用于显示数据点标记的选项。

常数 | 描述
VtMarkerStyleNull | 标记为空
VtMarkerStyleDash | 标记为短线
VtMarkerStylePlus | 标记为加号
VtMarkerStyleX | 标记为 X 符号
VtMarkerStyleStar | 标记为星号
VtMarkerStyleCircle | 标记为圆
VtMarkerStyleSquare | 标记为正方形
VtMarkerStyleDiamond | 标记为菱形
VtMarkerStyleUpTriangle | 标记为上三角形
VtMarkerStyleDownTriangle | 标记为下三角形
VtMarkerStyleFilledCircle | 标记为填充的圆
VtMarkerStyleFilledSquare | 标记为填充的正方形
VtMarkerStyleFilledDiamond | 标记为填充的菱形
VtMarkerStyleFilledUpTriangle | 标记为填充的上三角形
VtMarkerStyleFilledDownTriangle | 标记为填充的下三角形
VtMarkerStyle3dBall | 标记为立体球


MouseFlag 常数

VtChMouseFlag 指示按鼠标按钮时处于按下状态的键盘键。

常数 | 描述
VtChMouseFlagShiftKeyDown | 按鼠标按钮时 SHIFT 键处于按下状态。
VtChMouseFlagControlKeyDown | 按鼠标按钮时 CONTROL 键处于按下状态。


MousePointer 常数

VtMousePointer 常数提供了以下光标类型。

常数 | 描述
VtMousePointerArrow | 箭头光标
VtMousePointerArrowHourGlass | 箭头和沙漏
VtMousePointerArrowQuestion | 箭头和问号
VtMousePointerCross | 十字光标
VtMousePointerDefault | 缺省的图表光标
VtMousePointerHourGlass | 沙漏光标
VtMousePointerIbeam | Ibeam 光标
VtMousePointerIcon | 其中有一个小正方形的正方形光标
VtMousePointerNoDrop | 禁止放下的光标
VtMousePointerSize | 可调大小的箭头
VtMousePointerSizeAll | 可任意方向调节大小的箭头
VtMousePointerSizeNESW | 东北-西南方向的双箭头
VtMousePointerNS | 南北向的双箭头
VtMousePointerNWSE | 西北-东南方向的双箭头
VtMousePointerWE | 东西向的双箭头
VtMousePointerUpArrow | 向上箭头


Orientation 常数

VtOrientation 常数提供了以下放置文本的选项。

常数 | 描述
VtOrientationHorizontal | 水平显示文本。
VtOrientationVertical | 文本中每个字母都从上至下显示在其后续字母的正上方。
VtOrientationUp | 将文本旋转为从下往上阅读。
VtOrientationDown | 将文本旋转为从上往下阅读。


PartType 常数

VtChPartType 常数提供了以下图表元素选项。

常数 | 描述
VtChPartTypeChart | 标识图表控件。
VtChPartTypeTitle | 标识图表标题。
VtChPartTypeFootnote | 标识图表脚注。
VtChPartTypeLegend | 标识图表图例。
VtChPartTypePlot | 标识图表绘图区。
VtChPartTypeSeries | 标识图表系列。
VtChPartTypePoint | 标识单个数据点。
VtChPartTypePointLabel | 标识数据点标签。
VtChPartTypeAxis | 标识坐标轴。
VtChPartTypeAxisLabel | 标识坐标轴标签。
VtChPartTypeAxisTitle | 标识坐标轴标题。


PenCap 常数

VtPenCap 常数提供显示线段端点的方法。

常数 | 描述
VtPenCapButt | 线段端点为方形。
VtPenCapRound | 线段端点为以线宽为直径的一个半圆。
VtPenCapSquare | 线段在端点处继续向外延伸半个线宽的距离，且结束处为方形。


PenJoin 常数

VtPenJoin 常数为系列中的线段提供了以下相接方式。

常数 | 描述
VtPenJoinMiter | 两条线的外边线继续延伸直至相遇。
VtPenJoinRound | 用一段圆弧围绕两条线的交点。
VtPenJoinBevel | 将两条线连接处的尖角截平。


PenStyle 常数

VtPenStyle 常数为图表画笔提供了以下线型样式。

常数 | 描述
VtPenStyleNull | 空画笔
VtPenStyleSolid | 实线画笔
VtPenStyleDashed | 虚线画笔
VtPenStyleDotted | 点线画笔
VtPenStyleDashDot | 点划线画笔
VtPenStyleDashDotDot | 点点划画笔
VtPenStyleDitted | 短线（Ditted line）画笔
VtPenStyleDashDit | 长短线（Dash-ditted line）画笔
VtPenStyleDashDitDit | 短短长线（Dash-dit-dit line）画笔


PercentAxisBasis 常数

VtChPercentAxisBasis 常数为显示百分制坐标轴提供了以下方法。

常数 | 描述
VtChPercentAxisBasisMaxChart | 将图表中的最大值作为百分之百，图表上显示的是各个值对应这个值的百分比。
VtChPercentAxisBasisMaxRow | 将每一行中的最大值作为百分之百，图表上显示的是各个值对应其所在行的最大值的百分比。
VtChPercentAxisBasisMaxColumn | 将每一系列中的最大值作为百分之百，图表上显示的是各个值对应其所在系列的最大值的百分比。
VtChPercentAxisBasisSumChart | 将图表中所有值相加所得的总和作为百分之百。图表上显示的是各个值对应总和的百分比。
VtChPercentAxisBasisSumRow | 将每一行中所有值相加所得的总和作为百分之百。显示的是各个值对应所在行的总和的百分比。这种方式是百分制堆放图表的基础。
VtChPercentAxisBasisSumColumn | 将每一系列中所有值相加所得的总和作为百分之百。图表上显示的是各个值对应其所属系列的总和的百分比。


PieWeightBasis 常数

VtChPieWeightBasis 常数为饼图图表的切片提供了以下显示方式。

常数 | 描述
VtChPieWeightBasisNone | 所有饼图的大小都一样。
VtChPieWeightBasisTotal | 计算每个饼图的切片值的总和，并标识具有最大总和的饼图。图表中每个饼图的大小则根据该饼图总和与最大饼图的比例来决定。
VtChPieWeightBasisSeries | 数据网格的第一列数据存放相对大小的索引，换句话说，如果有 5 类数据，通过在数据网格的第一列存放 1 至 5 的行编号，就可以控制表示每一类数据的饼图的大小。每个饼图的大小由该饼图的第一列中的值与第一列中最大值的比例决定。值为 1 则是最大的饼图，值为 5 则是最小的饼图。绘制饼图时，一般都把第一列中的数据都排除在外，以防止把这些数据作为一个饼图切片来画。


PieWeightStyle 常数

VtChPieWeightStyle 常数为在单一图表中显示独立饼图提供了以下方式。

常数 | 描述
VtChPieWeightStyleArea | 独立饼图根据其权值调整其区域。
VtChPieWeightStyleDiameter | 独立饼图根据其权值调整其直径。


ProjectionType 常数

VtProjectionType 常数为显示和查看图表提供了视点及透视选项。

常数 | 描述
VtProjectionTypePerspective | 该选项提供最逼真的三维效果。由近及远，对象逐渐向一个无限远的点会聚。该常量为缺省投影类型。
VtProjectionTypeOblique | 这种方式有时称为 2.5 维。图表确实有深度，但改变图表的转角和仰角时 xy 平面不变。
VtProjectionTypeOrthogonal | 这种三维观察方式没有应用透视效果。这种投影类型的主要优点是竖直线始终竖直，使有些图表比较容易看明白。


ScaleType 常数

VtChScaleType 常数为绘制图表值以及显示图表的刻度提供了以下方式。

常数 | 描述
VtChScaleTypeLinear | 使用线性刻度绘制图表值，值的范围从最小的图表值到最大的图表值。
VtChScaleTypeLogarithmic | 对图表值求以 logBase 为底的对数值，以此结果在对数刻度上进行绘制。
VtChScaleTypePercent | 根据图表值占图表值域的百分比，在线性刻度上绘制这些图表值。


SeriesType 常数

VtChSeriesType 常数提供了以下系列类型的选项。

常数 | 系列类型
VtChSeriesType3dBar | 三维直方图
VtChSeriesType2dBar | 二维直方图
VtChSeriesType3dLine | 三维折线图
VtChSeriesType2dLine | 二维折线图
VtChSeriesType3dArea | 三维面积图
VtChSeriesType2dArea | 二维面积图
VtChSeriesType3dStep | 三维阶梯图
VtChSeriesType2dStep | 二维阶梯图
VtChSeriesType2dXY | XY 散点图
VtChSeriesType2dPie | 二维饼图


ShadowStyle 常数

VtShadowStyle 常数提供以下阴影选项。

常数 | 描述
VtShadowStyleNull | 无阴影。
VtShadowStyleDrop | 点阴影。


SortType 常数

VtSortType 常数为饼图图表提供了以下排序方式。

常数 | 描述
VtSortTypeNone | 根据数据在数据网格中的顺序来绘制饼图的各个切片。
VtSortTypeAscending | 从指定的起始角以及指定的绘图方向开始，按顺序先画最小的饼图切片，再递增至最大的饼图切片。
VtSortTypeDescending | 从指定的起始角以及指定的绘图方向开始，按顺序先画最大的饼图切片，再递减至最小的饼图切片。


StatsType 常数

VtChStats 常数提供了在图表上显示统计线的方法。

常数 | 描述
VtChStatsMinimum | 显示该系列的最小值。
VtChStatsMaximum | 显示该系列的最大值。
VtChStatsMean | 显示该系列的数据值的数学期望。
VtChStatsStddev | 显示该系列的数据值的标准方差。
VtChStatsRegression | 显示系列中数据值所确定的趋势线。


SubPlotLabelLocationType 常数

VtSubPlotLabelLocationType 常数为显示子绘图区标签提供了以下方法。

常数 | 描述
VtChSubPlotLabelLocationTypeNone | 不显示子绘图区的标签。
VtChSubPlotLabelLocationTypeAbove | 在饼图上方显示子绘图区标签。
VtChSubPlotLabelLocationTypeBelow | 在饼图下方显示子绘图区的标签。
VtChSubPlotLabelLocationTypeCenter | 在饼图中央显示子绘图区的标签。


TextLengthType 常数

VtTextLengthType 常数为在屏幕或打印机上优化文本的输出效果提供了以下选项。

常数 | 描述
VtTextLengthTypeVirtual | 选择该常量则使用 TrueType 虚拟字体的尺寸来优化打印机上的文本输出效果。TrueType 虚拟字体的尺寸对于显示在屏幕上的文本还不是十分精确。在屏幕上显示的文本的大小可能与该虚拟尺寸的大小不一样。在指定的位置可能会放不下比该尺寸大的文本，可能会出现半边字符，整个字符，甚至一个单词丢失的现象。
VtTextLengthTypeDevice | 选择该常量来为屏幕的文本输出效果进行优化。图表中的文本在屏幕上的位置将总是恰好位于该图表区。打印时文本一般会小一点，因此打印文本的位置与屏幕上的位置有时会有细微的差别。


TextOutputType 常数

VtTextOutputType 常数为输出文本提供了以下方法：

常数 | 描述
VtTextOutputTypeHardware | 设备描述表类型为空。
VtTextOutputTypePolygon | 设备描述表类型为元文件（Metafile）。


UpdateFlags 常数

下面列出的 UpdateFlags 常数可以被用于多种事件中，来决定图的哪一部分被更新。

常数 | 值 | 描述
VtChNoDisplay | 0 | 忽略更新标志；不影响显示的图。
VtChDisplayPlot | 1 | 图将被重新绘制。
VtChLayoutPlot | 2 | 图将被重新布局。
VtChDisplayLegend | 4 | 图例将被重新绘制。
VtChLayoutLegend | 8 | 图例将被重新布局。
VtChLayoutSeries | 16 | 系列将重新布局。
VtChPositionSection | 32 | 一个图表部分已经被移动或调整大小。

说明

这些常数可以在下列事件中使用：

AxisLabelUpdated 事件

AxisTitleUpdated 事件

AxisUpdated 事件

ChartUpdated 事件

DataUpdated 事件

FootnoteUpdated 事件

LegendUpdated 事件

PlotUpdated 事件

PointLabelUpdated 事件

PointUpdated 事件

SeriesUpdated 事件

TitleUpdated 事件


VerticalAlignment 常数

VtVerticalAlignment 常数提供了以下垂直对齐文本的方法。

常数 | 描述
VtVerticalAlignmentTop | 所有的文本行均与上边距对齐。
VtVerticalAlignmentBottom | 所有的文本行均与下边距对齐。
VtVerticalAlignmentCenter | 所有的文本行均居中垂直对齐。


AxisActivated 事件

双击图表的坐标轴时，该事件发生。

语法

Private Sub object_AxisActivated ( axisId As Integer, axisIndex As Integer, mouseFlags As Integer, cancel As Integer )

AxisActivated 事件的语法包含下面部分：

部分 | 描述
object | 对象表达式，其值是“应用于”列表中的对象。
axisId | Integer。它标识特定的坐标轴，如“设置值”中所描述。
axisIndex | Integer。保留作以后使用。在这个版本的 MSChart 控件中，该参数唯一有效的设置值是 1。
mouseFlags | Integer。它指示单击鼠标按钮时是否还按下了某个按键，如“设置值”中所描述。
cancel | Integer。当前未使用的整数。

设置值

事件处理程序决定要激活的坐标轴并将 axisId 设置为：

常数 | 描述
VtChAxisIdX | 如果 x 坐标轴受影响。
VtChAxisIdY | 如果 y 坐标轴受影响。
VtChAxisIdY2 | 如果次要 y 坐标轴受影响。
VtChAxisIdZ | 如果 z 坐标轴受影响。

事件处理程序确定在单击鼠标按钮时是否还按下了某个按钮并将 mouseFlags 设置为：

常数 | 描述
VtChMouseFlagShiftKeyDown | 如果按下 SHIFT 键。
VtChMouseFlagControlKeyDown | 如果按下 CTRL 键。


AxisLabelActivated 事件

双击坐标轴标签时，该事件发生。

语法

Private Sub object_AxisLabelActivated (axisId As Integer, axisIndex As Integer, labelSetIndex As Integer, labelIndex As Integer, mouseflags As Integer, cancel As Integer)

AxisLabelActivated 事件的语法包含下面部分：

部分 | 描述
object | 对象表达式，其值是“应用于”列表中的对象。
axisId | Integer。它标识特定的坐标轴，如“设置值”中所描述。
axisIndex | Integer。保留作将来使用。在这个版本的 MSChart 控件中，该参数唯一有效的设置值为 1。
labelSetIndex | Integer。它标识正在双击的标签级别。标签级别编号从 1 开始，从坐标轴向外依次编号。
labelIndex | Integer。当前未使用该数值。
mouseflags | Integer。它指示单击鼠标按钮时是否还按下了某个按键。
cancel | Integer。当前未使用该数值。

设置值

事件处理程序确定选定的坐标轴标签并将 axisId 设置为：

常数 | 描述
VtChAxisIdX | 如果 x 坐标轴受到影响。
VtChAxisIdY | 如果 y 坐标轴受到影响。
VtChAxisIdY2 | 如果次要 y 坐标轴受到影响。
VtChAxisIdZ | 如果 z 坐标轴受到影响。

事件处理程序确定单击鼠标按钮时，是否按下了某个按键并将 mouseflags 设置为：

常数 | 描述
VtChMouseFlagShiftKeyDown | 如果按下 SHIFT 键。
VtChMouseFlagControlKeyDown | 如果按下 CTRL 键。


AxisLabelSelected 事件

单击坐标轴标签时，该事件发生。

语法

Private Sub object_AxisLabelSelected ( axisId As Integer, axisIndex As Integer, labelSetIndex As Integer, labelIndex As Integer, mouseflags As Integer, cancel As Integer )

AxisLabelSelected 事件的语法包含下面部分：

部分 | 描述
object | 对象表达式，其值是“应用于”列表中的对象。
axisId | Integer。它标识特定的坐标轴，如“设置值”中所描述。
axisIndex | Integer。保留作以后使用。在这个版本的 MSChart 控件中，该参数唯一有效的设置值为 1。
labelSetIndex | Integer。它标识正在双击的标签的级别。标签级别编号时从 1 开始，从坐标轴向外依次编号。
labelIndex | Integer。当前未使用该数值。
mouseflags | Integer。它标识单击鼠标按钮时是否还按下了某个按键，如“设置值”中所描述。
cancel | Integer。此时未使用该数值。

设置值

事件处理程序确定选定的坐标轴标签并将 axisId 设置为：

常数 | 描述
VtChAxisIdX | 如果 x 坐标轴受到影响。
VtChAxisIdY | 如果 y 坐标轴受到影响。
VtChAxisIdY2 | 如果次要 y 坐标轴受到影响。
VtChAxisIdZ | 如果 z 坐标轴受到影响。

事件处理程序确定单击鼠标按钮时，是否还按下了某个按键并将 mouseflags 设置为：

常数 | 描述
VtChMouseFlagShiftKeyDown | 如果按下 SHIFT 键。
VtChMouseFlagControlKeyDown | 如果按下 CTRL 键。


AxisLabelUpdated 事件

改变坐标轴标签时，该事件发生。

语法

Private Sub object_AxisLabelUpdated (axisId As Integer, axisIndex As Integer, labelSetIndex As Integer, labelIndex As Integer, updateFlags As Integer)

AxisLabelUpdated 事件的语法包含下面部分：

部分 | 描述
object | 对象表达式，其值是“应用于”列表中的对象。
axisId | Integer。它标识特定的坐标轴，如“设置值”中所描述。
axisIndex | Integer。保留作以后使用。在这个版本的 MSChart 控件中，该参数唯一有效的设置值为 1。
labelSetIndex | Integer。它标识所双击的标签的级别。标签级别编号时从 1 开始，从坐标轴向外依次编号。
labelIndex | Integer。当前未使用该数值。
updateFlags | Integer。它提供关于标签更新的信息，如“设置值”中所描述。

设置值

事件处理程序确定更新的坐标轴标签并将 axisId 设置为：

常数 | 描述
VtChAxisIdX | 如果 x 坐标轴受影响。
VtChAxisIdY | 如果 y 坐标轴受影响。
VtChAxisIdY2 | 如果次要 y 坐标轴受影响。
VtChAxisIdZ | 如果 z 坐标轴受影响。

事件处理程序决定更新的效果并将 updateFlag 设置为：

常数 | 描述
VtChNoDisplay | 缺少更新标志；图表显示不受影响（定义为 0）。
VtChDisplayPlot | 更新使图表区域重新绘制。
VtChLayoutPlot | 更新使图表区域重新布局。
VtChDisplayLegend | 更新将使图例重新绘制。
VtChLayoutLegend | 更新使图例重新布局。
VtChLayoutSeries | 更新使系列重新布局。
VtChPositionSection | 图表的某部分被移动或被改变大小。


AxisSelected 事件

单击图表坐标轴时，该事件发生。

语法

Private Sub object_AxisSelected (axisId As Integer, axisIndex As Integer, mouseflags As Integer, cancel As Integer )

AxisSelected 事件的语法包含下面部分：

部分 | 描述
object | 对象表达式，其值是“应用于”列表中的对象。
axisId | Integer。它标识特定的坐标轴，如“设置值”中所描述。
AxisIndex | Integer。保留作以后使用。这个版本的 MSChart 控件中，该参数唯一有效的设置值为 1。
mouseflags | Integer。它指示单击鼠标按钮时是否还按下了某个按键，如“设置值”中所描述。
cancel | Integer。当前未使用该数值。

设置值

事件处理程序确定选定的坐标轴并将 axisId 设置为：

常数 | 值 | 描述
VtChAxisIdX | 0 | 如果 x 坐标轴受影响。
VtChAxisIdY | 1 | 如果 y 坐标轴受影响。
VtChAxisIdY2 | 2 | 如果次要 y 坐标轴受影响。
VtChAxisIdZ | 3 | 如果 z 坐标轴受影响。
VtChAxisIDNone | 4 | 无坐标轴

事件处理程序确定在单击鼠标按钮时，是否还按下了某个按键并将 mouseflags 设置为：

常数 | 描述
VtChMouseFlagShiftKeyDown | 如果按下 SHIFT 键。
VtChMouseFlagControlKeyDown | 如果按下 CTRL 键。


AxisTitleActivated 事件

双击坐标轴标题时，该事件发生。

语法

Private Sub object_AxisTitleActivated ( axisId As Integer, axisIndex As Integer, mouseflags As Integer, cancel As Integer )

AxisTitleActivated 事件的语法包含下面部分：

部分 | 描述
object | 对象表达式，其值是“应用于”列表中的对象。
axisId | Integer。它标识特定的坐标轴。
AxisIndex | Integer。保留作以后使用。在这个版本的 MSChart 控件中，该参数唯一有效的设置值为 1。
mouseflags | Integer。它指示单击鼠标按钮时是否还按下了某个按键。
cancel | Integer。当前未使用该数值。

设置值

事件处理程序确定激活的坐标轴标题并将 axisId 设置为：

常数 | 值 | 描述
VtChAxisIdX | 0 | 如果 x 坐标轴受影响。
VtChAxisIdY | 1 | 如果 y 坐标轴受影响。
VtChAxisIdY2 | 2 | 如果次要 y 坐标轴受影响。
VtChAxisIdZ | 3 | 如果 z 坐标轴受影响。
VtChAxisIDNone | 4 | 无坐标轴

事件处理程序确定单击鼠标按钮时，是否还按下了某个按键并将 mouseflags 设置为：

常数 | 描述
VtChMouseFlagShiftKeyDown | 如果按下 SHIFT 键。
VtChMouseFlagControlKeyDown | 如果按下 CTRL 键。


AxisTitleSelected 事件

单击坐标轴标题时，该事件发生。

语法

Private Sub object_AxisTitleSelected ( axisId As Integer, axisIndex As Integer, mouseflags As Integer, cancel As Integer )

AxisTitleSelected 事件的语法包含下面部分：

部分 | 描述
object | 对象表达式，其值是“应用于”列表中的对象。
axisId | Integer。它标识特定的坐标轴。
AxisIndex | Integer。保留作以后使用。在这个版本的 MSChart 控件中，该参数唯一有效的设置为 1。
mouseflags | Integer。它指示当单击鼠标按钮时是否还按下了某个按键。
cancel | Integer。当前未使用此参数。

设置值

事件处理程序确定选定了哪一个坐标轴标题并将 axisId 设置为：

常数 | Value | 描述
VtChAxisIdX | 0 | 如果 x 坐标轴受影响。
VtChAxisIdY | 1 | 如果 y 坐标轴受影响。
VtChAxisIdY2 | 2 | 如果次要 y 坐标轴受影响。
VtChAxisIdZ | 3 | 如果 z 坐标轴受影响。
VtChAxisIDNone | 4 | 无坐标轴

事件处理程序确定单击鼠标按钮时是否还按下了某个按键并将 mouseflags 设置为：

常数 | 描述
VtChMouseFlagShiftKeyDown | 如果按下 SHIFT 键。
VtChMouseFlagControlKeyDown | 如果按下 CTRL 键。


AxisTitleUpdated 事件

坐标轴标题变更时，该事件发生。

语法

Private Sub object_AxisTitleUpdated ( axisId As Integer, axisIndex As Integer, updateFlags As Integer)

AxisTitleUpdated 事件的语法包含下面部分：

部分 | 描述
object | 对象表达式，其值是“应用于”列表中的对象。
axisId | Integer。它标识特定的坐标轴。
axisIndex | Integer。保留作以后使用。在这个版本的 MSChart 控件中，该参数唯一有效的设置值为 1。
updateFlags | Integer。它提供关于标题更新的信息。

设置值

事件处理程序确定更新的坐标轴并将 axisId 设置为：

常数 | 值 | 描述
VtChAxisIdX | 0 | 如果 x 坐标轴受影响。
VtChAxisIdY | 1 | 如果 y 坐标轴受影响。
VtChAxisIdY2 | 2 | 如果次要 y 坐标轴受影响。
VtChAxisIdZ | 3 | 如果 z 坐标轴受影响。
VtChAxisIDNone | 4 | 无坐标轴

下表列出了 updateFlags 参数使用的常数。

常数 | 描述
VtChNoDisplay | 缺少更新标志；图表显示不受影响。（定义为 0）
VtChDisplayPlot | 更新将重新绘制图表区域。
VtChLayoutPlot | 更新使图表区域重新布局。
VtChDisplayLegend | 更新使图例重新绘制。
VtChLayoutLegend | 更新使图例重新布局。
VtChLayoutSeries | 更新使系列重新布局。
VtChPositionSection | 图表的某部分被移动或被改变大小。


AxisUpdatedEvent

坐标轴变更时，该事件发生。

语法

Private Sub object_AxisUpdated ( axisId As Integer, axisIndex As Integer, updateFlags As Integer)

AxisUpdated 事件的语法包含下面部分：

部分 | 描述
object | 对象表达式，其值是“应用于”列表中的对象。
axisId | Integer。它标识特定的坐标轴。
axisIndex | Integer。保留作以后使用。在这个版本的 MSChart 控件中，该参数唯一有效的设置值为 1。
updateFlags | Integer。它提供关于坐标轴更新的信息。

设置值

事件处理程序确定更新的坐标轴并将 axisId 设置为：

常数 | 值 | 描述
VtChAxisIdX | 0 | 如果 x 坐标轴受影响。
VtChAxisIdY | 1 | 如果 y 坐标轴受影响。
VtChAxisIdY2 | 2 | 如果次要 y 坐标轴受影响。
VtChAxisIdZ | 3 | 如果 z 坐标轴受影响。
VtChAxisIDNone | 4 | 无坐标轴

下表列出了 updateFlags 参数使用的常数。

常数 | 描述
VtChNoDisplay | 缺少更新标志；图表显示不受影响。（定义为 0）
VtChDisplayPlot | 更新使图表区域重新绘制。
VtChLayoutPlot | 更新使图表区域重新布局。
VtChDisplayLegend | 更新使图例重新绘制。
VtChLayoutLegend | 更新使图例重新布局。
VtChLayoutSeries | 更新使系列重新布局。
VtChPositionSection | 图表的某部分被移动或被改变大小。


ChartActivated 事件

双击 Microsoft Chart 控件时，该事件发生，但是双击图表的特定元素时事件不发生。

语法

Private Sub object_ChartActivated ( mouseflags As Integer, cancel As Integer )

ChartActivated 事件的语法包含下面部分：

部分 | 描述
object | 对象表达式，其值是“应用于”列表中的对象。
mouseflags | Integer。它指示单击鼠标按钮时是否还按下了某个按键，如“设置值”中所描述。
cancel | Integer。当前未使用该参数。

设置值

事件处理程序确定单击鼠标按钮时是否还按下了某个按键并将 mouseflags 设置为：

常数 | 描述
VtChMouseFlagShiftKeyDown | 如果按下 SHIFT 键。
VtChMouseFlagControlKeyDown | 如果按下 CTRL 键。


ChartSelected 事件

单击 Microsoft Chart 控件时，该事件发生，但是单击图表的某个元素时事件不发生。

语法

Private Sub object_ChartSelected ( mouseflags As Integer, cancel As Integer )

ChartSelected 事件的语法包含下面部分：

部分 | 描述
object | 对象表达式，其值是“应用于”列表中的对象。
mouseflags | Integer。它指示单击鼠标按钮时是否还按下了某个按键，如“设置值”中所描述。
cancel | Integer。当前未使用该参数。

设置值

事件处理程序确定单击鼠标按钮时是否还按下了某个按键并将 mouseflags 设置为：

常数 | 描述
VtChMouseFlagShiftKeyDown | 如果按下 SHIFT 键。
VtChMouseFlagControlKeyDown | 如果按下 CTRL 键。


ChartUpdated 事件

当图表变更时，该事件发生。

语法

Private Sub object_ChartUpdated (updateFlags As Integer)

部分 | 描述
object | 对象表达式，其值是“应用于”列表中的对象。
updateFlag | Integer。提供关于图表更新的信息，如“设置值”中所描述。

设置值

下表列出了 updateFlag 参数使用的常数。

常数 | 描述
VtChNoDisplay | 缺少更新标志；不影响图表显示。（定义为 0）
VtChDisplayPlot | 更新使图表区域重新绘制。
VtChLayoutPlot | 更新使图表区域重新布局。
VtChDisplayLegend | 更新使图例重新绘制。
VtChLayoutLegend | 更新使图例重新布局。
VtChLayoutSeries | 更新使系列重新布局。
VtChPositionSection | 图表的某部分被移动或被改变大小。


DataUpdated 事件

图表数据网格变更时，该事件发生。

语法

Private Sub object_DataUpdated (row As Integer, column As Integer, labelRow As Integer, labelColumn As Integer, labelSetIndex As Integer, updateFlags As Integer)

DataUpdated 事件的语法包含下面部分：

部分 | 描述
object | 对象表达式，其值是“应用于”列表中的对象。
row | Integer。标识数据网格中的行。
column | Integer。标识数据网格中的列。
labelRow | Integer。标识行标签。
labelColumn | Integer。标识列标签。
labelSetIndex | Integer。标识标签级别。标签级从 1 开始、由坐标轴向外依次编号。
updateFlag | Integer。提供关于数据更新的信息，如“设置值”中所描述。

设置值

下表列出了 updateFlag 参数使用的常数。

常数 | 描述
VtChNoDisplay | 缺少更新标志；图表显示不受影响。（定义为 0）
VtChDisplayPlot | 更新使图表区域重新绘制。
VtChLayoutPlot | 更新使图表区域重新布局。
VtChDisplayLegend | 更新使图例重新绘制。
VtChLayoutLegend | 更新使图例重新布局。
VtChLayoutSeries | 更新使系列重新布局。
VtChPositionSection | 图表的某部分被移动或被改变大小。

说明

如果行和列非 0 值，则变更指定的数据单元。如果 labelRow 或 labelColumn 以及 labelSetIndex 都非 0 值，则变更指定的行或列标签。如果这些数值都不是非 0 值，则无法提供关于变更的特定信息。


DonePainting 事件

重新绘制图表后，该事件立即发生。

语法

Private Sub object_DonePainting ( )

object 所在处代表对象表达式，其值是“应用于”列表中的对象。


FootnoteActivated 事件

双击图表脚注时，该事件发生。

语法

Private Sub object_FootnoteActivated ( mouseflags As Integer, cancel As Integer )

FootnoteActivated 事件的语法包含下面部分：

部分 | 描述
object | 对象表达式，其值是“应用于”列表中的对象。
mouseFlag | Integer。它指示单击鼠标按钮时是否还按下了某个按键，如“设置值”中所描述。
cancel | 当前未使用该参数。

设置值

事件处理程序确定单击鼠标按钮时是否还按下了某个按键并将 mouseflags 设置为：

常数 | 描述
VtChMouseFlagShiftKeyDown | 如果按下 SHIFT 键。
VtChMouseFlagControlKeyDown | 如果按下 CTRL 键。


FootnoteSelected 事件

单击图表脚注时，该事件发生。

语法

Private Sub object_FootnoteSelected ( mouseflags As Integer, cancel As Integer )

FootnoteSelected 事件的语法包含下面部分：

部分 | 描述
object | 对象表达式，其值是“应用于”列表中的对象。
mouseflags | Integer。它指示单击鼠标按钮时是否还按下了某个按键，如“设置值”中所描述。
cancel | 当前未使用该参数。

设置值

事件处理程序确定单击鼠标按钮时是否还按下了某个按键并将 mouseflags 设置为：

常数 | 描述
VtChMouseFlagShiftKeyDown | 如果按下 SHIFT 键。
VtChMouseFlagControlKeyDown | 如果按下 CTRL 键。


FootnoteUpdated 事件

图表脚注变更时，该事件发生。

语法

Private Sub object_FootnoteUpdated (updateFlags As Integer)

FootnoteUpdated 事件的语法包含下面部分：

部分 | 描述
object | 对象表达式，其值是“应用于”列表中的对象。
updateFlag | Integer。提供有关脚注更新的信息，如“设置值”中所描述。

设置值

下表列出了 updateFlag 参数使用的常数。

常数 | 描述
VtChNoDisplay | 缺少更新标志；图表显示不受影响。（定义为 0）
VtChDisplayPlot | 更新使图表区域重新绘制。
VtChLayoutPlot | 更新使图表区域重新布局。
VtChDisplayLegend | 更新使图例重新绘制。
VtChLayoutLegend | 更新使图例重新布局。
VtChLayoutSeries | 更新使系列重新布局。
VtChPositionSection | 图表的某部分被移动或被改变大小。


LegendActivated 事件

双击图表图例时，该事件发生。

语法

Private Sub object_LegendActivated ( mouseFlags As Integer, cancel As Integer )

LegendActivated 事件的语法包含下面部分：

部分 | 描述
object | 对象表达式，其值是“应用于”列表中的对象。
mouseFlags | Integer。它指示单击鼠标按钮时是否还按下了某个按键，如“设置值”中所描述。
cancel | Integer。此时未使用此参数。

设置值

事件处理程序确定单击鼠标按钮时是否还按下了某个按键并将 mouseFlags 设置为：

常数 | 描述
VtChMouseFlagShiftKeyDown | 如果按下 SHIFT 键。
VtChMouseFlagControlKeyDown | 如果按下 CTRL 键。


LegendSelected 事件

单击图表的图例时，该事件发生。

语法

Private Sub object_LegendSelected ( mouseFlags As Integer, cancel As Integer)

LegendSelected 事件的语法包含下面部分：

部分 | 描述
object | 对象表达式，其值是“应用于”列表中的对象。
mouseFlags | Integer。它指示单击鼠标按钮时是否还按下了某个按键。
cancel | Integer。此时未使用此参数。

设置值

事件处理程序确定单击鼠标按钮时是否还按下了某个按键并将 mouseFlags 设置为：

常数 | 描述
VtChMouseFlagShiftKeyDown | 如果按下 SHIFT 键。
VtChMouseFlagControlKeyDown | 如果按下 CTRL 键。


LegendUpdated 事件

当图表的图例变更时，该事件发生。

语法

Private Sub object_LegendUpdated (updateFlags As Integer)

LegendUpdated 事件的语法包含下面部分：

部分 | 描述
object | 对象表达式，其值是“应用于”列表中的对象。
updateFlags | Integer。提供关于图例更新的信息，如“设置值”中所描述。

设置值

下表列出了 updateFlag 参数使用的常数。

常数 | 描述
VtChNoDisplay | 缺少更新标志；图表显示不受影响。（定义为 0）
VtChDisplayPlot | 更新使图表区域重新绘制。
VtChLayoutPlot | 更新使图表区域重新布局。
VtChDisplayLegend | 更新使图例重新绘制。
VtChLayoutLegend | 更新使图例重新布局。
VtChLayoutSeries | 更新使系列重新布局。
VtChPositionSection | 图表的某部分被移动或被改变大小。


PlotActivated 事件

双击图表绘图区时产生该事件。

语法

Private Sub object_PlotActivated ( mouseFlags As Integer, cancel As Integer)

PlotActivated 事件的语法包含下面部分：

部分 | 描述
object | 对象表达式，其值是“应用于”列表中的对象。
mouseFlags | Integer。表示当鼠标按下时，是否有键处于按下状态。如“设置值”中所描述。
cancel | Integer。目前没有使用该参数。

设置值

事件句柄确定当鼠标按下时是否有键处于按下状态，并据此将 mouseFlags 设为：

常数 | 描述
VtChMouseFlagShiftKeyDown | SHIFT 键处于按下状态。
VtChMouseFlagControlKeyDown | CONTROL 键处于按下状态。


PlotSelected 事件

单击图表绘图区时产生该事件。

语法

Private Sub object_PlotSelected ( mouseFlags As Integer, cancel As Integer)

PlotSelected 事件的语法包含下面部分：

部分 | 描述
object | 对象表达式，其值是“应用于”列表中的对象。
mouseFlags | Integer。表示当鼠标按下时，是否有键处于按下状态，如“设置值”中所描述。
cancel | Integer。此时没有使用该参数。

设置值

事件句柄确定单击鼠标按钮时是否有键处于按下状态，并据此将 mouseFlags 设为：

常量 | 描述
VtChMouseFlagShiftKeyDown | SHIFT 键处于按下状态。
VtChMouseFlagControlKeyDown | CONTROL 键处于按下状态。


PlotUpdated 事件

当图表绘图区被改动时产生该事件。

语法

Private Sub object_PlotUpdated (updateFlags As Integer)

PlotUpdated 事件的语法包含下面部分：

部分 | 描述
object | 对象表达式，其值是“应用于”列表中的对象。
updateFlags | Integer。提供有关绘图区的更新信息，如“设置值”中所描述。

设置

下表列出了用于 updateFlags 的常数。

常数 | 描述
VtChNoDisplay | 缺少更新标记；图表显示没有任何变化。（定义为 0）。
VtChDisplayPlot | 更新使绘图区重绘。
VtChLayoutPlot | 更新使绘图区重新布局。
VtChDisplayLegend | 更新使图例重绘。
VtChLayoutLegend | 更新使图例重新布局。
VtChLayoutSeries | 更新使系列重新布局。
VtChPositionSection | 图表的某部分被移动或调度大小。


PointActivated 事件

双击数据点时产生该事件。

语法

Private Sub object_PointActivated ( series As Integer, dataPoint As Integer, mouseFlags As Integer, cancel As Integer)

PointActivated 事件的语法包含下面部分：

部分 | 描述
object | 对象表达式，其值是“应用于”列表中的对象。
series | Integer。标识包含该数据点的系列。根据数据网格中列的显示顺序给系列编号，编号从 1 开始。
dataPoint | Integer。标识系列中的数据点。根据数据网格中行的显示顺序给数据点编号，编号从 1 开始。
mouseFlags | Integer。指示当鼠标按下时，是否有键处于按下状态。如“设置值”中所描述。
cancel | Integer。目前没有使用这个参数。

设置

事件句柄确定单击鼠标按钮时是否有键处于按下状态，并据此将 mouseFlags 设为：

常数 | 描述
VtChMouseFlagShiftKeyDown | SHIFT 键处于按下状态。
VtChMouseFlagControlKeyDown | CONTROL 键处于按下状态。


PointLabelActivated 事件

双击数据点标签时产生该事件。

语法

Private Sub object_PointLabelActivated ( series As Integer, dataPoint As Integer, mouseflags As Integer, cancel As Integer )

PointLabelActivated 事件的语法包含下面部分：

部分 | 描述
object | 对象表达式，其值是“应用于”列表中的对象。
series | Integer。标识包含该数据点的系列。根据数据网格中列的显示顺序给系列编号，编号从 1 开始。
dataPoint | Integer。标识系列中的数据点。根据数据网格中行的显示顺序给数据点编号，编号从 1 开始。
mouseFlags | Integer。指示单击鼠标按钮时，是否有键处于按下状态。如“设置值”中所描述。
cancel | Integer。目前没有使用这个参数。

设置值

事件句柄确定单击鼠标按钮时是否有键处于按下状态，并据此将 mouseFlags 设为：

常数 | 描述
VtChMouseFlagShiftKeyDown | SHIFT 键处于按下状态。
VtChMouseFlagControlKeyDown | CONTROL 键处于按下状态。


PointLabelSelected 事件

单击数据点标签时产生该事件。

语法

Private Sub object_PointLabelSelected ( series As Integer, dataPoint As Integer, mouseFlags As Integer, cancel As Integer)

PointLabelSelected 事件的语法包含下面部分：

部分 | 描述
object | 对象表达式，其的值是“应用于”列表中的对象。
series | Integer。标识包含该数据点的系列。根据数据网格中列的显示顺序给系列编号，编号从 1 开始。
dataPoint | Integer。标识系列中的数据点。根据数据网格中行的显示顺序给数据点编号，编号从 1 开始。
mouseFlags | Integer。指示单击鼠标按钮时，是否有键处于按下状态。如“设置值”中所描述。
cancel | Integer。目前没有使用这个参数。

设置值

事件句柄确定单击鼠标按钮时是否有键处于按下状态，并据此将 mouseFlags 设为：

常数 | 描述
VtChMouseFlagShiftKeyDown | SHIFT 键处于按下状态。
VtChMouseFlagControlKeyDown | CONTROL 键处于按下状态。


PointLabelUpdated 事件

当数据点标签被改变时产生该事件。

语法

Private Sub object_PointLabelUpdated (series As Integer, dataPoint As Integer, updateFlags As Integer)

PointLabelUpdated 事件的语法包含下面部分：

部分 | 描述
object | 对象表达式，其值是“应用于”列表中的对象。
series | Integer。标识包含该数据点的系列。根据数据网格中列的显示顺序给系列编号，编号从 1 开始。
dataPoint | Integer。标识系列中的数据点。根据数据网格中行的显示顺序给数据点编号，编号从 1 开始。
updateFlags | Integer。提供有关数据点标签的更新信息，如“设置值”中所描述。

设置值

下表列出了用于 updateFlags 的常数。

常数 | 描述
VtChNoDisplay | 缺少更新标记；图表没有任何变化。（定义为 0）。
VtChDisplayout | 更新使绘图区重绘。
VtChLayoutPlot | 更新使对绘图区重新布局。
VtChDisplayLegend | 更新使图例重绘。
VtChLayoutLegend | 更新使对图例重新布局。
VtChLayoutSeries | 更新使对系列重新布局。
VtChPositionSection | 图表的某部分被移动或调度大小。


PointSelected 事件

单击数据点时产生该事件。

语法

Private Sub object_PointSelected ( series As Integer, dataPoint As Integer, mouseFlags As Integer, cancel As Integer )

PointSelected 事件的语法包含下面部分：

部分 | 描述
object | 对象表达式，其值是“应用于”列表中的对象。
series | Integer。标识包含该数据点的系列。根据数据网格中列的显示顺序给系列编号，编号从 1 开始。
dataPoint | Integer。标识系列中的数据点。根据数据网格中行的显示顺序给数据点编号，编号从 1 开始。
mouseFlags | Integer。指示单击鼠标按钮时，是否有键处于按下状态。如“设置值”中所描述。
cancel | Integer。目前没有使用这个参数。

设置值

事件句柄确定单击鼠标按钮时是否有键处于按下状态，并据此将 mouseFlags 设为：

常数 | 描述
VtChMouseFlagShiftKeyDown | SHIFT 键处于按下状态。
VtChMouseFlagControlKeyDown | CONTROL 键处于按下状态。


PointUpdated 事件

当数据点改变时产生该事件。

语法

Private Sub object_PointUpdated (series As Integer, dataPoint As Integer, updateFlags As Integer)

PointUpdated 事件的语法包含下面部分：

部分 | 描述
object | 对象表达式，其值是“应用于”列表中的对象。
series | Integer。标识包含该数据点的系列。根据数据网格中列的显示顺序给系列编号，编号从 1 开始。
dataPoint | Integer。标识系列中的数据点。根据数据网格中行的显示顺序给数据点编号，编号从 1 开始。
updateFlags | Integer。提供有关数据点的更新信息，如“设置值”中所描述。

设置值

下表列出了用于 updateFlags 的常数。

常数 | 描述
VtChNoDisplay | 缺少更新标记；图表的显示没有任何变化。（定义为 0）。
VtChDisplayout | 更新使绘图区重绘。
VtChLayoutPlot | 更新使对绘图区重新布局。
VtChDisplayLegend | 更新使图例重绘。
VtChLayoutLegend | 更新使对图例重新布局。
VtChLayoutSeries | 更新使对系列重新布局。
VtChPositionSection | 图表的某部分被移动或调整大小。


SeriesActivated 事件

双击图表系列时产生该事件。通过取消该事件并显示自己的对话框，可以取代标准的用户界面。

语法

Private Sub object_SeriesActivated (series As Integer, mouseFlags As Integer, cancel As Integer)

SeriesActivated 事件的语法包含下面部分：

部分 | 描述
object | 对象表达式，其值是“应用于”列表中的对象。
series | Integer。标识包含该数据点的系列。根据数据网格中列的显示顺序给系列编号，编号从 1 开始。
mouseFlags | Integer。表示单击鼠标按钮时，是否有键处于按下状态。如“设置值”中所描述。
cancel | Integer。目前没有使用这个参数。

设置值

事件句柄确定单击鼠标按钮时是否有键处于按下状态，并据此将 mouseFlags 设为：

常数 | 描述
VtChMouseFlagShiftKeyDown | SHIFT 键处于按下状态。
VtChMouseFlagControlKeyDown | CONTROL 键处于按下状态。


SeriesSelected 事件

当单击图表系列时产生该事件。

语法

Private Sub object_SeriesSelected (series As Integer, mouseFlags As Integer, cancel As Integer)

SeriesSelected 事件的语法包含下面部分：

部分 | 描述
object | 对象表达式，其值是“应用于”列表中的对象。
series | Integer。标识包含数据点的系列。根据数据网格中列的出现顺序给系列编号，编号从 1 开始。
mouseFlags | Integer。表示单击鼠标时，是否有键处于按下状态。如“设置值”中所描述。
cancel | Integer。目前没有使用这个参数。

设置值

事件句柄确定单击鼠标时是否有键处于按下状态，并据此将 mouseFlags 设为：

常数 | 描述
VtChMouseFlagShiftKeyDown | SHIFT 键处于按下状态。
VtChMouseFlagControlKeyDown | CONTROL 键处于按下状态。


SeriesUpdated 事件

当图表系列改变时产生该事件。

语法

Private Sub object_SeriesUpdated (series As Integer, updateFlags As Integer)

SeriesUpdated 事件的语法包含下面部分：

部分 | 描述
object | 对象表达式，其值是“应用于”列表中的对象。
series | Integer。标识包含该数据点的系列。根据数据网格中列的出现顺序给系列编号，编号从 1 开始。
updateFlags | Integer。提供有关系列的更新信息，如“设置值”中所描述。

设置值

下表列出了 updateFlags 的系列常数。

常数 | 描述
VtChNoDisplay | 缺少更新标记；图表没有任何变化。（定义为 0）。
VtChDisplayPlot | 更新使绘图区重绘。
VtChLayoutPlot | 更新使对绘图区重新布局。
VtChDisplayLegend | 更新使图例重绘。
VtChLayoutLegend | 更新使对图例重新布局。
VtChLayoutSeries | 更新使对系列重新布局。
VtChPositionSection | 图表的部分被移动或调整大小。


TitleActivated 事件

双击图表标题时产生该事件。通过取消该事件并显示自己的对话框，可以取代标准的用户界面。

语法

Private Sub object_TitleActivated ( mouseFlags As Integer, cancel As Integer )

TitleActivated 事件的语法包含下面部分：

部分 | 描述
object | 对象表达式，其值是“应用于”列表中的对象。
mouseFlags | Integer。表示单击鼠标按钮时，是否有键处于按下状态，如“设置值”中所描述。
cancel | Integer。目前没有使用这个参数。

设置值

事件句柄确定单击鼠标按钮时是否有键处于按下状态，并据此将 mouseFlags 设为：

常数 | 描述
VtChMouseFlagShiftKeyDown | Shift 键处于按下状态。
VtChMouseFlagControlKeyDown | Control 键处于按下状态。


TitleSelected 事件

单击图表标题时产生该事件。

语法

Private Sub object_TitleSelected (mouseFlags As Integer, cancel As Integer)

TitleSelected 事件的语法包含下面部分：

部分 | 描述
object | 对象表达式，其值是“应用于”列表中的对象。
mouseFlags | Integer。表示单击鼠标按钮时，是否有键处于按下状态，如“设置值”中所描述。
cancel | Integer。目前没有使用这个参数。

设置值

事件句柄确定单击鼠标按钮时是否有键处于按下状态，并据此将 mouseFlags 设为：

常数 | 描述
VtChMouseFlagShiftKeyDown | SHIFT 键处于按下状态。
VtChMouseFlagControlKeyDown | CONTROL 键处于按下状态。


TitleUpdated 事件

当改变图表标题时产生该事件。

语法

Private Sub object_TitleUpdated (updateFlags As Integer)

TitleUpdated 事件的语法包含下面部分：

部分 | 描述
object | 对象表达式，其值是“应用于”列表中的对象。
updateFlags | 提供有关更新标题的信息，如“设置值”中所描述。

设置值

下表列出了用于 updateFlags 参数的常数。

常数 | 描述
VtChNoDisplay | 缺少更新标记；图表的显示没有任何变化。（定义为 0）。
VtChDisplayPlot | 更新使绘图区重绘。
VtChLayoutPlot | 更新使对绘图区重新布局。
VtChDisplayLegend | 更新使图例重绘。
VtChLayoutLegend | 更新使对图例重新布局。
VtChLayoutSeries | 更新使对系列重新布局。
VtChPositionSection | 图表的部分被移动或调整大小。


错误消息（MSChart 控件）

发生在程序执行过程中的 MSChart 控件错误，可以象对待其它错误一样来处理。必须写出自己的错误处理例程来捕获错误，并对其进行管理。

下表列出了可以被异常处理例程捕获的错误。

错误名 | 解释
GetNotSupported | 试图对只写属性进行读操作。
InvalidPropertyValue | 值不适合于所使用的属性。
SetNotSupported | 试图对只读属性进行写操作。
VtChError | 由于并非特别的错误导致函数失败。
VtChErrorInvalidAxis | 方法中的一个参数是对图表上并不存在的轴的引用。
VtChErrorInvalidHandle | 传递了无效图表处理。
VtChErrorInvalidSeriesNumber | 方法中的一个参数是对图表上并不存在的一个系列的引用。
VtChErrorNoData | 完成任务所必需的数据不可用。
VtChErrorRestrictedVersion | 在产品的这个版本中不存在所需要的特性。
VtErrorActionCanceled | 用户取消了操作。用户没有选定菜单中的某一项，而是单击了菜单之外的某个地方。
VtErrorArchivePointerMismatch | 试图将指针加载到某个引用中。
VtErrorArchiveTypeMismatch | 遇到了意想不到的类的类型。
VtErrorArchiveVersion | 试图加载不兼容的版本。
VtErrorBufferTooSmall | 字符串缓冲区不够大，不足以容纳所需要的字符串。字符串已经被截断以适应缓冲区大小。
VtErrorCannotOpenFile | 不能打开所要求的文件。
VtErrorCopyingObject | 复制对象失败。
VtErrorCorruptArchive | 永久的存储被破坏。
VtErrorCorruptData | 内部错误，表示 MSChart 控件已经遇到损坏的数据，所以所要求的操作不能继续下去。
VtErrorCreateWindow | 不能创建窗口。
VtErrorDefaultFontSubstituted | 缺省字体取代了所要求的字体。
VtErrorDeletingDeletedObject | 内部错误，表示 MSChart 控件试图删除已被删除的对象。
VtErrorDeletingUsedObject | 内部错误，表示 MSChart 控件试图删除还在使用的对象。
VtErrorDisplay | MSChart 控件不能正确地跟显示驱动程序通信。
VtErrorDuplicateObject | 遇到过的重复对象。
VtErrorDuplicateSymbol | 重复符号。
VtErrorIconNotFound | 不能加载图标。
VtErrorIdentifierTooBig | 标识符太长。
VtErrorInvalidArgument | 函数参数中有一个是坏的。
VtErrorInvalidFont | 要求的字体描述无效。
VtErrorInvalidFontName | 要求的字体名不可用。
VtErrorInvalidIndex | 所给出的索引越界。
VtErrorInvalidObject | 对象没有初始化或者无效。
VtErrorInvalidRequest | 要求的操作不合适，或者无效。
VtErrorInvalidSyntax | 遇到了无效语法。
VtErrorInvalidTypeConversion | 不支持要求的类型转换。
VtErrorLoadPicture | 不能加载要求的图片。
VtErrorNoDisplayResources | MSChart 控件没有足够的显示资源来正确显示图表。
VtErrorNoMemory | 没有足够内存来完成要求的操作。
VtErrorNotFound | 找不到函数正在寻找的项。
VtErrorNotImplemented | 功能尚未实现。
VtErrorOSVersion | 不支持的 Windows 版本。
VtErrorStreamIo | 在试图读写文件时遇到了错误。
VtErrorTooSmall | 返回缓冲区太小，返回结果太长。结果在缓冲区中放了一个 NULL 字符串。
VtErrorUnableToLoadString | 不能加载字符串；可能是该字符串太长了。
VtErrorUnexpectedEOS | 遇到了意想不到的字符串结尾。
VtErrorUnrecognizedFunction | 遇到了无法辨认的函数。
VtErrorUserIo | 企图将某个文件写到用户所创建的函数，但失败了。
VtFail | 一般性失败的错误。
VtOk | 未出现任何错误。


Add 方法 (LightSources Collection)

在 LightSources 集合中添加 LightSource 对象。

语法

object.Add (x,y,z,intensity)

Add 方法的语法包含下面部分：

部分 | 描述
collection | 对象表达式，其值是“应用于”列表中的对象。
x, y, z | Integer。它们指示光源位置。
intensity | Single。指示光源强度。

说明

将 x、y 和 z 设置为 0 会导致 VtChInvalidArgument 错误。


Count 方法

返回集合中的对象数目。

语法

object.Count

object 所在处是对象表达式，其值是“应用于”列表中的对象。


DeleteColumnLabels 方法

从与图表关联的数据网格中删除数据列的标签级。

语法

object.DeleteColumnLabels (labelIndex, count)

DeleteColumnLabels 方法的语法包含下面部分：

部分 | 描述
object | 对象表达式，其值是“应用于”列表中的对象。
labelIndex | Integer。标识要删除的第一级标签编号。列标签从 1 开始，由底端向顶端依次编号。
count | Integer。指定要删除的标签级别数。要删除的列从 labelIndex 标识的列开始向上计算。


DeleteColumns 方法

在与图表关联的数据网格中删除数据列以及与它们关联的标签。

语法

object.DeleteColumns (column, count)

DeleteColumns 方法的语法包含下面部分：

部分 | 描述
object | 对象表达式，其值是“应用于”列表中的对象。
column | Integer。标识特定的数据列。列从 1 开始、由左向右依次编号。
count | Integer。指定要删除的列数。


DeleteRowLabels 方法

从与图表关联的数据网格的数据行中删除标签级。

语法

object.DeleteRowLabels (labelIndex, count)

DeleteRowLabels 方法的语法包含下面部分：

部分 | 描述
object | 对象表达式，其值是“应用于”列表中的对象。
labelIndex | Integer。指定要删除的第一级标签编号。行标签从 1 开始，由左向右依次编号。
count | Integer。指定要删除的标签级别编号。要删除的行标签从 labelIndex 标识的行开始向左计算。


DeleteRows 方法

从与图表关联的数据网格中删除数据行及与它们关联的标签。

语法

object.DeleteRows (row, count)

DeleteRows 方法的语法包含下面部分：

部分 | 描述
object | 对象表达式，其值是“应用于”列表中的对象。
row | Integer。标识特定的数据行。行从 1 开始、由顶端向底端依次编号。
count | Integer。指定要删除的行数。


EditCopy 方法

以 Windows 图元文件格式将当前图表的图片复制到剪贴板中。它同时将创建图表使用的数据复制到剪贴板中。

语法

object.EditCopy

object 所在处代表对象表达式，其值是“应用于”列表中的对象。

说明

使用此方法，可将图表数据或图表图片本身粘贴到另一个应用程序中。因为数据和图表图片都存储在剪贴板上，因此粘贴到新的应用程序中的内容取决于该应用程序的类型。例如，如果在代码中执行图表的 EditCopy 方法，然后切换到 Excel 工作表来选择“编辑”中的“粘贴”命令，则将把图表数据集复制到工作表中。如要将图表图片插入到工作表中，可在选定“编辑粘贴特殊”后选择“图片”类型。


EditPaste 方法

将剪贴板中的 Windows 图元文件图形或由 tab 键分隔的文本粘贴到图表的当前选定区域。

语法

object.EditPaste

object 所在处代表对象表达式，其值是“应用于”列表中的对象。

说明

图表可接受剪贴板中的几种类型的信息，这取决于调用 EditPaste 时选定的图表元素。如果选定了整个图表，则图表在剪贴板中寻找数据并试图使用这些新数据重新绘制图表。如果选定能够接受图片的项目，例如选定了条形图或图表背景，则图表在剪贴板上寻找图元文件。如果找到了图元文件，就使用该图元文件填充选定对象。


GetData 方法 (MSChart)

在与图表关联的数据网格中返回特定数据点中的当前存储数值。

语法

object.GetData (row, column, dataPoint, nullFlag)

GetData 方法的语法包含下面部分：

部分 | 描述
object | 对象表达式，其值是“应用于”列表中的对象。
row | Integer。标识包含数据点数值的行。
column | Integer。标识包含数据点数值的列。
dataPoint | Double。数据点的数值。
nullFlag | Integer。指示数据点数值是否为空值。


GetSelectedPart 方法

标识当前选定的图表元素。

语法

object.GetSelectedPart (part, index1, index2, index3, index4)

GetSelectedPart 方法的语法包含下面部分：

部分 | 描述
object | 对象表达式，其值是“应用于”列表中的对象。
part | Integer。指定图表元素。有效的常数为 VtChPartType。
index1 | Integer。如果元素引用一个系列或一个数据点，则此参数指定引用的系列。系列编号时从 1 开始，根据它们对应的列在数据网格中从左到右显示的顺序依次编号。如果元素引用坐标轴或坐标轴标签，则此参数将标识具有 VtChAxisId 常数的坐标轴类型。
Index2 | Integer。如果元素引用数据点，则此参数指定系列中由 index1 标识的数据点。
index3 | Integer。如果元素引用坐标轴标签，则此参数引用标签级别。坐标轴标签级别从 1 开始、由坐标轴向外依次编号。如果元素不是坐标轴标签，则此参数无效。
index4 | Integer。此时未使用该参数。


InitializeLabels 方法

为第一级数据网格标签中的每个标签赋予唯一标识符。

语法

object.InitializeLabels

object 所在处代表对象表达式，其值是“应用于”列表中的对象。


InsertColumnLabels 方法

在与图表关联的数据网格的数据列中插入标签级。

语法

object.InsertColumnLabels (labelIndex, count)

InsertColumnLabels 方法的语法包含下面部分：

部分 | 描述
object | 对象表达式，其值是“应用于”列表中的对象。
labelIndex | Integer。标识要插入的第一级标签编号。列标签级从 1 开始、由底端向顶端依次编号。
count | Integer。指定要插入的标签级数。要插入的列数从由 labelIndex 标识的列开始向上计算。


InsertColumns 方法

在与图表关联的数据网格中添加一个或多个数据列。

语法

object.InsertColumns (column, count)

InsertColumns 方法的语法包含下面部分：

部分 | 描述
object | 对象表达式，其值是“应用于”列表中的对象。
column | Integer。标识特定的数据列。列从 1 开始、由左向右依次编号。
count | Integer。指定要插入的列数。


InsertRowLabels 方法

在与图表关联的数据网格的数据行中插入标签级。

语法

object.InsertRowLabels (labelIndex, count)

InsertRowLabels 方法的语法包含下面部分：

部分 | 描述
object | 对象表达式，其值是“应用于”列表中的对象。
labelIndex | Integer。标识要插入的第一级标签编号。行标签从 1 开始、由右向左依次编号。
count | Integer。指定要插入的标签级数。插入的行标签由 labelIndex 标识的行起始，向左计算。


InsertRows 方法

在与图表关联的数据网格中添加一个或多个数据行。

语法

object.InsertRows (row, count)

InsertRows 方法的语法包含下面部分：

部分 | 描述
object | 对象表达式，其值是“应用于”列表中的对象。
row | Integer。标识特定的数据行。行从 1 开始、由顶端向底端依次编号。
count | Integer。指定要插入的行数。行中都包含空数据直到用数据行填充它们。


Layout 方法

布置图表，强制重新计算自动数值。

语法

object.Layout

object 所在处代表对象表达式，其值是“应用于”列表中的对象。

说明

首次绘制图表时就要布置图表。当任何图表设置值变更后，就会在下一次绘制时重新布置图表。图表有很多设置值需要根据其类型或一些其它设置来计算，例如坐标轴的最小值和最大值等等。在图表布置完成之前不能决定这些数值。如果在正确布置图表之前试图“获取”这些自动数值，那么获取的数值并不能反映新数值。


MoveData 方法

移动与图表关联的数据网格中的一组连续数据。

语法

object.MoveData (top, left, bottom, right, overOffset, downOffset)

MoveData 方法的语法包含下面部分：

部分 | 描述
object | 对象表达式，其值是“应用于”列表中的对象。
top | Integer。标识要移动数据的第一行。
left | Integer。标识要移动数据的第一列。
bottom | Integer。标识要移动数据的最后一行。
right | Integer。标识要移动数据的最后一列。
overOffset | Integer。标识数据移动的水平方向。正数使数据向右移动；负数使数据向左移动。
downOffset | Integer。标识数据移动的垂直方向。正数使数据向下移动；负数使数据向上移动。


RandomDataFill 方法

在与特定图表关联的数据网格中填充随机生成的数据。

语法

object.RandomDataFill

object 所在处代表对象表达式，其值是“应用于”列表中的对象。


RandomFillColumns 方法

在与图表关联的某些数据网格列中填充随机生成的数值。

语法

object.RandomFillColumns (column, count)

RandomFillColumns 方法的语法包含下面部分：

部分 | 描述
object | 对象表达式，其值是“应用于”列表中的对象。
column | Integer。标识要填充的第一列。列从 1 开始、由左向右依次编号。
count | Integer。指定要用随机数据填充的列数目。


RandomFillRows 方法

在与图表关联的某些数据网格行中填充随机生成的数值。

语法

object.RandomFillRows (row, count)

RandomFillRows 方法的语法包含下面部分：

部分 | 描述
object | 对象表达式，其值是“应用于”列表中的对象。
row | Integer。标识要填充的第一行。行从 1 开始、由顶端向底端依次编号。
count | Integer。指定要用随机数据填充的行数。


Remove 方法 （LightSources 集合）

从 LightSources 集合中删除 LightSource。

语法

object.Remove (index)

Remove 方法的语法包含下面部分：

部分 | 描述
Collection | 对象表达式，其值是“应用于”列表中的对象。
Index | 整数。排列在光源列表中的特定光源。


ResetCustomLabel 方法

将图表数据点标签上的任何自定义属性重新设置为系列的缺省值。

语法

object.ResetCustomLabel

object 所在处代表对象表达式，其值是“应用于”列表中的对象。


ResetCustom 方法

将数据点的任何自定义属性重新设置为系列的缺省值。

语法

object.ResetCustom

object 所在处代表对象表达式，其值是“应用于”列表中的对象。


Select 方法

选定指定的图表元素。

object.Select

object 所在处代表对象表达式，其值是“应用于”列表中的对象。


SelectPart 方法

选择指定的图表区域。

语法

object.SelectPart (part, index1, index2, index3, index4)

SelectPart 方法的语法包含下面部分：

部分 | 描述
object | 对象表达式，其值是“应用于”列表中的对象。
part | Integer。指定图表区域。有效常数为 VtChPartType。
index1 | Integer。如果 part 指向一个系列或一个数据点，则该参数说明是哪个系列。根据相应数据网格中的列从左至右的顺序给系列编号，编号从 1 开始。如果 part 指的是坐标轴或坐标轴标签，则该参数使用 VtChAxisId 常数来标识坐标轴的类型。
index2 | Integer。如果 part 指的是一个数据点，则用该参数来指定 index1 标识的是系列中的哪一个数据点。根据相应数据网格中的行从上至下的顺序给数据点编号，编号从 1 开始。如果 part 指的是坐标轴，坐标轴标题，或坐标轴标签，则该参数指向目前没有使用的坐标轴索引。若是这种情况，则该参数唯一有效的值是 1。
index3 | Integer。如果 part 指的是坐标轴标签，则用该参数指定该标签的级别。坐标轴的标签级别从坐标轴向外编号，编号从 1 开始。如果 part 不是坐标轴标签，则不使用这个参数。
index4 | Integer。目前没有使用这个参数。


SetData 方法 (MSChart)

设置与图表关联的数据网格中特定数据点的数值。

语法

object.SetData (row, column, dataPoint, nullFlag)

SetData 方法的语法包含下面部分：

部分 | 描述
object | 对象表达式，其值是“应用于”列表中的对象。
row | Integer。标识包含数据点数值的行。
column | Integer。标识包含数据点数值的列。
dataPoint | Double。数据点数值。
nullFlag | Integer。指示数据点数值是否为空值。


SetData Method (MSChart)

Sets the value for a specific data point in the data grid associated with a chart.

Syntax

object.SetData (row, column, dataPoint, nullFlag)

The SetData method syntax has these parts:

Part | Description
object | An object expression that evaluates to an object in the Applies To list.
row | Integer. Identifies the row containing the data point value.
column | Integer. Identifies the column containing the data point value.
dataPoint | Double. The data point value.
nullFlag | Integer. Indicates whether or not the data point value is a null.


Set 方法 (LightSource)

设置 LightSource 对象所在位置的 x、y、z 坐标及光强度。

语法

object.Set (x,y,z, intensity)

Set 方法的语法包含下面部分：

部分 | 描述
object | 对象表达式，其值是“应用于”列表中的对象。
x, y, z | Integer。指定光源的位置。
intensity | Single。指定光源的强度。


Set 方法 (Coor, LCoor)

设置图表的 x 和 y 坐标。

语法

object.Set ( x,y )

Set 方法的语法包含下面部分：

部分 | 描述
object | 对象表达式，其值是“应用于”列表中的对象。
x | Single。（对于 LCoor 对象，该参数是长整型）标识坐标的 x 数值。
Y | Single。（对于 LCoor 对象，该参数是长整型）标识坐标的 y 数值。


Set 方法 (View3D)

设置三维图表的转角及仰角度数。

语法

object.Set (rotation, elevation )

Set 方法的语法包含下面部分：

部分 | 描述
object | 对象表达式，其值是“应用于”列表中的对象。
rotation | Single。转角的度数。 从 0 至 360 度均为有效的旋转角度。旋转角的缺省单位是度。不过这取决于 AngleUnit 属性的当前设置。其它的选项为：梯度以及弧度。
elevation | Single。仰角的度数。 0 至 90 度都是有效的仰角度数。如果将仰角设为 90 度，就变成从上面俯视图表的顶部。如果将仰角设为 0 度，就变成正视图表的侧面。缺省值为 30 度。仰角的缺省单位是度。不过这取决于 AngleUnits 属性的当前设置值。其它的任选项为：梯度以及弧度。


Set 方法 (VtColor)

设置 VtColor 对象的红，绿，蓝分量的值。

语法

object.Set ( red,green,blue)

Set 方法的语法包含下面部分：

部分 | 描述
object | 对象表达式，其值是“应用于”列表中的对象。
red, green, blue | Integer。该颜色的红，绿，蓝分量的值。

说明

RGB 值说明了所显示的颜色的红，绿，蓝三个分量之间的相对强度。正常的 RGB 颜色的有效范围是 0 到 16,777,215。RGB 的任何超过 255 的分量值均按 255 处理。


Set 方法 (Weighting)

设置 Weighting 对象的基值及样式。

语法

object.Set ( basis, style )

Set 方法的语法包含下面部分：

部分 | 描述
object | 对象表达式，其值是“应用于”列表中的对象。
basis | 是 VtChPieWeightBasis 常数，用于标识权的类型。
style | 是 VtChPieWeightStyle 常数，用于标识权因数的样式。


SetSize 方法

调整数据行、数据列数以及与图表关联的数据网格中的列标签级数和行标签级数。

语法

object.SetSize (rowLabelCount, columnLabelCount, dataRowCount, columnLabelCount)

SetSize 方法的语法包含下面部分：

部分 | 描述
object | 对象表达式，其值是“应用于”列表中的对象。
rowLabelCount | Integer。返回或设置数据网格中的行标签级数。
columnLabelCount | Integer。返回或设置数据网格中的列标签级数。
dataRowCount | Integer。返回或设置数据网格上的数据行数。
columnLabelCount | Integer。返回或设置数据网格上的数据列数。

说明

此方法可代替 RowCount、ColumnCount、RowLabelCount 和 ColumnLabelCount。

如果减小数据网格的大小，则销毁已删除的行、列中的数据。


ToDefaults 方法

返回图表的初始设置值。

语法

object.ToDefaults

object 所在处是对象表达式，其值是“应用于”列表中的对象。


TwipsToChartPart 方法

使用 x，y 坐标来标识图表的区域。

语法

object.TwipsToChartPart (xVal, yVal, part, index1, index2, index3, index4)

TwipsToChartPart 方法的语法包含下面部分：

部分 | 描述
object | 对象表达式，其值是“应用于”列表中的对象。
xVal,yVal | Long 类型。坐标点的水平坐标和竖直坐标。
part | Integer。VtChPartType 常数标识由 xVal 和 yVal 坐标定位的图表区域。
index1 | Integer。如果 part 是一个系列或是一个数据点，则该参数说明是哪个系列。根据相应数据网格中的列从左至右的顺序给系列编号，编号从 1 开始。如果 part 是坐标轴或坐标轴标签，则该参数使用 VtChAxisId 常数来标识坐标轴的类型。
index2 | Integer。如果 part 指的是一个数据点，则该参数指定此数据点是 index1 标识的系列中的哪一个数据点。根据相应数据网格中的行从上至下的顺序给数据点编号，编号从 1 开始。如果 part 是坐标轴，坐标轴标题，或坐标轴标签，则该参数指向当前没有使用的坐标轴索引。若是这种情况，则该参数唯一有效的值是 1。
index3 | Integer。如果 part 是坐标轴标签，则该参数指定该标签的级别。坐标轴的标签级别从坐标轴向外编号，编号从 1 开始。如果 part 不是坐标轴标签，则不使用这个参数。
index4 | Integer。目前没有使用这个参数。


TypeByChartType 方法

返回当图表类型为 chType 时系列的相应类型（在绘制系列时要使用该类型）。使用这个方法，不必实际设置图表类型，就可以获得基于指定图表类型的系列类型的信息。

语法

object.TypeByChartType (chtype)

TypeByChartType 方法的语法包含下面部分：

部分 | 描述
object | 对象表达式，其值是“应用于”列表中的对象。
Chtype | Integer。是描述图表类型的 VtChChartType 常数。

返回值

取决于 chtype 参数指定的图表类型，TypeByChartType 方法返回 VtChSeriesType 值之一，如下所示：

常数 | 值 | 描述
VtChSeriesTypeDefault | -1 | 缺省
VtChSeriesType3dBar | 0 | 3D Bar
VtChSeriesType2dBar | 1 | 2D Bar
VtChSeriesType3dLine | 5 | 3D Line
VtChSeriesType2dLine | 6 | 2D Line
VtChSeriesType3dArea | 7 | 3D Area
VtChSeriesType3dStep | 9 | 3D Step
VtChSeriesType2dStep | 10 | 2D Step
VtChSeriesType2dXY | 11 | XY
VtChSeriesType2dPie | 24 | 2D Pie


AxisGrid 对象

表示围绕图表坐标轴的平面区域。

语法

AxisGrid


AxisGrid 对象示例

下面的示例将改变 y AxisGrid 的线型外观。

Private Sub Command1_Click()
   With MSChart1.Plot.Axis(VtChAxisIdY)
      .CategoryScale.Auto = False
      .ValueScale.MajorDivision = 10
      .ValueScale.MinorDivision = 5
      .AxisGrid.MajorPen.Style = VtPenStyleSolid
      .AxisGrid.MajorPen.VtColor.Green = 255
      .AxisGrid.MajorPen.Width = 2
      .AxisGrid.MinorPen.Style = VtPenStyleDashed
      .AxisGrid.MinorPen.VtColor.Red = 255
      .AxisGrid.MinorPen.Width = 1
      .AxisGrid.MinorPen.Cap = VtPenCapRound
   End With
End Sub


Axis 对象

表示图表上的坐标轴。

语法

Axis

说明

有三个坐标轴可用: x 轴、 y 轴和 z 轴。仅当是 3D 图表时，z 轴才可见。


Axis 对象示例

下面的示例使用 x Axis 对象读取 x 坐标轴显示的标签级别数。

Private Sub Command1_Click()
   Dim XAxis As Object
   Dim NumberOfLevels As Integer
   '读取 X 坐标轴上显示的
   '标签级别。
   Set XAxis = MSChart1.Plot.Axis(VtChAxisIdX, 1)
   NumberOfLevels = XAxis.LabelLevelCount
   MsgBox "Number of Label Levels = " _
   & Str(NumberOfLevels)
End Sub


AxisScale 对象

控制如何在坐标轴上绘制图表数值。

语法

AxisScale


AxisScale 示例

下面的示例将二维折线图表的 x、y 坐标轴刻度设置为百分比刻度或对数。要试验该例，在窗体中绘制一个 MSChart 和两个 CommandButton 控件。粘贴下列代码到该 Form 对象的代码模块并运行该工程。

Private Sub Command1_Click()
   '将二维折线图表的 x、y 坐标轴刻度设置为
   '折线图。
   Dim axisID As VtChAxisId
   Form1.MSChart1.ChartType = VtChChartType2dLine
   For AxisId = VtChAxisIdX To VtChAxisIdY
      With MSChart1.Plot.Axis(AxisId).AxisScale
         .Type = VtChScaleTypePercent
         .PercentBasis = VtChPercentAxisBasisSumChart
      End With
   Next
End Sub

Private Sub Command2_Click()
   Dim axisID As VtChAxisId
   ' 为二维折线图改变 x 和 y 轴为对数刻度。
   MSChart1.ChartType = VtChChartType2dLine
   For axisID = VtChAxisIdX To VtChAxisIdY
      With MSChart1.Plot.Axis(axisID).AxisScale
         .Type = VtChScaleTypeLogarithmic
         .LogBase = 12
      End With
   Next
End Sub


AxisTitle 对象

表示图表的坐标轴标题。

语法

AxisTitle


AxisTitle 对象示例

下面的示例将一个三维图表的所有坐标轴的坐标轴标题设置为可见。

Private Sub Command1_Click()
   '将 3D 图表所有坐标轴的坐标轴标题设置为
   '可见的。
   Dim axisID As VtChAxisId
   MSChart1.chartType = VtChChartType3dBar
   For axisId = VtChAxisIdX To VtChAxisIdZ
      With MSChart1.Plot.axis(axisId, 1)
         .AxisTitle.VtFont.Size = 14
         .AxisTitle.Visible = True
         Select Case axisId
            Case 0
               .AxisTitle.text = "X Axis Title"
            Case 1
                .AxisTitle.text = "Y Axis Title"
            Case 2
               .AxisTitle.text = "2nd Y Axis Title"
            Case 3
               .AxisTitle.text = "Z Axis Title"
         End Select
      End With
   Next
End Sub


Backdrop 对象

表示图表元素后面的阴影或图案。

语法

Backdrop

说明

对于 Plot 对象的 Backdrop 对象，设置其 Style 属性为 VtFillStyleBrush 以观察效果。


Brush 对象

用来显示图表元素的填充类型。

语法

Brush


Brush 对象示例

下面的示例使用 Brush 对象为图表背景设置粗体垂直线图案。

Private Sub Command1_Click()
   '将背景设置为 Fill - Brush 风格。
   MSChart1.Backdrop.Fill.Style = VtFillStyleBrush
   '使用对象为图表背景
   '设置图案。
   With MSChart1.Backdrop.Fill.Brush
      .Style = VtBrushStylePattern
      .Index = VtBrushPatternBoldVertical
   '将图案设置为粗体垂直线。
      .FillColor.Set 255, 0, 0   '填充颜色 = 红色。
      .PatternColor.Set 0, 0, 255   '图案颜色 =
                                 '蓝色。
   End With
End Sub


CategoryScale 对象

分类坐标轴的刻度。

语法

CategoryScale


CategoryScale 对象示例

下面的示例设置分类坐标轴的比例属性。

Private Sub Command1_Click()
   '设置分类坐标轴的刻度属性。
   MSChart1.ChartType = VtChChartType2dLine
   With MSChart1.Plot.Axis(VtChAxisIdX)
      .ValueScale.MajorDivision = 10
      .ValueScale.MinorDivision = 5
      .CategoryScale.Auto = False         '设置为人工缩放。
      .CategoryScale.DivisionsPerLabel = 2 '   '每两个单位显示
                              '标签。
      .CategoryScale.DivisionsPerTick = 2  '   '每两个单位显示
                              '刻度。
      .CategoryScale.LabelTick = True   '在刻度标记顶端显示
                        '标签。
   End With
End Sub


Coor 对象

描述图表的一对浮点数值型 x、y 坐标。

语法

Coor


DataGrid 对象

表示一个虚拟矩阵，它包含该 MSChart 控件的标签和数据点。

语法

DataGrid

说明

DataGrid 对象由行和列组成。您可以添加和抽出行、列以及标签到该矩阵中，以改变该图表的外观。


DataGrid 对象示例

下面的示例设置一个三维条形图表的图表参数，用随机数据填充图表并为数据网格列分配标签。

Option Explicit
Option Base 1
Private Sub Command1_Click()
   Dim rowLabelCount, columnLabelCount, rowCount As Integer
   Dim columnCount, labelIndex, Column, Row As Integer

   MSChart1.ChartType = VtChChartType3dBar
   With MSChart1.DataGrid
   '使用方法设置图表参数。
      rowLabelCount = 2
      columnLabelCount = 2
      rowCount = 6
      columnCount = 6
      .SetSize RowLabelCount, columnLabelCount, _
      RowCount, ColumnCount
      '随机填充数据。
      .RandomDataFill
      '然后为第二级分配标签。
      labelIndex = 2
      column = 1
      .ColumnLabel(column, labelIndex) = "Product 1"
      column = 4
      .ColumnLabel(column, labelIndex) = "Product 2"
      row = 1
      .RowLabel(row, labelIndex) = "1994"
      row = 4
      .RowLabel(row, labelIndex) = "1995"
   End With
End Sub


DataPointLabel 对象

图表中数据点的标签。

语法

DataPointLabel


DataPoint 对象

DataPoints 集合中的成员，它描述图表中单个数据点的属性。

语法

DataPoint

说明

DataPoints 集合是通过 SeriesCollection 对象来访问的。

重点 DataPoints 集合此时只包含一个成员。要访问它，您必须使用 –1，如下面所示：

MSChart1.Plot.SeriesCollection(1).DataPoints(-1) _
.Brush.FillColor.Set 0, 255, 255


DataPoint 对象示例

下面的示例将一个变量赋予数据点并设置数据点的颜色和标记。

Private Sub Command1_Click()
   '改变第一系列中第一数据点的
   '颜色和标记。
   With MSChart1.Plot.SeriesCollection(1).DataPoints(-1)
      '将数据点的颜色变成蓝色。
      .Brush.Style = VtBrushStyleSolid
      '设置 Color=Blue.
      .Brush.FillColor.Set 0, 255, 255
      '将数据点标记设置成可见的。
      .Marker.Visible = True
   End With
End Sub


Fill 对象

描述图表中对象背景的类型和外观。

语法

Fill


Fill 对象示例

下面的示例使用 Fill 对象为图表设置渐变的背景。

Private Sub Command1_Click()
   With MSChart1.backdrop.Fill
      '设置画笔图案背景。
      .Style = VtFillStyleBrush
      .Brush.Style = VtBrushPattern50Percent
   End With
End Sub


VtFontObject 示例

下面的示例为图表的标题设置字体参数。

Private Sub Command1_Click()
   ' Ask user to supply a title.
   MSChart1.Title.Text = InputBox("Title?")
   '使图表标题可见。
   MSChart1.Title.Location.Visible = True
   '为图表标题设置字体。
   With MSChart1.Title.VtFont
      .Name = "Times New Roman"
      .Size = 18
      .Style = VtFontStyleBold Or
      VtFontStyleItalic
      '文本中同时使用中划线和下划线。
      .Effect = VtFontEffectStrikeThrough Or _
      VtFontEffectUnderline
      '将文本颜色设为蓝色。
      .VtColor.Set 0, 0, 255
   End With
End Sub


Footnote 对象

出现在图表下方的描述性文字。

语法

Footnote


Footnote 对象示例

下面的示例设置图表的脚注位置、文本和颜色。

Private Sub Command1_Click()

   With MSChart1.Footnote
      '将脚注设置为可见。
      .Location.Visible = True
      .Location.LocationType = _
      VtChLocationTypeBottomLeft

      '设置脚注属性。
      .text = "Chart Footnote"
      .VtFont.VtColor.Set 255, 0, 0
   End With

End Sub


Frame 对象

包含图表元素周围框架外观的信息。

语法

Frame


Frame 对象示例

下面的示例在图表背景上设置蓝色的双线框架。

Private Sub Command1_Click()
   With MSChart1.backdrop.Frame
      .Style = VtFrameStyleDoubleLine
      .Width = 2
      .FrameColor.Set 0, 0, 255   '蓝色框架。
      .SpaceColor.Set 255, 0, 0   '红色间隔。
   End With
End Sub


Intersection 对象

两坐标轴相交于此点。

语法

Intersection


Intersection 对象示例

下面的示例设置手工相交位置属性并将标签与坐标轴一起显示。

Private Sub Command1_Click()
   With MSChart1.Plot.Axis(VtChAxisIdX).Intersection
      '设置相交属性。
      .Auto = False   '设置手工定位。
      .Point = 20      '将与 Y 坐标轴的相交点
                     '设置为 20。
      .LabelsInsidePlot = True   '将标签与坐标轴一起显示，
                                 '但是不显示在
                                 '坐标轴底部。
   End With
End Sub


Label 对象

Labels 集合中的项目，它描述特定的图表坐标轴标签。

语法

axis.Label


LCoor 对象

描述长整型 x、y 坐标对。

语法

Lcoor


Legend 对象

代表小图标和描述图表系列的伴随文字。

语法

Legend


Legend 对象示例

下面的示例为图表的图例设置文本和背景参数。

Private Sub Command1_Click()
   With MSChart1.Legend
      '将图例设置为可见。
      .Location.Visible = True
      .Location.LocationType = VtChLocationTypeRight
      '设置图例属性。
      .TextLayout.HorzAlignment = _
      VtHorizontalAlignmentRight   '右对齐。
      '使用黄色文本。
      .VtFont.VtColor.Set 255, 255, 0
      .Backdrop.Fill.Style = VtFillStyleBrush
      .Backdrop.Fill.Brush.Style = VtBrushStyleSolid
      .Backdrop.Fill.Brush.FillColor.Set 255, 0, 255
   End With
End Sub


Light 属性

Light 对象

代表三维图表的照明光源。

语法

Light


Light 对象示例

下面的示例设置图表周围的光线强度及边缘光线强度。要试着使用该示例，请在窗体上绘制一个 MSChart 和两个 ComboBox 控件。将代码粘贴到 Form 对象的代码模块中并运行该工程。单击 ComboBox 控件查看环境光线和边缘光线强度的变化。

Private Sub Form_Load()
    ' 配置该图表。
   With MSChart1
      .Title = "Hold down Control and mousedown on chart"
      .chartType = VtChChartType3dBar
      .Plot.Light.AmbientIntensity = 1   ' 100 % 强度。
      .Plot.Light.EdgeIntensity = 0.5        ' 50 % 强度。
      .Plot.Light.EdgeVisible = True
   End With
   '配置 ComboBoxe 控件。
   ConfigCombo Combo1
   ConfigCombo Combo2
End Sub

Private Sub ConfigCombo(cmb As ComboBox)
   ' 用值填充一个 combobox。
   Dim i As Single
   For i = 0 To 1 Step 0.1
      cmb.AddItem i
   Next i
   cmb.ListIndex = 0
End Sub

Private Sub Combo1_Click()
   MSChart1.Plot.Light.AmbientIntensity = Combo1.Text
End Sub

Private Sub Combo2_Click()
   MSChart1.Plot.Light.EdgeIntensity = Combo2.Text
End Sub


LightSource 对象

代表用来照射三维图表元素的光源。

语法

LightSource


Location 对象

表示文本图表元素，如标题，图列，或脚注的当前位置。

语法

Location

object 所在处是对象表达式，其值是“应用于”列表中的对象。


Location 对象示例

下面的示例使用 TitleLocation 对象来设置图表标题的位置。要试验该例，在窗体中绘制一个 MSChart 和 ComboBox 控件。粘贴下列代码到该窗体对象的代码模块，然后运行该工程。单击 ComboBox 改变标题的位置。

Option Explicit

Private Sub Combo1_Click()
   MSChart1.Title.Location.LocationType = Combo1.ListIndex
End Sub

Private Sub Form_Load()

   '设置标题文本。
   With MSChart1
      .TitleText = "Test Title Location"

   .Title.Location.Visible = True
   End With

   ' Add LocationType constants to ComboBox.
   With Combo1
      .AddItem "VtChLocationTypeTopLeft"     ' 0
      .AddItem "VtChLocationTypeTop"         ' 1
      .AddItem "VtChLocationTypeTopRight"    ' 2
      .AddItem "VtChLocationTypeLeft"        ' 3
      .AddItem "VtChLocationTypeRight"       ' 4
      .AddItem "VtChLocationTypeBottomLeft"  ' 5
      .AddItem "VtChLocationTypeBottom"      ' 6
      .AddItem "VtChLocationTypeBottomRight" ' 7
      .AddItem "VtChLocationTypeCustom"      ' 8
      .ListIndex = 0
   End With
End Sub


Marker 对象

标识图表中数据点的标记。

语法

Marker


Marker 对象示例

下面的示例为图表系列设置一个蓝色的 X 标记。

Option Explicit
Option Base 1
Private Sub Command1_Click()
   '显示系列 1 的标记。
   Dim i As Integer
   For i = 1 To MSChart1.Plot.SeriesCollection.Count
      With MSChart1.Plot.SeriesCollection _
      .Item(i).DataPoints.Item(-1).Marker
         .Visible = True
         .Size = 20
         .Style = VtMarkerStyleX
         .FillColor.Automatic = False
         .FillColor.Set 0, 0, 255
      End With
   Next i
End Sub


Pen 对象

描述图表上的线段或边框的颜色及线型。

语法

Pen


Pen 对象，GuideLinePen 属性示例

下面的示例为二维 xy 图表系列设置画笔属性。其中 GuideLinePen 属性返回对 Pen 对象的引用。

Private Sub Command1_Click()
   '为二维的 XY 图表的系列 1 设置引导线。
   MSChart1.ChartType = VtChChartType2dXY
   MSChart1.Plot.SeriesCollection.Item(1) _
   .ShowGuideLine(VtChAxisIdX) = True
   With _
   MSChart1.Plot.SeriesCollection.Item(1).GuideLinePen
      '设置画笔属性。
      .VtColor.Set 255, 255, 0
      .Width = 10
      .Style = VtPenStyleDashDot
      .Join = VtPenJoinRound
      .Cap = VtPenCapRound
   End With
End Sub


PlotBase 对象

图表的正下方区域。

语法

PlotBase


PlotBase 对象示例

下面的示例设置三维直方图图表的图表基座参数。

Private Sub Command1_Click()
   '设为三维图表类型
   MSChart1.ChartType = VtChChartType3dBar
   With MSChart1.Plot.PlotBase
      '设置基座高度。
      .BaseHeight = 20
      '选择基座的图案样式。
      .Brush.Style = VtBrushStylePattern
      .Brush.Index = VtBrushPatternHorizontal
      .Brush.FillColor.Set 255, 160, 160
      .Brush.PatternColor.Set 180, 180, 255
      .Pen.Style = VtPenStyleSolid
      .Pen.VtColor.Set 72, 72, 255
   End With
End Sub


Plot 对象

表示图表显示的区域。

语法

Plot

说明

Plot 对象允许您编程以下对象：

  1. Axis 对象—代表图表的 x 、 y 和 z 轴。z 轴仅在立体图表中是可见的。

  2. BackDrop 对象—轴后面的区域。

  12. Light 对象—图的环境和边缘光。

  13. LocationRect 对象—图的位置。

  19. SeriesCollection 对象—序列的集合。

  22. View3D 对象—立体图像的正视图和旋转图。

  23. Wall 对象—图后面的区域


Plot 对象示例

下面的示例设置图表的视图区距离以及沿坐标轴方向各项的间隔。

Private Sub Command1_Click()
   '将图表类型设为三维直方图。
   MSChart1.ChartType = VtChChartType3dBar
   With MSChart1.Plot
      '设置三维直方图图表的视图区。
      .DepthToHeightRatio = 2
      .WidthToHeightRatio = 2
      '设置 X 坐标轴相邻各项的间隔。
      .xGap = 0
      '设置 Z 坐标轴相邻各项的间隔。
      .zGap = 0.8
   End With
End Sub


Rect 对象

定义坐标点。

语法

Rect


LocationRect 属性，Rect 对象示例

下面的示例使用 LocationRect 属性和 Rect 对象 x 和 y 的属性来递增图表绘图区的大小。

Private Sub Command1_Click()
   '递增图表绘图区的大小。
   MSChart1.Plot.AutoLayout = False
   With MSChart1.Plot.LocationRect
.Min.x = .Min.x * 1.2
      .Min.y = .Min.y * 1.2
      .Max.x = .Max.x * 1.2
      .Max.y = .Max.y * 1.2
   End With
End Sub


SeriesMarker 对象

描述标识图表系列中所有数据点的标记。

语法

SeriesMarker


SeriesMarker 对象示例

下面的示例为图表中的所有系列设置标记参数。

Private Sub Command1_Click()
   Dim serX As series
   '显示所有系列的标记，但不显示系列的趋势线。
   MSChart1.chartType = VtChChartType2dLine
   For EachserX In MSChart1.Plot.SeriesCollection
   Form1.MSChart1.Plot.SeriesCollection
      serX.SeriesMarker.Show = True
      serX.ShowLine = False
   Next
End Sub


Series 对象

SeriesCollection 集合中的项，代表图表中的一组数据点。

语法

Series


Series 对象示例

下面的示例将三维折线图中所有系列改变线的外观。

Private Sub Command1_Click()
   Dim serX As Series
   '将图表类型设为三维折线图，
   '并对每条折线进行平滑。
   MSChart1.ChartType = VtChChartType3dLine
   MSChart1.ColumnCount = 4
   For Each serX In MSChart1.Plot.SeriesCollection
      serX.ShowGuideLine(VtChAxisIdY) = True
      serX.GuideLinePen.Style = VtPenStyleDitted
      serX.Pen.Style = 4
   Next
End Sub


SeriesPosition 对象

图表中系列所处的位置，这个位置与其它系列的位置相关。如果所有系列的顺序（位置）相同，则这些系列是叠放的。

语法

SeriesPosition


Shadow 对象

存放关于图表元素的阴影样式的信息。

语法

Shadow


Shadow 对象示例

下面的示例给图表的背景标题设置阴影。

Private Sub Command1_Click()
   '显示标题阴影。
   With MSChart1.Title
      .Location.Visible = True
      .Text = "Chart Title"
   .Backdrop.Frame.Width = 1

      .Backdrop.Frame.FrameColor.Set 255, 0, 0
      .Backdrop.Frame..Style = VtFrameStyleSingleLine
      .Backdrop.Shadow..Style = VtShadowStyleDrop
      .Backdrop.Shadow..Offset.x = 10
      .Backdrop.Shadow..Offset.y = 10
   End With
End Sub


StatLine 对象

描述如何在图表中显示统计线。

语法

StatLine


StatLine 对象示例

下面的示例为图表的统计线设置颜色及画笔的参数。

Private Sub Command1_Click()
   '显示系列 2 的所有统计线。
   MSChart1.chartType = VtChChartType2dLine
   With MSChart1.plot.SeriesCollection(2).StatLine
      .VtColor.Set 128, 128, 255
      .Flag = VtChStatsMinimum Or VtChStatsMaximum _
      Or VtChStatsMean Or VtChStatsStddev Or _
      VtChStatsRegression
      .Style(vtChStatsMinimum) = VtPenStyleDotted
      .width = 2
   End With
End Sub


TextLayout 对象

描述文本的位置及方向。

语法

TextLayout


TextLayout 对象示例

下面的示例设置图表的标题文本的位置及方向。

Private Sub Command1_Click()
   '设置标题文本的位置及方向。
   With Form1.MSChart1.Title
      .Location.Visible = True
      .Location.LocationType = VtChLocationTypeLeft
      .Text = "Title TextLayout"
   End With
   With Form1.MSChart1.Title.TextLayout
      .Orientation = VtOrientationUp
      .HorzAlignment = VtHorizontalAlignmentCenter
      .VertAlignment = VtVerticalAlignmentCenter
   End With
End Sub


Tick 属性

返回对 Tick 对象的引用，该对象描述沿图表坐标轴标识图表项的标记。

语法

object.Tick

object 所在处是对象表达式，其值是“应用于”列表中的对象。


Tick 对象示例

下面的示例为图表中的 y 坐标轴设置标记的长度以及样式。

Private Sub Command1_Click()
   '给 y 坐标轴设置标记。
   With Form1.MSChart1.Plot.Axis(VtChAxisIdY, 1).Tick
      .Length = 500
      .Style = VtChAxisTickStyleOutside
   End With
End Sub


Title 对象

标识图表的文本。

语法

Title


ValueScale 对象

坐标轴显示数值时所用的刻度。

语法

ValueScale


ValueScale 对象示例

下面的示例使用 ValueScale 对象为一个二维直方图图表设置主要和次要网格线的颜色。

Private Sub Command1_Click()
   '图表类型设为二维直方图。
   MSChart1.ChartType = VtChChartType2dBar
   '手工确定 y 坐标轴（数据坐标轴）的刻度。
   With MSChart1.Plot.Axis(VtChAxisIdY).ValueScale
      .Auto = False
      .MajorDivision = 2
      .MinorDivision = 5
   End With
   '用红色显示主要网格线，蓝色显示次要网格线。
   With MSChart1.Plot.Axis(VtChAxisIdY).AxisGrid
      .MajorPen.VtColor.Set 255, 0, 0
      .MajorPen.Width = 4
      .MinorPen.VtColor.Set 0, 0, 255
      .MinorPen.Width = 2
   End With
End Sub


View3D 对象

描述三维图表的实际方向。

语法

View3D


View3D 对象示例

下面的示例使用 view 对象设置三维直方图表的仰角及转角。

Private Sub Command1_Click()
   '图表类型设为三维直方图。
   Form1.MSChart1.ChartType = VtChChartType3dBar
   With Form1.MSChart1.Plot.View3d
      .Elevation = 90   '俯视图表顶部。
      .Rotation = 90
   End With
End Sub


MSChart 控件示例

下面的示例显示一个具有 8 行 8 列数据的三维图表，并设置了图例的参数。

Private Sub Command1_Click()
   With MSChart1
      '显示一个具有 8 行 8 列数据的三维图表。
      .ChartType = VtChChartType3dBar
      .ColumnCount = 8
      .RowCount = 8
      For column = 1 To 8
         For row = 1 To 8
            .Column = column
            .Row = row
            .Data = row * 10
         Next row
      Next column
      '将图表作为图例的背景。
      .ShowLegend = True
      .SelectPart VtChPartTypePlot, index1, index2, _
      index3, index4
      .EditCopy
      .SelectPart VtChPartTypeLegend, index1, _
      index2, index3, index4
      .EditPaste
   End With
End Sub


VtColor 对象

描述图表的绘图颜色。

语法

VtColor


VtColor 对象，FillColor 属性示例

下面的示例设置图表背景画刷的填充颜色。FillColor 属性返回对 VtColor 对象的引用。

Private Sub Command1_Click()
'将背景设为“填充画刷”方式。
   MSChart1.Backdrop.Fill.Style = VtFillStyleBrush
   '将图表的填充颜色设为红色。
   With MSChart1.Backdrop.Fill.Brush.FillColor
      .Red = 255   '使用属性来设置颜色。
      .Green = 0
      .Blue = 0
   End With
End Sub


VtFont 对象

用于显示图表文本的字体。

语法

VtFont


Wall 对象

三维图表中 y 坐标轴所在的平面区域。

语法

Wall


Wall 对象示例

下面的示例为一个三维图表显示彩色墙。

Private Sub Command1_Click()
   '为一个三维图表显示彩色墙。
   Form1.MSChart1.ChartType = VtChChartType3dBar
   With Form1.MSChart1.Plot.Wall
      .Brush.Style = VtBrushStylePattern
      .Brush.Index = VtBrushPatternChecks
      .Brush.FillColor.Set 255, 120, 120
      .Brush.PatternColor.Set 120, 120, 0
      .Width = 20
   End With
End Sub


Weighting 对象

代表在同一图表中与其它饼图相互关联的饼图的大小。

语法

Weighting


Weighting 对象示例

下面的示例显示饼图图表的权。

Private Sub Command1_Click()
   '显示饼图的权。
   Form1.MSChart1.ChartType = VtChChartType2dPie
   With Form1.MSChart1.Plot.Weighting
      .Basis = VtChPieWeightBasisTotal
      .Style = VtChPieWeightStyleArea
   End With
End Sub


ActiveSeriesCount 属性

根据 DataGrid 对象中的列数和绘制的图表类型返回图表中显示的系列数。

语法

object.ActiveSeriesCount

object 所在处代表对象表达式，其值是“应用于”列表中的对象。


AllowDithering 属性

返回或设置一个数值，该数值决定是否禁止八位彩色显示器上图表的颜色抖动，以便使用 MSChart 控件自身的彩色调色板来增强图表的显示。

语法

object.AllowDithering [ =boolean]

AllowDithering 属性的语法包含下面部分：

部分 | 描述
object | 对象表达式，其值是“应用于”列表中的对象。
boolean | 布尔表达式，它指定是否允许颜色抖动，如“设置值”中所描述。

设置值

boolean 的设置值为：

设置值 | 描述
True | 允许颜色抖动。
False | (缺省)使用 MSChart 控件的彩色调色板实现增强的彩色匹配和显示。


AllowDynamicRotation 属性

返回或设置一个数值，它指示是否在：按下 Ctrl 键显示旋转光标之后就可交互式地旋转三维图表。

语法

object.AllowDynamicRotation [ = boolean]

AllowDynamicRotation 属性的语法包含下面部分：

部分 | 描述
object | 对象表达式，其值是“应用于”列表中的对象。
boolean | 布尔表达式，它指定是否允许动态旋转，如“设置值”中所描述。

设置值

boolean 的设置值为：

设置值 | 描述
True | （缺省）可以使用光标交互式旋转图表。
False | 不能使用光标交互式旋转图表。


AllowSelections 属性

返回或设置一个数值，它指示是否可以选择图表对象。

语法

object.AllowSelections [ = boolean]

AllowSelections 属性的语法包含下面部分：

部分 | 描述
object | 对象表达式，其值是“应用于”列表中的对象。
boolean | 布尔表达式，它指定是否可选择图表中的对象，如“设置值”中所描述。

设置值

boolean 的设置值为：

设置值 | 描述
True | （缺省）可以交互式地选择图表对象。
False | 不能选择图表对象。


AllowSeriesSelection 属性

返回或设置一个数值，它指出在单击单个的图表数据点时是否可选定整个系列。

语法

object.AllowSeriesSelection [ = boolean]

AllowSeriesSelection 属性的语法包含下面部分：

部分 | 描述
object | 对象表达式，其值是“应用于”列表中的对象。
boolean | 布尔表达式，它指定是否可选定系列，如“设置值”中所描述。

设置值

boolean 的设置值为：

设置值 | 描述
True | （缺省）可以单击数据点选定整个系列。
False | 单击数据点时仅选定该数据点而不选定整个系列。


AmbientIntensity 属性

返回或设置三维图表周围光亮的百分比。

语法

object.AmbientIntensity [ = intensity ]

AmbientIntensity 属性的语法包含下面部分：

部分 | 描述
object | 对象表达式，其值是“应用于”列表中的对象。
intensity | Single。它代表图表光强度。有效的取值范围是从 0 到 1。如果设置为 1，则无论打开哪个光源，图表元素所有的侧面都将被完全照亮。如果设置为 0，则没有任何周围光源；只有图表元素的那些正对活动光源的侧面才被照亮。


AngleUnit 属性

返回或设置用于度量图表中所有角度的单位。

语法

object.AngleUnit [ = unit]

AngleUnit 属性的语法包含下面部分：

部分 | 描述
object | 对象表达式，其值是“应用于”列表中的对象。
unit | Integer。是描述度量单位的 VtAngleUnits 常数。可以用度、弧度、或梯度来度量角度。


AutoIncrement 属性

返回或设置一个数值，它决定在输入数据期间，那些设置当前数据点的属性值是否能不用人工设置 Column 和 Row 属性而自动递增。

语法

object.AutoIncrement [ = boolean]

AutoIncrement 属性的语法包含下面部分：

部分 | 描述
object | 对象表达式，其值是“应用于”列表中的对象。
boolean | 布尔表达式，它指定当前数据点是否递增，如“设置值”中所描述。

设置值

boolean 的设置值为：

设置值 | 描述
True | Data 属性改变后，Row 属性自动更新为列中的下一行。如果处于一列的末端，则 Column 属性递增到下一列。
False | （缺省）当前数据点不递增。


AutoLayout 属性

返回或设置一个值，该值决定 Plot 对象是采用人工还是自动的布局方式。

语法

object.AutoLayout [ = boolean ]

AutoLayout 属性的语法包含下面部分：

部分 | 描述
object | 对象表达式，其值是“应用于”列表中的对象。
boolean | 布尔表达式，该表达式指定布局方式，如“设置值”中所描述。

设置值

boolean 的设置值如下：

设置 | 描述
True | （缺省）根据其它元素的大小及位置，Plot 对象自动为其绘图区确定一个合适的大小及位置。
False | 使用 Plot 对象的 LocationRect 属性中指定的坐标来确定绘图区的位置。


Automatic 属性

返回或设置一个值，该值决定是否自动计算颜色。该属性仅用于图表元素的边界画笔。

语法

object.Automatic [ = boolean]

Automatic 属性的语法包含下面部分：

部分 | 描述
object | 对象表达式，其值是“应用于”列表中的对象。
boolean | 布尔表达式，如“设置值”中所述，该表达式决定是否自动计算颜色。

设置值

boolean 的设置值如下：

设置 | 描述
True | 自动使用该图表系列所用画刷的颜色。
False | 根据 Value 的值来确定颜色。


Auto 属性 (CategoryScale)

返回或设置一个数值，它指示是否自动为坐标轴决定刻度。

语法

object.Auto [ = boolean]

Auto 属性的语法包含下面部分：

部分 | 描述
object | 对象表达式，其值是“应用于”列表中的对象。
boolean | 布尔表达式，它指定是否显示项目，如“设置值”中所述。

设置值

boolean 的设置值为：

设置值 | 描述
True | （缺省）根据标注的数据自动为坐标轴决定刻度。
False | 不自动为坐标轴定比例。使用 DivisionsPerLabel 和 DivisionsPerTick 中的数值决定比例。


Auto 属性（相交）

返回或设置一个数值，它决定 Intersection 对象是否用 Point 属性的数值来放置坐标轴。

语法

object.Auto [ = boolean]

Auto 属性的语法包含下面部分：

部分 | 描述
object | 对象表达式，其值是“应用于”列表中的对象。
boolean | 布尔表达式，它指定是否显示项目，如“设置值”中所描述。

设置值

boolean 的设置值为：

设置值 | 描述
True | （缺省）将坐标轴放置在标准位置。
False | 将相交的坐标轴放置在 Point 指定的数值处。


Auto 属性（标签）

返回或设置一个数值，此数值决定坐标轴标签是否能够自动旋转以改进图表的布局。

语法

object.Auto [ = boolean ]

Auto 属性的语法包含下面部分：

部分 | 描述
object | 对象表达式，其值是“应用于”列表中的对象。
boolean | 布尔表达式，指定坐标轴标签如何定位，如设置值中所述。

设置值

boolean 的设置值为：

设置值 | 描述
True | （缺省）标签可自动旋转。
False | 标签不能自动旋转。此时将不能正确地显示长标签。


Auto 属性 (SeriesMarker)

返回或设置一个值，该值决定 SeriesMarker 对象是否用下一个可用标记来标记系列中的所有数据点。

语法

object.Auto [ = boolean]

Auto 属性的语法包含下面部分：

部分 | 描述
object | 对象表达式，其值是“应用于”列表中的对象。
boolean | 布尔表达式，该表达式决定如何分配标记，如“设置值”中所描述。

设置值

boolean 的设置值如下：

设置 | 描述
True | (缺省)由 SeriesMarker 对象来分配标记。
False | 可以分配自定义的标记。

说明

如果要改变系列的标记类型，则将该属性设为 False。

如果设置了 DataPoint 对象的 Marker 属性，则该属性自动设为 False。


Auto 属性 (ValueScale)

返回或设置一个值，该值决定是否使用自动调整刻度的特性来显示坐标轴的数值。

语法

object.Auto [ = boolean]

Auto 属性的语法包含下面部分：

部分 | 描述
object | 对象表达式，其值是“应用于”列表中的对象。
boolean | 布尔表达式，该表达式决定是否使用自动调整刻度的特性，如“设置值”中所描述。

设置值

boolean 的设置值如下：

设置 | 描述
True | 根据所绘制的数据自动设置刻度。
False | 使用 Minimum，Maximum，MajorDivisions 以及 MinorDivisions 属性中的值来指定坐标轴刻度。


AxisGrid 属性

返回对 AxisGrid 对象的引用，代表围绕图表坐标轴的平面区域。

语法

object.AxisGrid

object 所在处代表对象表达式，其值是“应用于”列表中的对象。


AxisId 属性

返回与当前坐标轴相交的特定坐标轴。

语法

object.AxisId

object 所在处代表对象表达式，其值是“应用于”列表中的对象。

返回值

返回值是标识相交坐标轴的Integer。


Axis 属性

返回对 Axis 对象的引用，它描述图表的坐标轴。

语法

object.Axis(axisID)

Axis 属性的语法包含下面部分：

部分 | 描述
object | 必需的。对象表达式，其值是“应用于”列表中的对象。
axisID | 必需的。标识特定坐标轴的一个整数或 VtChAxisId 常数。
index | 为以后使用而保留。当存在多个具有相同 axisID 的坐标轴时，该参数标识特定的坐标轴。

说明

有三个坐标轴可用: x 轴、 y 轴和 z 轴。仅当是 3D 图表时，z 轴才可见。


AxisScale 属性

返回对 AxisScale 对象的引用，它描述如何在坐标轴上绘制图表数值。

语法

object.AxisScale

object 所在处表示一个对象表达式，其值是“应用于”列表中的一个对象。


AxisTitle 属性

返回与图表坐标轴关联的 AxisTitle 对象的引用。

语法

object.AxisTitle

object 所在处代表对象表达式，其值是“应用于”列表中的对象。


Backdrop 属性

返回对 Backdrop 对象的引用，它描述在图表或图表元素后面的阴影、图案或图片。

语法

object.Backdrop

object 所在处代表对象表达式，其值是“应用于”列表中的对象。


BarGap 属性

返回或设置同一类中二维条或成簇的三维条之间的间隔。

语法

object.BarGap [ = value]

BarGap 属性的语法包含下面部分：

部分 | 描述
object | 对象表达式，其值是“应用于”列表中的对象。
value | Single。条的间隔距离。用条的宽度百分比表示。若值为 0 则条是互相挨着的。若值为 100 则条之间的间隔等于其宽度。


BaseHeight 属性

返回或设置三维图表的基座高度的点数。

语法

object.BaseHeight [ = height]

BaseHeight 属性的语法包含下面部分：

部分 | 描述
object | 对象表达式，其值是“应用于”列表中的对象。
height | Single。基座高度。


Basis 属性

返回或设置权（weighting）的类型，该类型决定图表中的饼图的大小。

语法

object.Basis [ = type ]

Basis 属性的语法包含下面部分：

部分 | 描述
object | 对象表达式，其值是“应用于”列表中的对象。
type | 是 VtChPieWeightBasis 常数，用于标识权的类型。


Blue 属性

返回或设置图表的 RGB 值的蓝色部分。

语法

object.Blue [=b]

Blue 属性的语法包含下面部分：

部分 | 描述
object | 对象表达式，其值是“应用于”列表中的对象。
b | Integer。蓝色值。

说明

RGB 值说明了所显示颜色的红，绿，蓝三个分量之间的相对强度。正常 RGB 颜色的有效范围是 0 到 16,777,215。任何超过 255 的 RGB 分量值均按 255 处理。


Brush 属性

返回对 Brush 对象的引用，它描述用于显示图表元素的填充类型。

语法

object.Brush

object 所在处代表对象表达式，其值是“应用于”列表中的对象。


Cap 属性

返回或设置决定线段端点样式的值。

语法

object.Cap [ = type ]

Cap 属性的语法包含下面部分：

部分 | 描述
object | 对象表达式，其值是“应用于”列表中的对象。
type | Integer。是描述直线画笔的线段端点样式的 VtPenCap 常量。


CategoryScale 属性

返回对 CategoryScale 对象的引用，它描述分类坐标轴的刻度信息。

语法

object.CategoryScale

object 所在处代表对象表达式，其值是“应用于”列表中的对象。


Chart3d 属性

返回一个数值，此数值指定图表是否为三维图表。

语法

object.Chart3D

object 所在处代表对象表达式，其值是“应用于”列表中的对象。

返回值

设置值 | 描述
True | 图表是三维图表。
False | 图表不是三维图表。

说明

某个图表是否是三维的取决于 ChartType 属性的设置值。


ChartData 属性

返回或设置一个数组，该数组包含将要被该图表显示的值。

语法

object.ChartData [ = data ]

ChartData 属性的语法包含下面部分：

部分 | 描述
object | 对象表达式，其值是“应用于”列表中的对象。
data | 变体型数值。二维数组，其中包含用来绘制图表的数据。

说明

如果某个多维数组的第一列包含字符串，则这些字符串将成为该图表的标签。

ChartData 是 MSChart 控件的缺省属性。


ChartData 属性示例

下面的示例使用 Visual Basic 数组直接加载图表数据网格。要试验该例，在窗体中绘制一个 MSChart 控件，粘贴下面的代码到该窗体对象的代码中：

Option Explicit
Option Base 1

Private Sub Form_Load()
    Dim arrData(3, 1 To 3)
    arrData(1, 1) = "Jan"   ' 在第一列设置标签。
    arrData(2, 1) = "Feb"
    arrData(3, 1) = "Mar"

    arrData(1, 2) = 8
    arrData(2, 2) = 4
    arrData(3, 2) = 0.3

    arrData(1, 3) = 0.2
    arrData(2, 3) = 3
    arrData(3, 3) = 6.3
    MSChart1.ChartData = arrData
End Sub

本例中将最低下标边界使用 Option Base 1语句声明为 1 而不声明为缺省值 0。这儿使用 Variant 数组，将第一个序列的值设置为字符串变量并将其第二个和第三个序列的值设置为数值。这样即可同时设置图表标签和数据。注意，也可将数值的类型声明为 String 类型，只要数组第二个和第三个序列包含代表数值的文本。如果只想设置图表数据，那么数组能为 Integer、Long、Single 或 Double 中的任一种数值类型。请注意这样设置将使缺省的行/列标签代替现有的图表标签。同时，如果数组最后的数值是数值型或是代表数值的文本，那么也可以使用一维数组。

下面的示例从图表中返回数据。示例中包含一个循环，它将把从图表返回的数组打印出来。注意，示例使用 Lbound 和 Ubound 函数判断从图表返回数组的上下边界。要试验该例，在窗体中绘制一个 CommandButton 控件和 MSChart 控件。粘贴下面的代码到代码模块中，运行该工程，并且单击该按钮。

Option Explicit
Private Sub Command1_Click()
   Dim y() As Variant
   Dim i, j As Integer
   Y = MSChart1.ChartData
For i = LBound(y, 2) To UBound(y, 2)
      Debug.Print
      For j = LBound(y, 1) To UBound(y, 1)
         Debug.Print y(j, i)
      Next j
   Next i
End Sub

返回的数组下边界数值等于 0。此数组总是变体型二维数组。因为图表的缺省属性是 ChartData，单独的对象名（例如 MSChart1）能替换为 MSChart1.ChartData。所以可用 MSChart1 = data 或者 data = MSChart1。


ChartType 属性

返回或设置用于显示图表的图表类型。

语法

object.ChartType [ = type]

ChartType 属性的语法包含下面部分：

部分 | 描述
object | 对象表达式，其值是“应用于”列表中的对象。
type | Integer。描述图表类型的 VtChChartType常数。


Clockwise 属性

返回或设置值，该值指定是否按顺时针方向绘制饼图图表。

语法

object.Clockwise [ = boolean]

Clockwise 属性的语法包含下面部分：

部分 | 描述
object | 对象表达式，其值是“应用于”列表中的对象。
boolean | 布尔表达式，该表达式决定饼图图表的绘制方向，如“设置值”中所描述。

设置值

boolean 的设置值如下：

设置 | 描述
True | （缺省）按顺时针方向绘制饼图图表。
False | 按逆时针方向绘制饼图图表。


ColumnCount 属性

返回或设置与图表关联的当前数据网格中的列数。

语法

object.ColumnCount [ = count]

ColumnCount 属性的语法包含下面部分：

部分 | 描述
object | 对象表达式，其值是“应用于”列表中的对象。
count | 数据列数。


ColumnLabelCount 属性

返回或设置与图表关联的数据网格中的列的标签级别数。

语法

object.ColumnLabelCount [ = count]

ColumnLabelCount 属性的语法包含下面部分：

部分 | 描述
object | 对象表达式，其值是“应用于”列表中的对象。
count | Integer。列标签级别数。可设置此属性以添加或删除数据网格列上的标签级别。

说明

从 1 开始、自下而上列标签级别编号。从顶部添加或减少级别。


ColumnLabelIndex 属性

返回或设置与图表关联的特定列标签的级别。

语法

object.ColumnLabelIndex [ = index]

ColumnLabelIndex 属性的语法包含下面部分：

部分 | 描述
object | 对象表达式，其值是“应用于”列表中的对象。
index | Integer。它标识列标签级别。

说明

要将列标签设置多个标签级别，或者要返回标签当前值时，必须首先标识要影响的级别。列标签级别编号时从 1 开始从底端向顶端编号。


ColumnLabel 属性 (MSChart)

返回或设置与图表数据网格中的列关联的标签文本。

语法

object.ColumnLabel [ = text ]

ColumnLabel 属性的语法包含下面部分：

部分 | 描述
object | 对象表达式，其值是“应用于”列表中的对象。
text | 字符串。与数据网格中的列相关联的标签文本。

说明

此属性设置 Column 属性当前标识的列的标签。


ColumnLabel 属性 （DataGrid 对象）

返回或设置与图表关联的网格中数据列的标签。

语法

object.ColumnLabel( column, labelIndex ) [= text ]

ColumnLabel 属性的语法包含下面部分：

部分 | 描述
object | 对象表达式，其值是“应用于”列表中的对象。
column | Integer。它标识特定的数据列。列编号时从 1 开始，由左向右依次编号。任何包含标签的列不作为数据列计数。
labelIndex | Integer。标识特定的标签。如果对该列有多个列标签级别，则必须标识其中之一。列标签从 1 开始，从左向右依次编号。
text | 字符串。列标签文本。


ColumnLabel 属性示例

该示例对图表的 z 轴添加了三列标签。要试着使用该示例，请在窗体上绘制一个 MSChart 控件。将代码粘贴到 Form 对象的代码模块中，并运行该工程。单击该窗体查看标签。

Option Explicit
Option Base 1

Private Sub Form_Click()
   With MSChart1
      .chartType = VtChChartType3dLine

      .Plot.Axis(VtChAxisIdZ).Labels(1).VtFont.Size = 24
      .DataGrid.ColumnLabel(1, 1) = "Label Z1"
      .DataGrid.ColumnLabel(2, 1) = "Label Z2"
      .DataGrid.ColumnLabel(3, 1) = "Label Z3"
   End With
End Sub

Private Sub Form_Load()
   ' 第一系列包含了 X 轴的标签。
   Dim arrData(4, 1 To 4)
   arrData(1, 1) = "Jan"
   arrData(2, 1) = "Feb"
   arrData(3, 1) = "Mar"
   arrData(4, 1) = "Apr"

   arrData(1, 2) = 8
   arrData(2, 2) = 4
   arrData(3, 2) = 0.3
   arrData(4, 2) = 3

   arrData(1, 3) = 0.2
   arrData(2, 3) = 3
   arrData(3, 3) = 6.3
   arrData(4, 3) = 2

   arrData(1, 4) = 5
   arrData(2, 4) = 7
   arrData(3, 4) = 2
   arrData(4, 4) = 9
   MSChart1.ChartData = arrData
End Sub


Column 属性（MSChart 控件）

返回或设置数据网格中当前的数据列。

语法

object.Column [ = col ]

Column 属性的语法包含下面部分：

部分 | 描述
object | 对象表达式，其值是“应用于”列表中的对象。
col | Integer。当前数据列。

说明

必须选定列后才能使用其它属性更改列中相应的图表系列或系列中的任何数据点。


Component 属性

返回或设置用来标识数据点的标签类型。

语法

object.Component [ = type]

Component 属性的语法包含下面部分：

部分 | 描述
object | 对象表达式，其值是“应用于”列表中的对象。
type | Integer。标识标签类型的 VtChLabelComponent 常数。


CompositeColumnLabel 属性

返回多级标签字符串标识与图表关联的数据网格中的列。

语法

object.CompositeColumnLabel(column)

CompositeColumnLabel 属性的语法包含下面部分：

部分 | 描述
object | 对象表达式，其值是“应用于”列表中的对象。
column | Integer。标识特定的数据列。列标号从 1 开始，由左向右依次编号。任何包含标签的列不作为数据列计数。


CompositeRowLabel 属性

返回多级标签字符串，它标识与图表关联的数据网格中的行。

语法

object.CompositeRowLabel (row)

CompositeRowLabel 属性的语法包含下面部分：

部分 | 描述
object | 对象表达式，其值是“应用于”列表中的对象。
row | Integer。标识特定的数据行。行从 1 开始、由底端向顶端依次编号。任何包含标签的行不作为数据行计数。


Custom 属性

返回或设置一个数值，它决定是否使用自定义文本标注图表的数据点。

语法

object.Custom [ = boolean]

Custom 属性的语法包含下面部分：

部分 | 描述
object | 对象表达式，其值是“应用于”列表中的对象。
boolean | 布尔表达式，指定是否使用自定义文本，如“设置值”中所描述。

设置值

boolean 的设置值为：

设置值 | 描述
True | 标签中包含自定义文本。
False | （缺省）DataPointLabel 对象的 Components 属性指定的信息被用来标注数据点。


DataGrid 属性

返回 DataGrid 对象的引用，它描述与图表关联的数据网格。

语法

object.DataGrid

object 所在处代表对象表达式，其值是“应用于”列表中的对象。


DataPointLabel 属性

返回对 DataPointLabel 对象的引用，它描述个别图表数据点上的标签。

语法

object.DataPointLabel

object 所在处代表对象表达式，其值是“应用于”列表中的对象。


DataPoints 属性

返回对 DataPoint 集合的引用，它描述图表系列中的数据点。

语法

object.DataPoints

object 所在处代表对象表达式，其值是“应用于”列表中的对象。


Data 属性 (MSChart)

返回或设置被插入图表数据网格中的当前数据点的数值。

语法

object.Data [ = value]

Data 属性的语法包含下面部分：

部分 | 描述
object | 对象表达式，其值是“应用于”列表中的对象。
value | Integer。数据点数值。

说明

如果当前数据点已经包含数据，则新数据将代替原有数据。重新绘制图表以反映当前数据点的新数值。


DataSeriesInRow 属性

返回或设置值，该值指示按该图表所关联的数据网格的行或列来读取系列的数据。

语法

object.DataSeriesInRow [ = boolean]

DataSeriesInRow 属性的语法包含下面部分：

部分 | 描述
object | 对象表达式，其值是“应用于”列表中的对象。
boolean | 布尔表达式，该表达式决定系列数据的读取方式，如“设置值”中所描述。

设置值

其中 boolean 的设置值如下：

设置 | 描述
True | 按数据网格的行读取系列的数据。
False | （缺省）按数据网格的列读取系列的数据。


DefaultPercentBasis 属性

返回图表百分制的缺省坐标轴。

语法

object.DefaultPercentBasis

object 所在处是对象表达式，其值是“应用于”列表中的对象。

Return Value

一个表示图表百分制缺省坐标轴的整数。可能的返回值是 VtChPercentAxisBasis 常数。


DepthToHeightRatio 属性

返回或设置图表的深度与高度的百分比。

语法

object.DepthToHeightRatio [ = pctg]

DepthToHeightRatio 属性的语法包含下面部分：

部分 | 描述
object | 对象表达式，其值是“应用于”列表中的对象。
pctg | Single。图表高度的百分比。

说明

该属性只有在三维图表类型中才有效果。


DivisionsPerLabel 属性

返回或设置标签之间跳过的部分数。

语法

object.DivisionsPerLabel [ = num]

DivisionsPerLabel 属性的语法包含下面部分：

部分 | 描述
object | 对象表达式，其值是“应用于”列表中的对象。
num | Integer。它代表部分数。

说明

如果设置了该属性，则 Auto 属性将自动设置为 False。


DivisionsPerTick 属性

返回或设置主刻度之间跳过的部分数。

语法

object.DivisionsPerTick [ = num ]

DivisionsPerTick 属性的语法包含下面部分：

部分 | 描述
object | 对象表达式，其值是“应用于”列表中的对象。
num | Integer。代表部分数。

说明

如果设置了该属性，则对象的 Auto 属性将自动设置为 False。


DoSetCursor 属性

返回或设置一个数值，它指示图表是否能设置光标。DoSetCursor 属性决定应用程序是否能够控制鼠标指针的外观。

语法

object.DoSetCursor [ = boolean]

DoSetCursor 属性的语法包含下面部分：

部分 | 描述
object | 对象表达式，其值是“应用于”列表中的对象。
boolean | 布尔表达式，它指定是否使用自定义文本，如“设置值”中所描述。

设置值

boolean 的设置值为：

设置值 | 描述
True | （缺省）应用程序可控制鼠标指针的外观。
False | 应用程序不能控制鼠标指针的外观。


DrawMode 属性 (MSChart)

返回或设置一个数值，它决定什么时候以及如何重绘图表。

语法

object.DrawMode [ = mode]

DrawMode 属性的语法包含下面部分：

部分 | 描述
object | 对象表达式，其值是“应用于”列表中的对象。
mode | Integer。它决定什么时候、用什么方法重绘图表，如“设置值”中所描述。

设置值

mode 的设置值为：

常数 | 设置值 | 描述
VtChDrawModeDraw | 0 | 直接绘制到显示设备上。
VtChDrawModeBlit | 1 | 使用 Blit 方式把内存中的图形绘制到显示设备上。


EdgeIntensity 属性

返回或设置用来绘制三维图表对象边缘的光线强度。

语法

object.EdgeIntensity [ = edgeint ]

EdgeIntensity 属性的语法包含下面部分：

部分 | 描述
object | 对象表达式，其值是“应用于”列表中的对象。
edgeint | Single。它代表边缘光源强度。有效的取值范围是从 0 到 1。设置强度为 0 时将关闭边缘光源并用黑色线段绘制图表元素的边缘；强度设置为 1 时完全照亮边缘并用元素的笔的颜色绘制这些边缘。

说明

如果设置了这个属性，则 Light 对象的 EdgeVisible 属性将自动设置为 True。


EdgePen 属性

返回 Pen 对象，此对象用于绘制图表中数据点的边界。

语法

object.EdgePen

object 所在处是对象表达式，其值是“应用于”列表中的对象。


EdgeVisible 属性

返回或设置一个数值，该数值决定是否显示三维图表元素的边缘。

语法

object.EdgeVisible [ = boolean ]

EdgeVisible 属性的语法包含下面部分：

部分 | 描述
object | 对象表达式，其值是“应用于”列表中的对象。
boolean | 布尔表达式，它指定显示的边缘，如“设置值”中所描述。

设置值

boolean 的设置值为：

设置值 | 描述
True | 边缘可见。
False | 不显示三维图表元素的边缘。


Effect 属性

返回或设置图表的字体效果。

语法

object.Effect [ = effects ]

Effect 属性的语法包含下面部分：

部分 | 描述
object | 对象表达式，其值是“应用于”列表中的对象。
effects | Integer。是描述字体效果的 VtFontEffect 常数。


Elevation 属性

返回或设置一个值。该值指定三维图表的观察仰角的度数。

语法

object.Elevation [ = degree]

Elevation 属性的语法包含下面部分：

部分 | 描述
object | 对象表达式，其值是“应用于”列表中的对象。
degree | Single。仰角的度数。 0 至 90 度都是合法的仰角度数。如果将仰角设为 90 度，就变成从上面俯视图表的顶部。如果将仰角设为 0 度，就变成正视图表的侧面。缺省值为 30 度。仰角的缺省单位是度。不过这取决于 AngleUnits 属性的当前设置值。其它的选项为：梯度以及弧度。


Excluded 属性

返回或设置一个值，该值决定是否将某个系列包括在图表之中。

语法

object.Excluded [ = boolean]

Excluded 属性的语法包含下面部分：

部分 | 描述
object | 对象表达式，其值是“应用于”列表中的对象。
boolean | 布尔表达式，该表达式决定是否将系列包括在图表中，如“设置值”中所描述。

设置值

boolean 的设置值如下：

设置 | 描述
True | 绘制图表时，不绘制该系列。
False | （缺省）图表中包括该系列。通过设置 Hidden 属性，可以在图表中包括某个系列而不显示它。


FillColor 属性

返回对 VtColor 对象的引用，它描述用于填充图表元素的颜色。

语法

object.FillColor

object 所在处代表对象表达式，其值是“应用于”列表中的对象。

说明

若设置了 Marker 对象的 FillColor 属性，则 Marker 对象的 Visible 属性将被自动设置为 True。


Fill 属性

返回对 Fill 对象的引用，它描述图表对象背景的类型和外观。

语法

object.Fill

object 所在处代表对象表达式，其值是“应用于”列表中的对象。


Flag 属性

返回或设置显示系列的是哪条统计线。

语法

object.Flag [ = lines]

Flag 属性的语法包含下面部分：

部分 | 描述
object | 对象表达式，其值是“应用于”列表中的对象。
lines | Integer。是用于描述统计线的 VtChStats 常量。如果显示的统计线不止一条，则使用 OR 操作符来组合这些常量。


Font 属性 (MSChart)

返回对标准 Font 对象的引用，它描述在图表上显示文本所用的字体。

语法

object.Font

object 所在处代表对象表达式，其值是“应用于”列表中的对象。


Footnote 属性

返回对 Footnote 对象的引用，它提供关于注释图表所用的描述性文字信息。

语法

object.Footnote

object 所在处代表对象表达式，其值是“应用于”列表中的对象。


FootnoteText 属性

返回或设置用作脚注的文本。

语法

object.FootnoteText [ = text]

FootnoteText 属性的语法包含下面部分：

部分 | 描述
object | 对象表达式，其值是“应用于”列表中的对象。
text | 字符串数值。脚注文本。

说明

可使用 Footnote 对象的 Text 属性达到同样的效果。


FormatLength 属性

返回格式字符串的长度。

语法

object.FormatLength

object 所在处代表对象表达式，其值是“应用于”列表中的对象。

返回值

整数


Format 属性 (MSChart)

返回或设置用来定义显示坐标轴标签格式的字符。

语法

object.Format [ = format]

Format 属性的语法包含下面部分：

部分 | 描述
object | 对象表达式，其值是“应用于”列表中的对象。
format | 字符串。定义用来显示坐标轴标签的格式。


FrameColor 属性

返回对 VtColor 对象的引用，该对象指定环绕图表元素的单框所用的颜色。

语法

object.FrameColor

object 所在处是对象表达式，其值是“应用于”列表中的对象。


Frame 属性

返回对 Frame 对象的引用，它描述图表元素周围框架的外观。

语法

object.Frame

object 所在处代表对象表达式，其值是“应用于”列表中的对象。


Green 属性

返回或设置图表的 RGB 值的绿色份额。

语法

object.Green [=g]

Green 属性的语法包含下面部分：

部分 | 描述
object | 对象表达式，其值是“应用于”列表中的对象。
g | Integer。绿色值。

说明

RGB 值说明了所显示颜色的红，绿，蓝三个分量之间的相对强度。正常 RGB 颜色的有效范围是 0 到 16,777,215。任何超过 255 的 RGB 分量值均按 255 处理。


GuidelinePen 属性

返回对 Pen 对象的引用，该对象描述用于显示引导线的线型及颜色。

语法

object.GuidelinePen

object 所在处是对象表达式，其值是“应用于”列表中的对象。

说明

设置该属性会自动将 ShowGuideLines 属性设为 True。


Hidden 属性 (MSChart)

返回或设置一个值，该值决定是否在图表中显示系列。

语法

object.Hidden [ = boolean]

Hidden 属性的语法包含下面部分：

部分 | 描述
object | 对象表达式，其值是“应用于”列表中的对象。
boolean | 布尔表达式，该表达式决定是否在图表上显示系列，如“设置值”中所描述。

设置值

boolean 的设置值如下：

设置 | 描述
True | 在显示图表时，不显示该系列。不过仍会保留分配给该系列的位置。
False | （缺省）显示该系列。


Hide 属性

返回或设置一个数值，它决定是否隐藏图表的坐标轴。

语法

object.Hide [ = boolean]

Hide 属性的语法包含下面部分：

部分 | 描述
object | 对象表达式，其值是“应用于”列表中的对象。
boolean | 布尔表达式，它指定是否隐藏坐标轴，如“设置值”中所描述。

设置值

boolean 的设置值为：

设置值 | 描述
True | 隐藏坐标轴刻度、轴线、刻度标记和标题。
False | （缺省）在图表上显示坐标轴。


HorzAlignment 属性

返回或设置文本的水平对齐方式。

语法

object.HorzAlignment [ = type]

HorzAlignment 属性的语法包含下面部分：

部分 | 描述
object | 对象表达式，其值是“应用于”列表中的对象。
type | Integer。是用于描述文本水平对齐方式的 VtHorizontalAlignment 常数。


Index 属性 (Brush)

如果画笔的 Style 属性设置为 VtBrushStylePattern 或 VtBrushStyleHatch，则此属性返回或设置画笔中使用的图案或阴影。

语法

object.Index [= num ]

Index 属性的语法包含下面部分：

部分 | 描述
object | 对象表达式，其值是“应用于”列表中的对象。
num | 描述画笔图案的 VtBrushPattern 常数或 VtBrushHatch 常数。


Index 属性（相交）

当有多个坐标轴具有相同索引时，返回与另一个坐标轴相交的坐标轴。

语法

object.Index

object 所在处代表对象表达式，其值是“应用于”列表中的对象。

返回值

返回值为Integer，它指定相交坐标轴的索引。当前，此参数唯一有效的设置值是 1。


Intensity 属性

返回或设置光源发出的光的强度。

语法

object.Intensity [ = strength]

Intensity 属性的语法包含下面部分：

部分 | 描述
object | 对象表达式，其值是“应用于”列表中的对象。
strength | Single。光的强度。如果将强度设为百分之百（1），则图表表面中面向光源的部分将被彻底照亮。如果将强度设为百分之五十（.5），则面向光源的表面部分将接收该光源百分之五十的光照。有效范围为 0 到 1。

说明

Intensity 是 LightSource 对象的缺省属性。


Intersection 属性

返回对 Intersection 对象的引用，它描述图表上两坐标轴的相交点。

语法

object.Intersection

object 所在处代表对象表达式，其值是“应用于”列表中的对象。


Item 属性 (MSChart)

返回对集合中的对象的引用，该集合描述图表元素。

语法

object.Item (index)

Item 属性语法包含下列部分：

部分 | 描述
object | 对象表达式，其值是“应用于”列表的一个对象。
index | 一个唯一的整数，标识该集合的成员。


Join 属性

返回或设置决定线段的连接方式的值。

语法

object.Join [ = type ]

Join 属性的语法包含下面部分：

部分 | 描述
object | 对象表达式，其值是“应用于”列表中的对象。
type | Integer。是描述画笔的连接方式的 VtPenJoin 常数。


LabelLevelCount 属性

返回或设置给定坐标轴标签的级别数。设计时不可用。

语法

object.LabelLevelCount [= count]

LabelLevelCount 属性的语法包含下面部分：

部分 | 描述
object | 对象表达式，其值是“应用于”列表中的对象。
count | Integer。它描述标签的数目。


LabelsInsidePlot 属性

返回或设置一个数值，它决定是将坐标轴标签保留在正常位置，还是将它们与坐标轴一起移动到新的相交点。

语法

object.LabelsInsidePlot [= boolean]

LabelsInsidePlot 属性的语法包含下面部分：

部分 | 描述
object | 对象表达式，其值是“应用于”列表中的对象。
boolean | 布尔表达式，它指定显示坐标轴标签的位置，如“设置值”中所描述。

设置值

boolean 的设置值为：

设置值 | 描述
True | （缺省）坐标轴标签保留在正常位置。
False | 图象内部的标签移动到新的相交点处。

说明

如果设置了这个属性，则 Intersection 对象的 Auto 属性将自动设置为 False。


Labels 属性

返回对 Labels 集合的引用，它描述图表坐标轴上的标签。

语法

object.Labels

object 所在处代表对象表达式，其值是“应用于”列表中的对象。


LabelTick 属性

返回或设置一个数值，该数值指示分类坐标轴标签是否位于坐标轴刻度标记的中心。

语法

object.LabelTicks [ = boolean]

LabelTicks 属性的语法包含下面部分：

部分 | 描述
object | 对象表达式，其值是“应用于”列表中的对象。
boolean | 布尔表达式，它指定是否显示项目，如“设置值”中所述。

设置值

boolean 的设置值为：

设置值 | 描述
True | 标签位于刻度标记的中心。
False | (缺省)标签位于两个刻度标记之间。

说明

如果设置了该属性，则对象的 Auto 属性将自动设置为 False。


Legend 属性

返回对 Legend 对象的引用，它包含有关小图标的外观及其描述图表系列的伴随文字的信息。

语法

object.Legend

object 所在处代表对象表达式，其值是“应用于”列表中的对象。


LegendText 属性

返回或设置在图表的图例中标识系列的文本。

语法

object.LegendText [ = text ]

LegendText 属性的语法包含下面部分：

部分 | 描述
object | 对象表达式，其值是“应用于”列表中的对象。
text | String 类型。标识在图例中当前系列的文本。

说明

缺省情况下，该文本和 ColumnLabel 对象的 Text 属性的文本相同。


Length 属性 (MSChart)

返回或设置坐标轴 tick 标记的长度，以点为单位。

语法

object.Length [ = length]

Length 属性的语法包含下面部分：

部分 | 描述
object | 对象表达式，其值是“应用于”列表中的对象。
length | Integer。坐标轴标记的长度。


Light 属性

返回对 Light 对象的引用，它提供有关三维图表亮度的信息。

语法

object.Light

object 所在处代表对象表达式，其值是“应用于”列表中的对象。


LightSources 属性

返回对 LightSources 集合的引用，它描述三维图表照明所使用的所有光源。

语法

object.LightSources

object 所在处代表对象表达式，其值是“应用于”列表中的对象。


Limit 属性

返回或设置该直线连接点的极限。

语法

object.Limit [ = joint ]

Limit 属性的语法包含下面部分：

部分 | 描述
object | 对象表达式，其值是“应用于”列表中的对象。
joint | Single。连接极限应是线宽的整数倍。如果两条线相交成一个锐角，则斜向连接点将在实际的交点之外。如果从内侧交点至外侧交点的距离大于由这个变量所指定的值，则连接方式自动改为斜角。


LineStyle 属性(DataPointLabel Object)

返回或设置用来连接图表中数据点和标签的线段类型。

语法

object.LineStyle [ = type]

LineStyle 属性的语法包含下面部分：

部分 | 描述
object | 对象表达式，其值是“应用于”列表中的对象。
type | Integer。VtChLabelLineStyle 常数，它标识连接的直线。


Location 属性

返回对 Location 对象的引用，该对象描述文本图表元素的位置。

语法

object.Location

object 所在处是对象表达式，其值是“应用于”列表中的对象。


LocationRect 属性

返回对 Rect 对象的引用，该对象用 x，y 坐标描述图表绘图区的位置。

语法

object.LocationRect

object 所在处是对象表达式，其值是“应用于”列表中的对象。

说明

如果 AutoLayout 为 False，则该属性的值用于绘图区的定位。

如果设置了该属性，则 AutoLayout 属性自动设为 False。


LocationType 属性

返回或设置显示图表元素的标准位置。

语法

object.LocationType [=type]

LocationType 属性的语法包含下面部分：

部分 | 描述
object | 对象表达式，其值是“应用于”列表中的对象。
type | Integer。对于 DataPointLabel 对象，该参数是标识标签位置的 VtChLabelLocationType 常数。 对于 Location 对象，该参数是描述文本位置的 VtChLocationType 常数。


LogBase 属性

返回或设置在对数坐标轴上绘制图表数值时使用的对数底数。

语法

object.LogBase [ = base]

LogBase 属性的语法包含下面部分：

部分 | 描述
object | 对象表达式，其值是“应用于”列表中的对象。
base | Integer。它标识对数的底数。缺省的底数为 10。有效的取值范围是从 2 到 100。

说明

仅当 Type 属性设置为 VtChScaleTypeLogarithmic 时，此属性有效果。


MajorDivision 属性

返回或设置在坐标轴上显示的主要图表项的数目。

语法

object.MajorDivision [ = num]

MajorDivision 属性的语法包含下面部分：

部分 | 描述
object | 对象表达式，其值是“应用于”列表中的对象。
num | Integer。图表项的数目。

说明

如果设置该属性，则 ValueScale 对象的 Auto 属性自动设为 False。


MajorPen 属性

返回对 Pen 对象的引用，它描述主坐标轴网格线的外观。

语法

object.MajorPen

object 所在处代表对象表达式，其值是“应用于”列表中的对象。


Marker 属性

返回对 Marker 对象的引用，该对象描述用来标识图表中的数据点的图标。

语法

object.Marker

object 所在处是对象表达式，其值是“应用于”列表中的对象。


Maximum 属性

返回或设置图表坐标轴的最大值或终止值。

语法

object.Maximum [ = value]

Maximum 属性的语法包含下面部分：

部分 | 描述
object | 对象表达式，其值是“应用于”列表中的对象。
value | Double。坐标轴的最大值。

说明

如果设置该属性，则 ValueScale 对象的 Auto 属性自动设为 False。

Maximum 属性的设置应在设置 Minimum 属性之前，以避免图表显示出错。


Max 属性 (MSChart)

返回对 Coor 对象的引用，该对象描述矩形的终止坐标点。

语法

object.Max

object 所在处是对象表达式，其值是“应用于”列表中的对象。


Minimum 属性

返回或设置图表坐标轴的最小值或起始值。

语法

object.Minimum [ = value]

Minimum 属性的语法包含下面部分：

部分 | 描述
object | 对象表达式，其值是“应用于”列表中的对象。
value | Double。坐标轴的最小值。

说明

如果设置该属性，则 ValueScale 对象的 Auto 属性自动设为 False。

Maximum 属性的设置应在设置 Minimum 属性之前，以避免图表显示出错。


MinorDivision 属性

返回或设置在坐标轴上显示的次要图表项的数目。

语法

object.MinorDivision [ = num]

MinorDivision 属性的语法包含下面部分：

部分 | 描述
object | 对象表达式，其值是“应用于”列表中的对象。
num | Integer。次要图表项的数目。

说明

如果设置该属性，则 ValueScale 对象的 Auto 属性自动设为 False。


MinorPen 属性

返回对 Pen 对象的引用，它描述次坐标轴网格线的外观。

语法

object.MinorPen

object 所在处代表对象表达式，其值是“应用于”列表中的对象。


Min 属性 (MSChart)

返回对 Coor 对象的引用，该对象描述矩形的起始坐标点。

语法

object.Min

object 所在处是对象表达式，其值是“应用于”列表中的对象。


MousePointer 属性 (MSChart)

vbcstMousePointerConstants

返回或设置一个值，该值指定运行时当鼠标位于对象的特定部分时应显示的鼠标光标类型。

语法

object.MousePointer [ = value ]

MousePointer 属性的语法包含下面部分：

部分 | 描述
object | 对象表达式，其值是“应用于”列表中的对象。
value | 整数。是描述鼠标光标显示类型的 VtMousePointer 常数。


Name 属性 (VtFont)

返回或设置字体的名称。这是 VtFont 对象的缺省属性。

语法

object.Name [ = text ]

Name 属性的语法包含下面部分：

部分 | 描述
object | 对象表达式，其值是“应用于”列表中的对象。
text | Integer。包含字体名称的文本。


Offset 属性

返回或设置，图表元素与它的缺省位置偏移的距离。

语法

object.Offset [ = offset ]

Offset 属性的语法包含下面部分：

部分 | 描述
object | 对象表达式，其值是“应用于”列表中的对象。
offset | 对于 DataPoint 对象，该Integer描述偏移距离。偏移量根据缺省 Windows 设置值，以英寸或厘米计量。 对于 DataPointLabel 和 Shadow 对象，该参数是 Coor 对象的引用，它描述偏移量的 x、y 数值。

说明

对于 DataPointLabel 对象，此属性指示数据点标签距某预定义（标准）标签位置的偏移量。当根据 DataPointLabel 对象的 LocationType 设置值计算位置时，应加入此偏移量。


Order 属性

返回或设置系列在图表中的位置。如果这个位置与别的系列的位置相同，则叠加放置这些系列。

语法

object.Order [ = order]

Order 属性的语法包含下面部分：

部分 | 描述
object | 对象表达式，其值是“应用于”列表中的对象。
order | Integer。位置的序号。


Orientation 属性 (MSChart)

返回或设置文本的方向。

语法

object.Orientation [ = type]

Orientation 属性的语法包含下面部分：

部分 | 描述
object | 对象表达式，其值是“应用于”列表中的对象。
type | Integer。是用于描述文本方向的 VtOrientation 常数。


PatternColor 属性

返回对 VtColor 对象的引用，它描述用来填充图表元素的图案。

语法

object.PatternColor

object 所在处代表对象表达式，其值是“应用于”列表中的对象。


Pen 属性

返回或设置对 Pen 对象的引用，该对象描述图表元素上的线段或边框的颜色及线型。

语法

object.Pen

object 所在处是对象表达式，其值是“应用于”列表中的对象。


PercentBasis 属性

返回或设置在百分比坐标轴上用来绘制图表数值的百分比类型。

语法

object.PercentBasis [ = type ]

PercentBasis 属性的语法包含下面部分：

部分 | 描述
object | 对象表达式，其值是“应用于”列表中的对象。
type | 用来描述绘制百分比坐标轴数值的VtChPercentAxisBasis常数。

说明

仅当 Type 属性设置为VtChScaleTypePercent时，此属性有效果。


PercentFormat 属性

返回或设置一个字符串，它描述用来显示百分比标签的格式。

语法

object.PercentFormat [ = format]

PercentFormat 属性的语法包含下面部分：

部分 | 描述
object | 对象表达式，其值是“应用于”列表中的对象。
format | 字符串。描述用来显示百分比标签的格式。

说明

请用 DataPointLabel 对象的 Component 属性改变标签类型。

下表中列出若干百分比格式字符串示例。左面列出的数值是有效格式。

 | 3 | -3 | .3
0% | 300% | -300% | 30%
0.0% | 300.0% | -300.0% | 30.0%
0.00% | 300.00% | -300.00% | 30.00%


PlotBase 属性

返回对 PlotBase 对象的引用，该对象描述图表中正下方区域的外观。

语法

object.PlotBase

object 所在处是对象表达式，其值是“应用于”列表中的对象。


Plot 属性

返回对 Plot 对象的引用，该对象描述图表的绘制区域。

语法

object.Plot

object 所在处是对象表达式，其值是“应用于”列表中的对象。


Point 属性

返回或设置当前坐标轴与另一坐标轴的相交点。

语法

object.Point [ = point]

Point 属性的语法包含下面部分：

部分 | 描述
object | 对象表达式，其值是“应用于”列表中的对象。
point | Double。当前坐标轴与一个轴的相交点。

说明

如果设置了该属性，则 Intersection 对象的 Auto 属性将自动设置为 False。


Position 属性 (MSChart)

返回对 SeriesPosition 对象的引用，该对象描述与其它图表系列互相关联的系列的位置。

语法

object.Position

object 所在处是对象表达式，其值是“应用于”列表中的对象。


Projection 属性

返回或设置用来显示图表的投影类型。

语法

object.Projection [ = type]

Projection 属性的语法包含下面部分：

部分 | 描述
object | 对象表达式，其值是“应用于”列表中的对象。
type | 整数。是描述图表投影类型的 VtProjectionType 常数。

说明

Projection 属性决定三维图表的外观。


Projection 属性示例

本例使您能够观察到通过设置 Projection 属性而得到的效果。要试验该例，在一个窗体中绘制一个 MSChart 和 ComboBox 控件。粘贴下面的代码到“声明”部分，然后单击 F5。单击 ComboBox 以查看不同的设置值。

Option Explicit

Private Sub Combo1_Click()
   ' 单击以改变投影。
   MSChart1.Plot.Projection = Combo1.ListIndex
End Sub

Private Sub Form_Load()
   ' 设置图表为立体的。
   MSChart1.chartType = VtChChartType3dBar
   ' 通过添加有效的设置值配置 ComboBox。
   With Combo1
      .AddItem "VtProjectionTypePerspective" ' 0
      .AddItem "VtProjectionTypeOblique"      ' 1
      .AddItem "VtProjectionTypeOrthogonal"  ' 2
      .AddItem "VtProjectionTypeFrontal"      ' 3
      .AddItem "VtProjectionTypeOverhead"    ' 4
      .ListIndex = 0
   End With
End Sub


RandomFill 属性

该属性指定是否随机产生图表数据网格的数据。

语法

object.RandomFill [ = boolean]

RandomFill 属性的语法包含下面部分：

部分 | 描述
object | 对象表达式，其值是“应用于”列表中的对象。
boolean | 布尔表达式，该表达式决定数据的产生方式，如“设置值”中所描述。

设置值

boolean 的设置值如下：

设置 | 描述
True | (缺省)使用随机数来绘制图表。
False | 不产生随机数。由用户提供图表所需的数据。


Rect 属性

返回对 Rect 对象的引用，该对象定义坐标点。

语法

object.Rect

object 所在处是对象表达式，其值是“应用于”列表中的对象。


Red 属性

返回或设置图表的 RGB 值的红色部分。

语法

object.Red [=r]

Red 属性的语法包含下面部分：

部分 | 描述
object | 对象表达式，其值是“应用于”列表中的对象。
r | Integer。红色值。

说明

RGB 值说明了所显示的颜色红，绿，蓝三个分量之间的相对强度。正常 RGB 颜色的有效范围是 0 到 16,777,215。任何超过 255 的 RGB 分量值均按 255 处理。


Repaint 属性

返回或设置值，该值决定图表被改变后是否重绘 MSChart 控件。

语法

object.Repaint [ = boolean]

Repaint 属性的语法包含下面部分：

部分 | 描述
object | 对象表达式，其值是“应用于”列表中的对象。
boolean | 布尔表达式，该表达式决定是否重绘该图表，如“设置值”中所描述。

设置值

boolean 的设置值如下：

设置 | 描述
True | （缺省）刷新该控件。
False | 当图表被改变后，不允许重绘该控件。当要在图表上执行若干个操作，且不想让图表在此过程中连续重绘，则应选用这个值。


Rotation 属性

返回或设置一个值，该值指定三维图表的观察转角的度数。

语法

object.Rotation [ = degree]

Rotation 属性的语法包含下面部分：

部分 | 描述
object | 对象表达式，其值是“应用于”列表中的对象。
degree | Single。转角的度数。 从 0 至 360 度均为有效的旋转角度。旋转角的缺省单位是度。不过这取决于 AngleUnits 属性的当前设置值。其它的选项为：梯度以及弧度。


RowCount 属性 (MSChart)

返回或设置与图表关联的数据网格每一列的行数。

语法

object.RowCount [ = count]

RowCount 属性的语法包含下面部分：

部分 | 描述
Object | 对象表达式，其值是“应用于”列表中的对象。
Count | Integer。列的行数。

说明

虚拟数据网格由 DataGrid 对象表示。


RowLabelCount 属性

返回或设置与图表关联的数据网格行标签的级别数。

语法

object.RowLabelCount [ = count ]

RowLabelCount 属性的语法包含下面部分：

部分 | 描述
object | 对象表达式，其值是“应用于”列表中的对象。
count | Integer。标签级别数。通过设置该属性来添加或减少数据网格的行标签级别。行标签的级别从 1 开始，从右往左进行编号。标签的添加或减少均在左边进行。


RowLabelIndex 属性

返回或设置描述行标签级别的值。

语法

object.RowLabelIndex [ = index]

RowLabelIndex 属性的语法包含下面部分：

部分 | 描述
object | 对象表达式，其值是“应用于”列表中的对象。
index | Integer。行标签级别。要给具有多级标签的行设置标签，或返回标签的当前值，必须先指定是对哪一级进行操作。行标签从右至左进行编号，编号从 1 开始。


RowLabel 属性 (MSChart)

返回或设置一个数据标签，该标签用来标识图表中的当前数据点。

语法

object.RowLabel [ = text]

RowLabel 属性的语法包含下面部分：

部分 | 描述
object | 对象表达式，其值是“应用于”列表中的对象。
text | String 类型。行标签的文本。用所指定的标签来设置由 Row 属性标识的数据点的标签。对绝大多数图表类型而言，标签沿分类坐标轴分布，但在饼图图表中把标签作为每个独立饼图的标签。如果标签的文本太长，无法在图表中放置，可以不显示该标签。


RowLabel 属性 (DataGrid)

返回或设置与图表关联的当前数据网格中的特定行标签。

语法

object.RowLabel ( row, labelIndex ) [ = text ]

RowLabel 属性的语法包含下面部分：

部分 | 描述
object | 对象表达式，其值是“应用于”列表中的对象。
row | Integer。指定行。行从 1 开始、由顶端向底端依次编号。
labelIndex | Integer。指定特定的行标签级别。行标签从 1 开始、由顶端向底端依次编号。
Text | 字符串。行标签的文本。


Row 属性 (MSChart)

返回或设置与图表关联的数据网格中当前列的指定行。

语法

object.Row [ = num]

Row 属性的语法包含下面部分：

部分 | 描述
object | 对象表达式，其值是“应用于”列表中的对象。
num | Integer。当前列的行号。行的编号按从上至下的顺序，从 1 开始。


SecondaryAxis 属性

返回或设置值，这个值决定是否在次坐标轴绘制该系列。

语法

object.SecondaryAxis [ = boolean]

SecondaryAxis 属性的语法包含下面部分：

部分 | 描述
object | 对象表达式，其值是“应用于”列表中的对象。
boolean | 布尔表达式，该表达式决定是否在次坐标轴绘制该系列，如“设置值”中所描述。

设置值

boolean 的设置值如下：

设置 | 描述
True | 在次坐标轴绘制该系列。
False | （缺省）不在次坐标轴绘制该系列。


SeriesCollection 属性

返回 SeriesCollection 集合的引用，它提供构成图表系列的信息。

语法

object.SeriesCollection

object 所在处代表对象表达式，其值是“应用于”列表中的对象。


SeriesColumn 属性

返回或设置当前系列数据列位置。

语法

object.SeriesColumn [ = pos]

SeriesColumn 属性的语法包含下面部分：

部分 | 描述
object | 对象表达式，其值是“应用于”列表中的对象。
pos | Integer。表示当前系列的列位置。可以使用这个属性对系列重新排序。如果两个系列被指定到同一位置，就形成叠放。


SeriesMarker 属性

返回对 SeriesMarker 对象的引用，该对象描述标识图表系列中的所有数据点的标记。

语法

object.SeriesMarker

object 所在处是对象表达式，其值是“应用于”列表中的对象。


SeriesType 属性

返回或设置用于显示当前系列的类型。

语法

object.SeriesType [ = type]

SeriesType 属性的语法包含下面部分：

部分 | 描述
object | 对象表达式，其值是“应用于”列表中的对象。
type | Integer。是 VtChSeriesType 常数，描述用于显示该系列的方法。在使用 SeriesType 属性之前必须使用 Column 属性来选择相应的系列。


Shadow 属性

返回对 Shadow 对象的引用，该对象描述图表元素的阴影样式。

语法

object.Shadow

object 所在处是对象表达式，其值是“应用于”列表中的对象。


ShowGuideLine 属性

返回或设置决定是否将图表中的数据点连接成直线，以作为一个系列显示。

语法

object.ShowGuideLines (axisId, index) [ = boolean ]

ShowGuideLine 属性的语法包含下面部分：

部分 | 描述
object | 对象表达式，其值是“应用于”列表中的对象。
axisId | Integer。是 VtChAxisId 常数，描述要设置该属性的系列坐标轴。
index | Integer。保留供以后使用。对 MSChart 控件目前的这个版本，只有 1 是有效的参数值。
boolean | 布尔表达式，该表达式决定是否在次坐标轴绘制该系列，如“设置值”中所描述。

设置值

其中 boolean 的设置值如下：

设置 | 描述
True | 显示系列的引导线。
False | （缺省）不显示系列的引导线。


ShowLegend 属性

返回或设置一个决定图表的图例是否可见的值。

语法

object.ShowLegend [ = boolean]

ShowLegend 属性的语法包含下面部分：

部分 | 描述
object | 对象表达式，其值是“应用于”列表中的对象。
boolean | 布尔表达式，该表达式决定是否显示图表的图例，如“设置值”中所描述。

设置值

boolean 的设置值如下：

设置 | 描述
True | 在 Location 对象指定的位置显示图表的图例。
False | (缺省)不显示图表的图例。缺省图例位置是图表的右边。

说明

缺省图例位置是图表的右边。


ShowLine 属性

返回或设置值，这个值决定是否显示图表中连接数据点的连线。

语法

object.ShowLine [ = boolean]

ShowLine 属性的语法包含下面部分：

部分 | 描述
object | 对象表达式，其值是“应用于”列表中的对象。
boolean | 布尔表达式，该表达式决定是否显示连线，如“设置值”中所描述。

设置值

boolean 的设置值如下：

设置 | 描述
True | （缺省）在图表中显示数据点的连线。
False | 不显示数据点的连线。


Show 属性

返回或设置一个值，该值决定是否在图表上显示系列的标记。

语法

object.Show [ = boolean]

Show 属性的语法包含下面部分：

部分 | 描述
object | 对象表达式，其值是“应用于”列表中的对象。
boolean | 布尔表达式，该表达式决定是否显示系列的标记，如“设置值”中所描述。

设置值

boolean 的设置值如下：

设置 | 描述
True | 显示系列标记。
False | （缺省）不显示系列标记。


Size 属性 (MSChart)

返回或设置以磅为单位的图表元素大小。

语法

object.Size [ = size]

Size 属性的语法包含下面部分：

部分 | 描述
object | 对象表达式，其值是“应用于”列表中的对象。
size | Single。以磅为单位的图表元素大小。


Sort 属性 (MSChart)

返回或设置饼图图表的排序类型。

语法

object.Sort [ = type]

Sort 属性的语法包含下面部分：

部分 | 描述
object | 对象表达式，其值是“应用于”列表中的对象。
type | 整数。是描述绘图区排序方式的 VtSortType 常数。


SpaceColor 属性

返回对 VtColor 对象的引用，该对象指定填充环绕图表元素的双框间的空白所用的颜色。

语法

object.SpaceColor

object 所在处是对象表达式，其值是“应用于”列表中的对象。


Stacking 属性

设置一个决定图表的所有系列是否叠加放置的值。

语法

object.Stacking [ = boolean]

Stacking 属性的语法包含下面部分：

部分 | 描述
object | 对象表达式，其值是“应用于”列表中的对象。
boolean | 布尔表达式，该表达式决定是否将所有图表系列叠加放置，如“设置值”中所描述。

设置值

boolean 的设置值如下：

设置 | 描述
True | 将图表的所有系列叠加放置。
False | （缺省）图表的系列不采用叠放方式。


StackOrder 属性

若当前系列与其它系列叠放在一起，则用该属性返回或设置当前系列显示的位置。

语法

object.StackOrder [ = position]

StackOrder 属性的语法包含下面部分：

部分 | 描述
object | 对象表达式，其值是“应用于”列表中的对象。
position | Integer。与其它系列一起叠放的序号。叠放序号较小的在底部。


Standing 属性

返回或设置一个数值，它指定是在 x 平面或 z 平面中水平显示坐标轴标签，还是在 y 平面文本基线位置垂直显示坐标轴标签。

语法

object.Standing [ = boolean ]

Standing 属性的语法包含下面部分：

部分 | 描述
object | 对象表达式，其值是“应用于”列表中的对象。
boolean | 布尔表达式，它指定如何显示坐标轴标签，如“设置值”中所描述。

设置值

boolean 的设置值为：

设置值 | 描述
True | 在 y 平面文本基线位置垂直显示坐标轴标签。
False | （缺省）在 x 平面或 z 平面水平显示坐标轴标签。


StartingAngle 属性

返回或设置饼图图表的起始绘制位置。

语法

object.StartingAngle [ = angle]

StartingAngle 属性的语法包含下面部分：

部分 | 描述
object | 对象表达式，其值是“应用于”列表中的对象。
Angle | 单精度值。该角度的单位可以为度、弧度、或梯度，取决于 AngleUnits 的当前设置。值为 0 则表示从 3 点钟的位置开始。起始角设为 90 度时，若 Clockwise 属性为逆时针方向，则起始位置就是 12 点钟的位置，若是顺时针方向，则起始位置就是 6 点钟的位置。有效值的范围是 -360 至 360 度。


StatLine 属性

返回对 StatLine 对象的引用，该对象描述如何在图表中显示统计线。

语法

object.StatLine

object 所在处是对象表达式，其值是“应用于”列表中的对象。


Style 属性 (MSChart)

返回或设置用来绘制特定图表元素的风格。

语法

object.Style [=style]

Style 属性的语法包含下面部分：

部分 | 描述
object | 对象表达式，其值是“应用于”列表中的对象。
style | 对于 Brush 对象，VtBrushStyle 常数描述画笔图案。 对于 Fill 对象，VtFillStyle 常数描述填充风格。一个填充可以具有一个画笔，该画笔可以是纯色或图案填充。 对于 Frame 对象，VtFrameStyle 常数描述框架的类型。 对于 Marker 对象，VtMarkerStyle 常数列出标记的类型。 对于 Pen 对象，VtPenStyle常数描述笔的样式。 对于 Shadow 对象，VtShadowStyle 常数描述阴影类型。 对于 Tick 对象，VtChAxisTickStyle 常数用来描述坐标轴刻度标记位置。 对于 VtFont 对象，VtFontStyle 常数描述字体的风格。 对于 Weighting 对象，VtChPieWeightStyle 常数标识加权因数方法。


Style 属性 (StatLine)

返回或设置用于显示统计线的线型。

语法

object.Style (type )[ = style]

Style 属性的语法包含下面部分：

部分 | 描述
object | 对象表达式，其值是“应用于”列表中的对象。
type | Integer。是用于描述统计线类型的 VtChStats 常数。
style | Integer。是描述统计线样式的 VtPenStyle 常数。


SubPlotLabelPosition 属性

返回或设置用来显示图表中每个饼图标签的位置。

语法

object.SubPlotLabelPosition [ = pos]

SubPlotLabelPosition 属性的语法包含下面部分：

部分 | 描述
object | 对象表达式，其值是“应用于”列表中的对象。
pos | 整数。是用来描述图表标签的位置的 VtChSubPlotLabelLocationType 常数。


TextLayout 属性

返回对 TextLayout 对象的引用，该对象描述文本的位置及方向。

语法

object.TextLayout

object 所在处是对象表达式，其值是“应用于”列表中的对象。


TextLength 属性

返回或设置图表坐标轴标题、数据点标签、脚注或者图表标题的文本中的字符数。

语法

object.TextLength [ = size]

TextLength 属性的语法包含下面部分：

部分 | 描述
object | 对象表达式，其值是“应用于”列表中的对象。
size | Integer。它指定文本中的字符数。


TextLengthType 属性

返回或设置一个值，该值指定文本的显示方式如何优化文本在屏幕或打印机上的输出效果。

语法

object.TextLengthType [ = type]

TextLengthType 属性的语法包含下面部分：

部分 | 描述
object | 对象表达式，其值是“应用于”列表中的对象。
type | Integer。是指示文本显示方式的 VtTextLengthType 常数。


Text 属性 (MSChart)

返回或设置用于显示图表元素（例如坐标轴标题、数据点标签、脚注或图表标题）的文本。

语法

object.Text [ = text ]

Text 属性的语法包含下面部分：

部分 | 描述
object | 对象表达式，其值是“应用于”列表中的对象。
text | 字符串。它包含图表元素使用的文本。

说明

Text 属性是具有该属性的对象的缺省属性。


Tick Property

Returns a reference to a Tick object that describes a marker indicating a division along a chart axis.

Syntax

object.Tick

The object placeholder represents an object expression that evaluates to an object in the Applies To list.


Title 属性 (MSChart)

对 Title 对象的引用，该对象描述图表的标题文本。

语法

object.Title

object 所在处是对象表达式，其值是“应用于”列表中的对象。


TitleText 属性

返回或设置作为图表标题而显示的文本。

语法

object.TitleText [ = text]

TitleText 属性的语法包含下面部分：

部分 | 描述
object | 对象表达式，其值是“应用于”列表中的对象。
text | 用于显示图表标题的文本。

说明

该属性提供了一个设置或返回图表标题的简单办法。该属性的作用相当于使用 MSChart.Title.Text。


Type 属性 (MSChart)

返回或设置坐标轴的刻度类型。

语法

object.Type [ = type]

Type 属性的语法包含下面部分：

部分 | 描述
object | 对象表达式，其值是“应用于”列表中的对象。
type | 描述坐标轴刻度类型的VtChScaleType 常数。


UniformAxis 属性

返回或设置一个值，该值指定图表的所有值坐标轴的单位刻度是否一致。

语法

object.UniformAxis [ = boolean]

UniformAxis 属性的语法包含下面部分：

部分 | 描述
object | 对象表达式，其值是“应用于”列表中的对象。
Boolean | 布尔表达式，该表达式控制单位刻度，如“设置值”中所描述。

设置值

boolean 的设置值如下：

设置 | 描述
True | （缺省）所有值坐标轴的单位刻度都一致。
False | 单位刻度不一致。根据 AutoLayout或 LocationRect 属性设置的绘图区大小及位置来确定单位刻度。如果 AutoLayout 为 True，则绘图区大小及位置取决于其它自动布局的元素的大小及位置。如果 AutoLayout 为 False，则由 LocationRect 属性指定的坐标来确定绘图区的位置以及坐标轴的单位刻度。


ValueFormat 属性

返回或设置用来将标签显示为数值的格式。

语法

object.ValueFormat [ = format]

ValueFormat 属性的语法包含下面部分：

部分 | 描述
object | 对象表达式，其值是“应用于”列表中的对象。
format | 字符串。描述用来将标签显示为数值。

说明

请用 DataPointLabel 对象的 Component 属性变更标签的类型。


ValueScale 属性

返回对 ValueScale 对象的引用，该对象描述坐标轴上显示数值所用的刻度。

语法

object.ValueScale

object 所在处是对象表达式，其值是“应用于”列表中的对象。


VertAlignment 属性

返回或设置文本的垂直对齐方式。

语法

object.VertAlignment [ = type]

VertAlignment 属性的语法包含下面部分：

部分 | 描述
object | 对象表达式，其值是“应用于”列表中的对象。
type | Integer。是用于描述文本垂直对齐方式的 VtVerticalAlignment 常数。


View3D 属性

返回对 View3D 对象的引用，该对象描述三维图表的实际方向。

语法

object.View3D

object 所在处是对象表达式，其值是“应用于”列表中的对象。


Visible 属性 (MSChart)

返回或设置一个值，它判断是否显示图表元素。

语法

object.Visible [ = boolean]

Visible 属性的语法包含下面部分：

部分 | 描述
object | 对象表达式，其值是“应用于”列表中的对象。
boolean | 布尔表达式，它指定是否显示项目，如“设置值”中所描述。

设置值

boolean 的设置值为：

设置值 | 描述
True | 显示图表、坐标轴标题、标签或标记。
False | 隐藏图表元素。


VtColor 属性

返回对 VtColor 对象的引用，该对象描述图表中绘图所用的颜色。

语法

object.VtColor

object 所在处是对象表达式，其值是“应用于”列表中的对象。


VtFont 属性

返回对 VtFont 对象的引用，该对象描述用于显示图表文本的字体。

语法

object.VtFont

object 所在处对应对象表达式，该表达式的值是“应用于”列表中的对象。


Wall 属性

返回对 Wall 对象的引用，该对象描述三维图表中 y 坐标轴所在的平面区域。

语法

object.Wall

object 所在处是对象表达式，其值是“应用于”列表中的对象。


Weighting 属性

返回对 Weighting 对象的引用，该对象描述了在同一图表中与其它饼图相互关联的饼图的大小。

语法

object.Weighting

object 所在处是对象表达式，其值是“应用于”列表中的对象。


Width 属性 (MSChart)

返回或设置以磅为单位的图表元素宽度。

语法

object.Width [ = width]

Width 属性的语法包含下面部分：

部分 | 描述
object | 对象表达式，其值是“应用于”列表中的对象。
width | Single。图表元素的宽度。


WidthToHeightRatio 属性

返回或设置图表宽度与高度的百分比。

语法

object.WidthToHeightRatio [ = pctg]

WidthToHeightRatio 属性的语法包含下面部分：

部分 | 描述
object | 对象表达式，其值是“应用于”列表中的对象。
pctg | Single。图表高度的百分比。


WordWrap 属性 (MSChart)

返回或设置一个决定文本是否回绕的值。

语法

object.WordWrap [ = boolean ]

The WordWrap 属性的语法包含下面部分：

部分 | 描述
object | 对象表达式，其值是“应用于”列表中的对象。
boolean | 布尔表达式，该表达式决定文本是否回绕，如“设置值”中所描述。

设置值

boolean 的设置值如下：

设置 | 描述
True | 文本回绕。
False | （缺省）文本不回绕。


XGap 属性

返回或设置 x 轴上相邻条之间的间隔。该间隔用条宽度的百分比表示。

语法

object.xGap [ = spacing]

xGap 属性的语法包含下面部分：

部分 | 描述
object | 对象表达式，其值是“应用于”列表中的对象。
spacing | Single。条宽度的百分比。如果值为 0 则该系列的条是紧挨着的。


X 属性

返回或设置图表浮点坐标对中的 x 数值。

语法

object.X [ = x ]

X 属性的语法包含下面部分：

部分 | 描述
object | 对象表达式，其值是“应用于”列表中的对象。
x | Single。（对于 LCoor 对象，该参数是长整型）标识坐标的 x 数值。


Y 属性

返回或设置图表浮点坐标对中的 y 数值。

语法

object.Y [ = y ]

Y 属性的语法包含下面部分：

部分 | 描述
object | 对象表达式，其值是“应用于”列表中的对象。
y | Single。（对于 LCoor 对象，该参数是长整型）标识坐标的 y 数值。


ZGap 属性

返回或设置三维图表中 z 轴上相邻条之间的间隔。该间隔用条深度的百分比表示。

语法

object.zGap [ = spacing]

zGap 属性的语法包含下面部分：

部分 | 描述
object | 对象表达式，其值是“应用于”列表中的对象。
spacing | Single。条深度的百分比。如果值为 0 则该系列的条形图沿 z 轴方向是紧挨着的。


Z 属性

返回或设置坐标点的 z 值。

语法

object.Z [ = z ]

Z 属性的语法包含下面部分：

部分 | 描述
object | 对象表达式，其值是“应用于”列表中的对象。
z | Single。（若是 Lcoor 对象则这部分为 Long 类型）。标识坐标的 z 值。